usbprinter.device problem if printer not turned on

A forum for general AmigaOS 4.x support questions that are not platform-specific
xenic
Posts: 1171
Joined: Sun Jun 19, 2011 12:06 am

usbprinter.device problem if printer not turned on

Post by xenic »

Some word processing programs open the printer.device to access the current settings when they start. usbprinter.device throws up requesters (& Ringhio notifications) if the device is opened with the printer off. If I attempt to change the device from usbprinter.device to printer.device in printer prefs I get requesters (& Ringhio notifications) telling me that USB printer is not available. Why does it need to tell me that USB printer is unavailable if I am changing "from" usbprinter.device "to" printer.device? It also doesn't appear to be possible to select usbprinter.device if the printer is not connected and turned on. I think a program should be able to open usbprinter.device to access the current system printer prefs without requesters and notifications. This problem is with usbprinter.device 53.2. I reverted to usbprinter.device 52.8 which works more like the normal printer.device. I also think it would be nice to have an option to disable Ringhio notifications for usbprinter.device since it seems that Ringhio somehow seems to prevent screen closing sometimes.

System: SAM Flex 800 with OS 4.2
EDIT: Sorry, that's OS4.1u2
Last edited by xenic on Fri Jul 29, 2011 2:56 pm, edited 1 time in total.
AmigaOne X1000 with 2GB memory - OS4.1 FE
User avatar
nexus
Beta Tester
Beta Tester
Posts: 347
Joined: Mon Dec 20, 2010 2:11 pm
Location: Germany

Re: usbprinter.device problem if printer not turned on

Post by nexus »

xenic wrote: System: SAM Flex 800 with OS 4.2
:o
:shock:
xenic
Posts: 1171
Joined: Sun Jun 19, 2011 12:06 am

Re: usbprinter.device problem if printer not turned on

Post by xenic »

nexus wrote:
xenic wrote: System: SAM Flex 800 with OS 4.2
:o
:shock:
Yes. It's actually OS 4.1 update 2. Just wishful thinking I suppose.
AmigaOne X1000 with 2GB memory - OS4.1 FE
User avatar
Hypex
Beta Tester
Beta Tester
Posts: 444
Joined: Mon Dec 20, 2010 2:23 pm
Location: Vic. Australia.

Re: usbprinter.device problem if printer not turned on

Post by Hypex »

This really annoys me as well. I don't know why they changed it to ask the user to press 10 buttons in a row if the printer is missing. So what!

I also tried the trick adding the printer USB vendor and model ID but that didn't work. Took me a few minutes to work out which device was my printer from the USB log. But the requesters still came up! Be a lot easier if they provided a GUI for this so it gets the ID for you and saves it. AmigaOS4 is too old to expect the user to fiddle with the CLI!

But it's not limited to programs that can print. It's every program that goes through the device list! For example I like to use DiskMonTools. But I have to get past about 16 requesters when ever it examines the device list! Argh!!!

It better be fixed by the time I finish this sentence. ;-)
xenic
Posts: 1171
Joined: Sun Jun 19, 2011 12:06 am

Re: usbprinter.device problem if printer not turned on

Post by xenic »

Hypex wrote:It better be fixed by the time I finish this sentence. ;-)
It would be nice if getting things fixed was as simple as demanding that it happen :-) When these forums started, I sort of expected that bugs and problems would be acknowledged in some way. It would be nice to hear something like: "Added to bug list" - "Will be fixed" - "Can't reproduce" - "Not a bug" - "Won't be fixed" etc.etc. This report and a number of others just sit here unresponded like they did at Amigans.net or AmigaWorld.net. At least the previous version of usbprinter.device works and can be reinstalled as a workaround.
AmigaOne X1000 with 2GB memory - OS4.1 FE
User avatar
nbache
Beta Tester
Beta Tester
Posts: 1568
Joined: Mon Dec 20, 2010 7:25 pm
Location: Copenhagen, Denmark
Contact:

Re: usbprinter.device problem if printer not turned on

Post by nbache »

xenic wrote:
Hypex wrote:It better be fixed by the time I finish this sentence. ;-)
It would be nice if getting things fixed was as simple as demanding that it happen :-) When these forums started, I sort of expected that bugs and problems would be acknowledged in some way. It would be nice to hear something like: "Added to bug list" - "Will be fixed" - "Can't reproduce" - "Not a bug" - "Won't be fixed" etc.etc. This report and a number of others just sit here unresponded like they did at Amigans.net or AmigaWorld.net. At least the previous version of usbprinter.device works and can be reinstalled as a workaround.
This sort of feedback is actually often given in these forums. But for any given bug, it requires at least one beta tester (or developer with time on his hands), who has the necessary hardware and/or software, to try to recreate the problem on his own system, create logs or other supporting material, and then report the bug. In this case, apparently, no beta tester with either suitable hardware/software or time has seen your thread yet and/or had time to test and report it.

Best regards,

Niels
User avatar
broadblues
AmigaOS Core Developer
AmigaOS Core Developer
Posts: 594
Joined: Sat Jun 18, 2011 2:40 am
Location: Portsmouth, UK
Contact:

Re: usbprinter.device problem if printer not turned on

Post by broadblues »

Some word processing program
Which word processing program? No one has time to install random software to see if that was the program that caused the bug to appear.

I can't replicate your issues here.

BTW you cannot change to printer.device at all it must be a parrallel or serial device of some kind. Assuming that you are talking about the device setting in Printer Prefs.
User avatar
Hypex
Beta Tester
Beta Tester
Posts: 444
Joined: Mon Dec 20, 2010 2:23 pm
Location: Vic. Australia.

Re: usbprinter.device problem if printer not turned on

Post by Hypex »

This issue is very easy to reproduce I find and have seen it mentiioned a lot in other places.

It requires the following:
1.) A USB printer that is set up to print with in Preferences.
2.) The printer to be turned off.

How to reproduce?
Run Media Toolbox and enjoy dealing with the requester onslaught! :-P
User avatar
broadblues
AmigaOS Core Developer
AmigaOS Core Developer
Posts: 594
Joined: Sat Jun 18, 2011 2:40 am
Location: Portsmouth, UK
Contact:

Re: usbprinter.device problem if printer not turned on

Post by broadblues »

I have my hp815c connected via usb and set as printer in printer prefs via usbprinter.device

It's switched off

I start media tool box

Nothing untoward happens. No requesters, no ringhio notifications.

Either this is abug that's fixed (no promises I haven't searched bugzila / release notes for it yet) or there is another step required.

NB in my case I'm working on a Sam Flex 733
User avatar
Hypex
Beta Tester
Beta Tester
Posts: 444
Joined: Mon Dec 20, 2010 2:23 pm
Location: Vic. Australia.

Re: usbprinter.device problem if printer not turned on

Post by Hypex »

I just tested again. I have a HP C4180 connected to my USB and also turned off.

I tried Partition Wizard. One notification came up and disappered.

I tested MTB again. Yep! At least eight notifications and requesters requring me to click a gadget came up.

This tool is also a good one to test as it's very anoying to use here:
http://aminet.net/package/disk/moni/DiskMonTools

I take it you don't have your printer ID set for USB printer device?

Thanks for testing. :-)
Post Reply