Problem with Catweasel driver

A forum for general AmigaOS 4.x support questions that are not platform-specific
Post Reply
User avatar
samo79
Posts: 557
Joined: Fri Jun 17, 2011 11:13 pm
Location: Italy

Problem with Catweasel driver

Post by samo79 »

Since Update 5 we have this new driver onboard by default and this is cool but i need to disabled it completely from my AmigaInput preferences because it crash badly any time i try to start some games/emulators that have a proper Joypad settings already configured (for example GnGeo)

I don't have any Catweasel hardware on my Sam440 so maybe this is the real cause of the crash, but it shouldn't i think .. if one didn't have any hardware suppoted by this driver would be better to just skip, not a crash :-)

Anyone with the same problem ?
If so, maybe someone can open a new report/ticket for that ?
zzd10h
Posts: 546
Joined: Sun Sep 16, 2012 5:40 am
Location: France

Re: Problem with Catweasel driver

Post by zzd10h »

Just to say that I had exactly the same problem since update5 with UAE.

Crash log for task "Work:Emu/E-UAE_0.8.29-WIP4+_SDL/uae"
Generated by GrimReaper 53.5
Crash occured in module PCI_CatweaselJoystick.driver at address 0x7F463320
Type of crash: DSI (Data Storage Interrupt) exception

Under update4, my USB pad worked like a charm under UAE and since the update5 GrimReaper
each time relating to the catweasel driver.

Since I disabled it on AmigaInput it works great.
http://apps.amistore.net/zTools
X1000 - AmigaOS 4.1.6 / 4.1 FE
User avatar
samo79
Posts: 557
Joined: Fri Jun 17, 2011 11:13 pm
Location: Italy

Re: Problem with Catweasel driver

Post by samo79 »

Hi Guillaume, thanks to confirm the problem ;)
Do you have a Pegasos 2 right ?
zzd10h
Posts: 546
Joined: Sun Sep 16, 2012 5:40 am
Location: France

Re: Problem with Catweasel driver

Post by zzd10h »

Hello Samir,
Yes I have a Pegasos 2.
You think that it can have an impact on catweasel driver ?
http://apps.amistore.net/zTools
X1000 - AmigaOS 4.1.6 / 4.1 FE
User avatar
samo79
Posts: 557
Joined: Fri Jun 17, 2011 11:13 pm
Location: Italy

Re: Problem with Catweasel driver

Post by samo79 »

No in this case i don't think so, however sometimes the OS can react different depending on the hardware used, look for example at our recent discussion about SysMon and AmiDock
User avatar
nubechecorre
Posts: 69
Joined: Fri Jun 17, 2011 11:28 pm
Location: Sanremo
Contact:

Re: Problem with Catweasel driver

Post by nubechecorre »

same problem here with the sam mini-itx.. I also tried to remove the catweasel driver from devs/dosdriver but nothing changed..
http://www.os4games.it

Sam440ep mini-itx

Classic System:

Amiga 1200
PowerPC 603+ 68040 25 Mhz + 256MbRam
Radeon 9250 128Mb VRam
Voodoo 3 3000 16Mb VRam
HD-Western Digital Caviar Blue 500 Gb PATA
DVD-RW LG Dual Layer
SoundBlaster PCI 128
4xEIDE Buffered Interface Elbox
Cocolino Interface Elbox
AmigaOne White Mouse
Spectre660
Posts: 1505
Joined: Sat Jun 18, 2011 2:16 pm
Location: Montserrat

Re: Problem with Catweasel driver

Post by Spectre660 »

You need to move
PCI_CatweaselJoystick.driver
from
Libs:AmigaInput
nubechecorre wrote:same problem here with the sam mini-itx.. I also tried to remove the catweasel driver from devs/dosdriver but nothing changed..
Sam460ex : Radeon Rx550 Single slot Video Card : SIL3112 SATA card
User avatar
nubechecorre
Posts: 69
Joined: Fri Jun 17, 2011 11:28 pm
Location: Sanremo
Contact:

Re: Problem with Catweasel driver

Post by nubechecorre »

@Spectre660

Thanks :-)
http://www.os4games.it

Sam440ep mini-itx

Classic System:

Amiga 1200
PowerPC 603+ 68040 25 Mhz + 256MbRam
Radeon 9250 128Mb VRam
Voodoo 3 3000 16Mb VRam
HD-Western Digital Caviar Blue 500 Gb PATA
DVD-RW LG Dual Layer
SoundBlaster PCI 128
4xEIDE Buffered Interface Elbox
Cocolino Interface Elbox
AmigaOne White Mouse
User avatar
ChrisH
Beta Tester
Beta Tester
Posts: 920
Joined: Mon Dec 20, 2010 9:09 pm
Contact:

Re: Problem with Catweasel driver

Post by ChrisH »

Just to let you guys know that this problem was reported to the Catweasel driver author a while ago.
User avatar
samo79
Posts: 557
Joined: Fri Jun 17, 2011 11:13 pm
Location: Italy

Re: Problem with Catweasel driver

Post by samo79 »

ChrisH wrote:Just to let you guys know that this problem was reported to the Catweasel driver author a while ago.
:-)
Post Reply