PlayCD changes

A forum for general AmigaOS 4.x support questions that are not platform-specific
Post Reply
xenic
Posts: 1165
Joined: Sun Jun 19, 2011 12:06 am

PlayCD changes

Post by xenic »

I find it somewhat irritating that I had to find out in an X1000 forum topic that a new PlayCD option enables playback through AHI instead of the old method of sending the audio directly from a CDROM drive to a motherboard or soundcard through a wired connection. I've suffered through several unnesessary "PlayCDDA" system freezes since Update4 was released because I wasn't aware that PlayCD could be used instead. Previously, I didn't pay much attention to kas1e's complaints about the lack of detail in changes listed for updates etc. Now I think he has a point. The new PlayCD "USEAHI " TOOLTYPE isn't listed in the changes for Update4 and apparently there was no new icon with the option listed in the TOOLTYPES. Also, the PlayCD documentation wasn't updated to list the new option.

Reguest:
Add a new icon for PlayCD that shows the USEAHI tooltype as an option; even if not enabled (USEAHI).
Update the PlayCD docs to include the USEAHI TOOLTYPE.
In the future please mention changes that enable new functionality in system commands & utilities.
AmigaOne X1000 with 2GB memory - OS4.1 FE
User avatar
BillEaves
Beta Tester
Beta Tester
Posts: 202
Joined: Wed Dec 22, 2010 10:14 am
Location: Caithness, Scotland
Contact:

Re: PlayCD changes

Post by BillEaves »

Thanks for the info. I had vaguely heard that newer versions of PlayCD could use AHI but had no idea as to how to do it.

Using the USEAHI tooltype now :-)
User avatar
samo79
Posts: 555
Joined: Fri Jun 17, 2011 11:13 pm
Location: Italy

Re: PlayCD changes

Post by samo79 »

xenic wrote:Reguest:
Add a new icon for PlayCD that shows the USEAHI tooltype as an option; even if not enabled (USEAHI).
Update the PlayCD docs to include the USEAHI TOOLTYPE.
In the future please mention changes that enable new functionality in system commands & utilities.
That problem was already reported and (i presume) fixed, see this thread:

http://forum.hyperion-entertainment.biz ... f=14&t=793

I agree that docs must be always updated according to the changes, for example PlayCD in Update 4 was never mentioned on the included doc even if availible into the Update 4 archive (and updated)
User avatar
Hans
AmigaOS Core Developer
AmigaOS Core Developer
Posts: 703
Joined: Tue Dec 21, 2010 9:25 pm
Location: New Zealand
Contact:

Re: PlayCD changes

Post by Hans »

xenic wrote:I find it somewhat irritating that I had to find out in an X1000 forum topic that a new PlayCD option enables playback through AHI instead of the old method of sending the audio directly from a CDROM drive to a motherboard or soundcard through a wired connection. I've suffered through several unnesessary "PlayCDDA" system freezes since Update4 was released because I wasn't aware that PlayCD could be used instead. Previously, I didn't pay much attention to kas1e's complaints about the lack of detail in changes listed for updates etc. Now I think he has a point. The new PlayCD "USEAHI " TOOLTYPE isn't listed in the changes for Update4 and apparently there was no new icon with the option listed in the TOOLTYPES. Also, the PlayCD documentation wasn't updated to list the new option.

Reguest:
Add a new icon for PlayCD that shows the USEAHI tooltype as an option; even if not enabled (USEAHI).
Update the PlayCD docs to include the USEAHI TOOLTYPE.
In the future please mention changes that enable new functionality in system commands & utilities.
That must have been an accidental omission from the X1000 install CD, as my beta Sam460ex installation has both "(USEAHI)" in the tool-types (actually I enabled it so it is now "USEAHI"), and updated documentation which includes the USEAHI flag. Those items are indeed missing on my A1-X1000 installation. Sorry about that.

Hans
http://hdrlab.org.nz/ - Amiga OS 4 projects, programming articles and more. Home of the RadeonHD driver for Amiga OS 4.x project.
xenic
Posts: 1165
Joined: Sun Jun 19, 2011 12:06 am

Re: PlayCD changes

Post by xenic »

@Hans
It's only a minor irritation but I thought is was worth mentioning in order to get it fixed. Apparently I missed the topic that samo79 mentioned and didn't realize the problem was already reported and solved.
AmigaOne X1000 with 2GB memory - OS4.1 FE
xenic
Posts: 1165
Joined: Sun Jun 19, 2011 12:06 am

Re: PlayCD changes

Post by xenic »

Since the documentation problem has been reported I'd like to add a request. The CDDB data that is cached by PlayCD is missing the DYEAR and DGENRE keywords and data.

Request:
Add the DYEAR and DGENRE keywords and data to the cached CDDB data files.
AmigaOne X1000 with 2GB memory - OS4.1 FE
Post Reply