Search found 1071 matches

by tonyw
Sun Feb 23, 2020 5:09 am
Forum: Platform: AmigaOne X5000
Topic: Test request to all X5000 owners!
Replies: 29
Views: 8213

Re: Test request to all X5000 owners!

Thanks for that, Darren.

I've never heard it before, so maybe it was only mentioned in the Linux part of the world.

Now, the next question: how the hell do we program the EEPROM with the missing values?

I do wish we had some proper hardware documentation...
by tonyw
Thu Feb 20, 2020 10:44 pm
Forum: Platform: AmigaOne X5000
Topic: Test request to all X5000 owners!
Replies: 29
Views: 8213

Re: Test request to all X5000 owners!

OK Dave, I'm convinced. It must be just that version that you have (I have versions before and after your date).

PM me with your email address...
by tonyw
Thu Feb 20, 2020 12:31 am
Forum: Platform: AmigaOne X5000
Topic: Test request to all X5000 owners!
Replies: 29
Views: 8213

Re: Test request to all X5000 owners!

What is the version string (from SysInfo) of the naughty U-Boot? I ask because I have about four different versions of U-Boot here for X-5020 and 5040. None of them shows any problem with reading, writing, saving or repairing MAC addresses. My two latest versions are: "U-Boot molsen-2018-03-23&...
by tonyw
Tue Feb 18, 2020 10:46 am
Forum: General Developer Support
Topic: DMA cache issues on SAM440ep
Replies: 1
Views: 1408

Re: DMA cache issues on SAM440ep

I can't answer your question, but I have pointed it out to others more skilled in the art.
by tonyw
Mon Feb 17, 2020 11:12 pm
Forum: Platform: AmigaOne X5000
Topic: Test request to all X5000 owners!
Replies: 29
Views: 8213

Re: Test request to all X5000 owners!

@Skateman
At this moment everyone using an X5000 with the onboard nic and using OS4.1 FE is having the same MAC address!
True, but that's the fault of the driver, not the hardware or firmware. The Hyperion driver does not have that problem.
by tonyw
Sun Feb 16, 2020 10:38 am
Forum: Platform: AmigaOne X1000
Topic: eth3com.device crashes on X1000
Replies: 4
Views: 1693

Re: eth3com.device crashes on X1000

Short answer: No, there is only the one V53.x version. V53.3 was released in 2011 and no newer version has been released. No bug reports have been filed since 2006, the two from that year were both closed at the time. So your problem has not been reported before. Have you checked it with a clean sys...
by tonyw
Fri Feb 14, 2020 12:12 pm
Forum: Platform: AmigaOne X5000
Topic: Test request to all X5000 owners!
Replies: 29
Views: 8213

Re: Test request to all X5000 owners!

@Spectre660: Firstly, I don't remember an "issue" with MAC addresses in the past. Gregor's complaint is the only one I've heard and I haven't seen it confirmed by anyone else (Is Skateman confirming the problem?). Until this thread, I didn't even know that U-Boot regenerated the MAC addres...
by tonyw
Fri Feb 14, 2020 11:19 am
Forum: AmigaOS Feature Requests
Topic: Pivot monitor support on driver level?
Replies: 15
Views: 14475

Re: Pivot monitor support on driver level?

I don't pretend to be an Intuition or a Graphics expert, but as far as I can see, you can't change the width x height values of a screen. In order to change the aspect ratio of a display, you would have to close the screen and reopen it in the new width x height. Of course, you don't have to do that...
by tonyw
Thu Feb 13, 2020 10:08 pm
Forum: Platform: AmigaOne X5000
Topic: Test request to all X5000 owners!
Replies: 29
Views: 8213

Re: Test request to all X5000 owners!

If what Skateman says is true (that all later boards act this way), then I would prefer to fix the bug in U-Boot.

Unfortunately we don't yet have access to the U-Boot sources.
by tonyw
Mon Feb 03, 2020 11:06 pm
Forum: Platform: AmigaOne X5000
Topic: Restoring automatically ethernet MAC addresses
Replies: 14
Views: 3632

Re: Restoring automatically ethernet MAC addresses

No, forget that. You only need the RX, TX and ground. Nothing else is connected at the X5k end. RX from one end becomes TX at the other, so pins 2 & 3 are swapped in the cable. Pin 5 (ground) goes straight through. I would suggest that you use Term on the MicroA1, rather than on a Classic. U-Boo...