Search found 569 matches

by ssolie
Wed Jul 27, 2011 6:26 pm
Forum: General AmigaOS
Topic: List command show wrong file size
Replies: 5
Views: 2238

Re: List command show wrong file size

Rigo wrote:This has, AFAIK, already been reported and probably fixed.
I noticed that years ago when we first introduced 64 bit sizes into the system. I thought I even fixed it myself but I'll need to check my notes. :D
by ssolie
Wed Jul 27, 2011 5:39 pm
Forum: Platform: AmigaOne 500 and Sam series
Topic: Amiga OS 4.1 & FastFileSystem SFS/00
Replies: 13
Views: 12048

Re: Amiga OS 4.1 & FastFileSystem SFS/00

Only use 512 bytes. Anything else is not supported. When the author of the file system who wrote the code tells you not to use anything but 512 byte blocks you do it. Sorry, but this is *not* what the documentation of SFS says. 512 is recommended for a reason. Feel free to ignore me but I'll listen...
by ssolie
Tue Jul 26, 2011 7:12 pm
Forum: Platform: AmigaOne 500 and Sam series
Topic: Amiga OS 4.1 & FastFileSystem SFS/00
Replies: 13
Views: 12048

Re: Amiga OS 4.1 & FastFileSystem SFS/00

- Don't use blocksize more than 512 with SFS/00 or SFS/02 Why not? I'm using SFS/02 partitions with bigger block sizes since three years in daily usage without any problems. It was - btw - the default setting of my system builder (SAM440ep). Only use 512 bytes. Anything else is not supported. When ...
by ssolie
Tue Jul 26, 2011 7:08 pm
Forum: Platform: AmigaOne 500 and Sam series
Topic: sam460ex audio driver ??
Replies: 8
Views: 8943

Re: sam460ex audio driver ??

jacknife wrote:When will it be ?
It is being tested and will be released when ready.
by ssolie
Mon Jul 18, 2011 10:56 pm
Forum: Platform: AmigaOne 500 and Sam series
Topic: Which Uboot version are you using?
Replies: 3
Views: 3925

Re: Which Uboot version are you using?

alekc wrote:Since some Uboot updates are only "one-way" I wonder which Uboot version on SAMs are you using. For example I'm still running 1.3.1a but this is more lack of time result than anything else.
Given ACube are still actively supporting UBoot on their boards I don't see any problem with updating.
by ssolie
Mon Jul 11, 2011 5:58 pm
Forum: General AmigaOS
Topic: What I expect on Update3
Replies: 27
Views: 12329

Re: What I expect on Update3

O.K., here it is: The source file: overlay-bug.c The binary: overlay-bug The program opens a PIP window, renders a white background, then from left to right a black, a red, a green and a blue rectangle. But on update 1 + 2 the background is pink and the rectangles are dark green, dark red, light gr...
by ssolie
Fri Jul 08, 2011 7:40 pm
Forum: General AmigaOS
Topic: What I expect on Update3
Replies: 27
Views: 12329

Re: What I expect on Update3

Afterwards I write the gfx data in R5G6B5 format directly into the video memory. This worked in the first release of OS 4.1, but not in update 1 and 2. I can write an example program an post a link to it here - if it makes sense. Yes please! Just even a rectangle drawn into the PIP window would be ...
by ssolie
Fri Jul 08, 2011 4:30 pm
Forum: Platform: Pegasos II
Topic: Better Altivec support
Replies: 2
Views: 10457

Re: Better Altivec support

Is there any chance that in some future version of the system will be better support for the AltiVec unit (dytatypes, etc...)? I do not know how much it is difficult and I understand that the Pegasos is a minority platform, but it would be very nice ;) AmigaOS has a substantial amount of AltiVec co...
by ssolie
Thu Jul 07, 2011 3:55 pm
Forum: General AmigaOS
Topic: What I expect on Update3
Replies: 27
Views: 12329

Re: What I expect on Update3

I'm talking about db101, who Needs at least elf.library 53.13 (currently beta) to work (this is just a part of the better debug system). Also a new GDB version will also help a lot to locate efficiently DSI problems. I've worked with Alfkil on a few issues already. How do you think he got the beta ...
by ssolie
Thu Jul 07, 2011 3:52 pm
Forum: General AmigaOS
Topic: What I expect on Update3
Replies: 27
Views: 12329

Re: What I expect on Update3

I am not quite sure what you mean, AmiCygnix doesn't have anything to do with AmigaOS 4.x, it's a third party application/package (A good one, but hardly anything we can address with an update). There is some bug in the PIP support but CygnusEd (the author) has not yet managed to contact any of us ...