Search found 48 matches

by AlfredOne
Sun Aug 16, 2020 11:38 pm
Forum: Platform: AmigaOne X1000
Topic: Dual Display unstable on X1000
Replies: 9
Views: 8689

Re: Dual Display unstable on X1000

Hi all, I have Dopus launch on the older 4650 display and it seems OK. But, I get mirroring of 4650 on the other monitor sometimes, really slow mirroring. I get lock ups when switching between displays and screens. I can be on display 2 and click take cursor back to then main display. Instead of cur...
by AlfredOne
Mon Jun 15, 2020 8:01 am
Forum: General Developer Support
Topic: USB device with multiple interfaces
Replies: 2
Views: 305

Re: USB device with multiple interfaces

I observed this: 1) when i claim the Interface 0 and i request the HID Report Descriptor, i get an HID Report descriptor for a touchscreen with 10 touch points. 2) when i claim the Interface 1 and i request the HID Report Descriptor, i get an HID Report descriptor with only one touch point. In the I...
by AlfredOne
Fri Jun 12, 2020 7:53 pm
Forum: General Developer Support
Topic: Testers wanted - USB3 XHCI USBHCD
Replies: 11
Views: 1922

Re: Testers wanted - USB3 XHCI USBHCD

Hi, I have this card in my X1000: https://www.inateck.com/inateck-ktu3fr-2o2i-usb-3-0-pci-express-card.html Infos from Ranger: ID: Bus:0x0E Device: 0x00 Function: 0x00 Class: Base: 0x0C Sub: 0x03 IFace: 0x30 (Undefined USB) Device: 0x1100 Rev: 0x10 (N/A) Vendor: 0x1B73 (Fresco Logic) Header Type: No...
by AlfredOne
Fri Jun 12, 2020 12:26 pm
Forum: General Developer Support
Topic: USB device with multiple interfaces
Replies: 2
Views: 305

USB device with multiple interfaces

Hello, i'm writing a driver for a multitouch monitor. The USB device has only 1 configuration with two interfaces: - the 1st interface (ID = 0) is the multitouch interface with only 1 input endpoint (interrupt type with address 0x82) - the 2nd interface (ID = 1) is the singletouch interface with onl...
by AlfredOne
Wed Jun 03, 2020 3:41 pm
Forum: General AmigaOS
Topic: Picasso96Mode: screen too large for this card
Replies: 1
Views: 411

Picasso96Mode: screen too large for this card

Hello, i'm trying to create this custom display mode for a touchscreen: 800x480@60Hz. I created the mode with Picasso96Mode , but i wasn't able to try directly the parameters because the "Test" and "Edit" buttons show me always the following message: "Screen too large for this card". Note that after...
by AlfredOne
Wed Apr 15, 2020 7:29 pm
Forum: Platform: AmigaOne X1000
Topic: New install on SSD problems
Replies: 22
Views: 4740

Re: New install on SSD problems

That´s not a problem of your SSD, but your other hardware/mainboard. It never reaches CFE. I know getting stuck at [DEVI] just too well. For me it was the fact that a simple reset (button press) never did it (i need to press and hold the reset button for three or more seconds) There might be a bad ...
by AlfredOne
Wed Apr 15, 2020 4:26 pm
Forum: Platform: AmigaOne X1000
Topic: New install on SSD problems
Replies: 22
Views: 4740

Re: New install on SSD problems

@powler @AlfredOne As there is no way to tell from afar what is happening with your setups, i can only advise to plug a serial cable nad read out the stuff (it hopefully still writes) on a PC/Linux machine. I´m still using a SSD in my X1000, no problems whatsoever (i still think Amiga hardware is n...
by AlfredOne
Mon Apr 13, 2020 10:03 pm
Forum: Platform: AmigaOne X1000
Topic: New install on SSD problems
Replies: 22
Views: 4740

Re: New install on SSD problems

Well, my joy at having my X1000 booting off the SSD and getting to play with it over the Easter long weekend was short lived. All I get now when I power the X1000 on is a black screen with a flashing line cursor in the top left of the screen. * I checked all cabling * Replaced the battery * Tried c...
by AlfredOne
Wed Jan 22, 2020 12:44 am
Forum: General Developer Support
Topic: Graphic card driver development guide
Replies: 0
Views: 1624

Graphic card driver development guide

Hi all,
does anyone know if a developer's guide for graphics card drivers updated to AmigaOS4 is expected to be published?
Alternatively, is the P96 Developer guide (provided here by IndividualComputers) applicable to AmigaOS4?

Thank you.
by AlfredOne
Thu Jan 12, 2017 11:32 pm
Forum: Platform: AmigaOne X1000 - Linux Only
Topic: ubuntu MATE 16.04.1 Live DVD
Replies: 141
Views: 93678

Re: ubuntu MATE 16.04.1 Live DVD

Hi Christian, i modified fstab but it doesn't resolve the problem. I'm not a linux expert, but i think the problem is very early in the startup phase. /etc/fstab is not accessible if linux can't mount the root partition, is it? Booting with bootargs 'root=/dev/sdc3 rootdelay=5' i can see following ...