Search found 10 matches

by TomSoniq
Wed Feb 03, 2021 8:36 pm
Forum: Platform: AmigaOne 500 and Sam series
Topic: Sam440 and keyboard/mouse via hub or KVM switch: Still unstable
Replies: 1
Views: 264

Sam440 and keyboard/mouse via hub or KVM switch: Still unstable

Hi all, I've still got issues with my keyboard and mouse connected to the Sam440 via a KVM switch. The hardware and software sees this as a USB hub, nothing more. In fact two different KVM switches and two different USB hubs I've tested show exactly the same behaviour: If the both the mouse keyboard...
by TomSoniq
Wed Mar 25, 2020 3:55 pm
Forum: General AmigaOS
Topic: Dynamically changing a label text
Replies: 2
Views: 1498

Dynamically changing a label text

Hi! I'd like to dynamically change the text in a label in both cases when the window containing that label is open and when it is closed (but the label object still exists). From what I can see in the SDK examples, a label can have multiple elements. This means that a label can have multiple texts. ...
by TomSoniq
Wed May 08, 2019 6:44 pm
Forum: General AmigaOS
Topic: USB Stack Issue still unsolved...
Replies: 39
Views: 19947

Re: USB Stack Issue still unsolved...

Found out the following: Both the mouse and the keyboard always show up in the USB inspector. But in the case one of them is not working it's because no driver was assigned to it. "Driver: none" If I pull the USB plug (the one to the hub/KVM) a couple of times then sooner or later both of ...
by TomSoniq
Wed May 08, 2019 9:10 am
Forum: General AmigaOS
Topic: USB Stack Issue still unsolved...
Replies: 39
Views: 19947

Re: USB Stack Issue still unsolved...

I've got a new KVM switch which features transparent keyboard/mouse emulation. This means all connected hosts see a permanently connected keyboard and mouse behind a USB hub. This works perfectly fine with one connected Windows10 and one connected Ubuntu 18.04.2 LTS machine. OS4.1FE Update 1 on the ...
by TomSoniq
Fri Jan 18, 2019 10:02 pm
Forum: General AmigaOS
Topic: USB Stack Issue still unsolved...
Replies: 39
Views: 19947

Re: USB Stack Issue still unsolved...

The issue could well be the KVM. Best workaround is not to use a KVM.... Well, if two PCs and an A4k with Deneb/Poseidon/OS3.9 work perfectly fine with this KVM switch I really don't feel like setting up a second monitor, mouse and keyboard just to please that damn SAM440/OS4.1 :P Not to mention th...
by TomSoniq
Thu Jan 17, 2019 3:56 pm
Forum: General AmigaOS
Topic: USB Stack Issue still unsolved...
Replies: 39
Views: 19947

Re: USB Stack Issue still unsolved...

I've been facing similar problems so I thought it's well worth to bring this up once more. Scenario: SAM440 connected to USB mouse and keyboard via a KVM switch Workaround for startup issue: Disable bootkeyboard.usbfd and bootmouse.usbfd kickstart modules Workaround when switching KVM from other sou...
by TomSoniq
Thu Oct 31, 2013 10:49 am
Forum: General Developer Support
Topic: Ringhio bug?
Replies: 6
Views: 3004

Re: Ringhio bug?

Tried removing the dash: Same thing Called second instance TestApp-Different : Everything ok. So it seems as if the Ringhio server only does the string compare until the length of the shorter string is reached. Registering an application called Ami is fun. To make it shut up you have to disable AmiU...
by TomSoniq
Wed Oct 30, 2013 10:37 am
Forum: General Developer Support
Topic: Ringhio bug?
Replies: 6
Views: 3004

Re: Ringhio bug?

Long story short:

Two registered applications, one called TestApp-Something, the other one TestApp

Disabling TestApp in Ringhio Prefs does nothing.
Disabling TestApp-Something in Ringhio Prefs disables them both.

Any ideas? ;)
by TomSoniq
Tue Oct 29, 2013 10:07 am
Forum: General Developer Support
Topic: Ringhio bug?
Replies: 6
Views: 3004

Ringhio bug?

Hi! I've discovered some strange ringhio behaviour which can be reproduced by running the code below like this: Start the Notify program for the first time Two popups should be displayed. Now open Prefs/Notifications You should find two new registered applications: "TestApp-Something" and ...
by TomSoniq
Wed May 08, 2013 5:19 pm
Forum: General AmigaOS
Topic: ASL file requester directory lock bug?
Replies: 1
Views: 2156

ASL file requester directory lock bug?

Hi all, I've come across the following strange behaviour: When opening an ASL file requester in which you're allowed to select multiple files and you actually do select multiple files, e.g. RAM:0/1.txt RAM:0/2.txt ...then click on OK, the parent directory remains locked even if you deallocate the AS...