Search found 1181 matches

by xenic
Thu May 13, 2021 2:42 pm
Forum: Platform: AmigaOne X5000
Topic: sii3114ide.device
Replies: 9
Views: 794

Re: sii3114ide.device

What do I have to do to load the sii3114ide.device so that the available drives attached to it do show up? Just to be more explicit about trgswe's suggestion, you can try this: Connect the hard-disk to your sii3114ide card before turning on the computer. Copy Mounter from SYS:System to ram: and cha...
by xenic
Tue May 11, 2021 4:58 pm
Forum: General AmigaOS
Topic: Bug in shell/cli/console
Replies: 17
Views: 482

Re: Bug in shell/cli/console

Ouch ... noted. For your convenience here is a short AmigaDOS script that will list (to a file in ram:) the C: files that have no English help files: ;Script docomp FOREACH NAME file IN `list SORT N C: LFORMAT "C:%N"` IF NOT EXISTS SYS:Locale/Help/english/Shell/${file}.help ECHO >>ram:noh...
by xenic
Mon May 10, 2021 3:43 pm
Forum: General AmigaOS
Topic: Bug in shell/cli/console
Replies: 17
Views: 482

Re: Bug in shell/cli/console

Sligtly OT, I know, but why don't you just do "help assign"? Because I was testing if the more command produced the same error reported in this topic for lha in a shell. I normally don't use more for anything. Besides, the help files haven't been kept up to date with all the commands in t...
by xenic
Sun May 09, 2021 2:25 pm
Forum: General AmigaOS
Topic: Bug in shell/cli/console
Replies: 17
Views: 482

Re: Bug in shell/cli/console

@xenic What c commands were giving you problems? And what were your command to make them appear flawed? I plan to do some more testing once I'm back home. As far as I can tell all the SYS:Documentation/C/ command docs have a formfeed near the beginning and at the end of the doc. The ^L characters a...
by xenic
Mon May 03, 2021 2:21 pm
Forum: General AmigaOS
Topic: Bug in shell/cli/console
Replies: 17
Views: 482

Re: Bug in shell/cli/console

I tested your procedure using the "more" command to read a text file and did not see the extra characters that appear with "lha". However, when I display one of the C: command documentation files with the more command I do see some extra characters ( ^L ) where there are formfeed...
by xenic
Sun May 02, 2021 3:15 pm
Forum: Platform: AmigaOne XE and MicroA1-C
Topic: microA1 Serial port(s)
Replies: 6
Views: 574

Re: microA1 Serial port(s)

So in regards to, that the build in serial port was somehow a serial-usb-style interface, i think a "real" RS-232C port on computer is needed to actually receive something from the amiga. But nevertheless i can confirm that the on board serial port of the microA1 is working. I still need ...
by xenic
Thu Apr 22, 2021 2:49 pm
Forum: General AmigaOS
Topic: Turbotext problem with OS4FEupdate2
Replies: 28
Views: 1191

Re: Turbotext problem with OS4FEupdate2

If it really does run out of stack with the system default stack, try raising the system default stack and see if that helps. Maybe Turbotext is using more stack than expected for the search operations, possibly specifically when running under 68k emulation? Ranger shows Turbotext using about 15% o...
by xenic
Wed Apr 21, 2021 4:22 pm
Forum: General AmigaOS
Topic: Turbotext problem with OS4FEupdate2
Replies: 28
Views: 1191

Re: Turbotext problem with OS4FEupdate2

That was also my initial thinking leading to blacklisting them all when the program alone didn't do it. I'm not using TTX myself (other than for testing this), so I'm looking forward to your conclusion. Blacklisting all the Turbotext files does eliminate the original problem but creates new ones (w...
by xenic
Wed Apr 21, 2021 4:12 pm
Forum: General AmigaOS
Topic: Turbotext problem with OS4FEupdate2
Replies: 28
Views: 1191

Re: Turbotext problem with OS4FEupdate2

That was also my initial thinking leading to blacklisting them all when the program alone didn't do it. I'm not using TTX myself (other than for testing this), so I'm looking forward to your conclusion. Blacklisting all the Turbotext files does eliminate the original problem but creates new ones (w...
by xenic
Tue Apr 20, 2021 12:57 am
Forum: General AmigaOS
Topic: Turbotext problem with OS4FEupdate2
Replies: 28
Views: 1191

Re: Turbotext problem with OS4FEupdate2

Yes, I was thinking about trying various combinations of things being blacklisted or not. Thanks for getting ahead of me :-). Correction! I spoke too soon. Blacklisting only one of the files leads to eventual instability and crashes. So far blacklisting the program and all the libraries seems to be...