Search found 1175 matches

by xenic
Thu Apr 22, 2021 2:49 pm
Forum: General AmigaOS
Topic: Turbotext problem with OS4FEupdate2
Replies: 28
Views: 664

Re: Turbotext problem with OS4FEupdate2

If it really does run out of stack with the system default stack, try raising the system default stack and see if that helps. Maybe Turbotext is using more stack than expected for the search operations, possibly specifically when running under 68k emulation? Ranger shows Turbotext using about 15% o...
by xenic
Wed Apr 21, 2021 4:22 pm
Forum: General AmigaOS
Topic: Turbotext problem with OS4FEupdate2
Replies: 28
Views: 664

Re: Turbotext problem with OS4FEupdate2

That was also my initial thinking leading to blacklisting them all when the program alone didn't do it. I'm not using TTX myself (other than for testing this), so I'm looking forward to your conclusion. Blacklisting all the Turbotext files does eliminate the original problem but creates new ones (w...
by xenic
Wed Apr 21, 2021 4:12 pm
Forum: General AmigaOS
Topic: Turbotext problem with OS4FEupdate2
Replies: 28
Views: 664

Re: Turbotext problem with OS4FEupdate2

That was also my initial thinking leading to blacklisting them all when the program alone didn't do it. I'm not using TTX myself (other than for testing this), so I'm looking forward to your conclusion. Blacklisting all the Turbotext files does eliminate the original problem but creates new ones (w...
by xenic
Tue Apr 20, 2021 12:57 am
Forum: General AmigaOS
Topic: Turbotext problem with OS4FEupdate2
Replies: 28
Views: 664

Re: Turbotext problem with OS4FEupdate2

Yes, I was thinking about trying various combinations of things being blacklisted or not. Thanks for getting ahead of me :-). Correction! I spoke too soon. Blacklisting only one of the files leads to eventual instability and crashes. So far blacklisting the program and all the libraries seems to be...
by xenic
Mon Apr 19, 2021 6:28 pm
Forum: General AmigaOS
Topic: Turbotext problem with OS4FEupdate2
Replies: 28
Views: 664

Re: Turbotext problem with OS4FEupdate2

I've also found out something potentially more interesting: If you blacklist both TTX and the three libraries found in the libs subdrawer, the problem doesn't occur for me. xenic, could you please try that? Since the Turbotext find problem occurs in a requester, I tried blacklisting the ttxreqs.lib...
by xenic
Mon Apr 12, 2021 4:15 pm
Forum: Platform: AmigaOne XE and MicroA1-C
Topic: microA1 Serial port(s)
Replies: 3
Views: 344

Re: microA1 Serial port(s)

I don't have a microA1 any more but when I had one years ago I connected a "header to female 9 pin" adapter to the internal serial serial header so I could use that serial port with a dialup modem and it worked for years. Unlike some newer NG Amigas the µA1 uses all serial pins which allow...
by xenic
Mon Apr 12, 2021 3:22 pm
Forum: General AmigaOS
Topic: Turbotext problem with OS4FEupdate2
Replies: 28
Views: 664

Re: Turbotext problem with OS4FEupdate2

Okay, sounds likely then. When you say you have tracked the problem down to those modules, what do you base that on? Do you have crash logs or similar pointing into them? Or is it just that the problem disappears when you revert them? If the latter, do you need to revert all three, or is one or two...
by xenic
Sun Apr 11, 2021 5:03 pm
Forum: General AmigaOS
Topic: Turbotext problem with OS4FEupdate2
Replies: 28
Views: 664

Re: Turbotext problem with OS4FEupdate2

@ nbache Since I tracked down the problem to the update2 kernal, sb600sata.device.kmod & sb600ide.device.kmod files and other platforms have different versions of those files; it would be quite possible that the problem only affects the X1000. If I replace those files (in an otherwise complete u...
by xenic
Thu Apr 01, 2021 6:00 pm
Forum: General AmigaOS
Topic: Turbotext problem with OS4FEupdate2
Replies: 28
Views: 664

Re: Turbotext problem with OS4FEupdate2

@nbache Every time I see an update2 problem reported I wonder if the pasemi_dma.resource.kmod file was installed and an entry for it added to Kicklayout. The answer to your query is yes I have that kmod installed and added the MODULE entry in Kicklayout in the specified spot. It would be nice if the...
by xenic
Thu Apr 01, 2021 5:42 pm
Forum: General AmigaOS
Topic: Turbotext problem with OS4FEupdate2
Replies: 28
Views: 664

Re: Turbotext problem with OS4FEupdate2

@ NinjaCyborg I have an unused copy of AmigaForever8, so I copyed TurboText from there and it has the same problem with update2. The only difference I can see in the AmigaForever version is that it defaults to a white background. I have OS4 asyncio.library but it's not installed. I think it was reco...