Search found 42 matches

by dstastny
Sun Mar 04, 2018 10:32 pm
Forum: General Developer Support
Topic: Updated SDK
Replies: 6
Views: 2817

Updated SDK

Hi I know there was a hope to get updated SDK out last fall 2017 but understood there was some stuff needed to get done to make that happen. Is there anything the public could offer to help or volunteer to see it happen?

Regards
Doug
by dstastny
Tue Feb 27, 2018 8:57 pm
Forum: Platform: AmigaOne X5000
Topic: X5000 Proven to Work Hardware List
Replies: 60
Views: 32556

Re: X5000 Proven to Work Hardware List

I have been hesitant to buy a new mechanical as some I have tried did not work. Aaron at amigaonthelake suggested Deck Hassium Pro Blue LED Backlit PBT Mechanical Keyboard (Brown Cherry MX).
https://mechanicalkeyboards.com/shop/in ... tail&p=677
Works great no errors!

Regards
Doug
by dstastny
Thu Feb 01, 2018 9:57 pm
Forum: Platform: AmigaOne X5000
Topic: Time
Replies: 11
Views: 2303

Re: Time

@Thread - Thanks for details on how it works.

I think I figured out the issue. When the DPMS kicks in something is not quite right there. I disabled DPMS and it seems to hold time steady. If I allow DPMS to kick in the time is advancing upon wake up.

Thanks
Doug
by dstastny
Wed Jan 31, 2018 10:46 pm
Forum: Platform: AmigaOne X5000
Topic: Time
Replies: 11
Views: 2303

Re: Time

@Xenic if you run ranger what is it showing for Frequencies?

Doug
by dstastny
Wed Jan 31, 2018 6:45 am
Forum: Platform: AmigaOne X5000
Topic: Time
Replies: 11
Views: 2303

Re: Time

@broadblues. Yeah about that. I didn't notice at first as my coding was crashing a alot. Last few weeks I have had it running and timing. Reset with load hour later it would gain time. Real noticble after few days and no reboot.

Doug
by dstastny
Tue Jan 30, 2018 4:22 pm
Forum: Platform: AmigaOne X5000
Topic: Time
Replies: 11
Views: 2303

Time

I know there have been issues reported with RTC but that is not problem I am seeing as the RTC is running fine. My issue is post boot the accuracy of the system time diverges away from the RTC. If I call setclock load it goes back in sync. Now if I remember the Amgia OS was designed to function with...
by dstastny
Tue Dec 26, 2017 9:28 pm
Forum: General Developer Support
Topic: (solved) Help with __translate_amiga_to_unix_path_name
Replies: 3
Views: 1497

Re: Help with __translate_amiga_to_unix_path_name

@salass00 Thank you so much! I noticed the NULL IDOS pointer I just could not understand why linking that the function was causing issue. Thank you for acknowledging it was a bug and providing work around. To be complete for thread here is working example "four.c" /* gcc -o four four.c This works co...
by dstastny
Tue Dec 26, 2017 2:55 am
Forum: General Developer Support
Topic: (solved) Help with __translate_amiga_to_unix_path_name
Replies: 3
Views: 1497

(solved) Help with __translate_amiga_to_unix_path_name

I have been working with trying to utilize the newlib function __translate_amiga_to_unix_path_name but it seems to introduce and issue I cant wrap my head around. Below are 3 simple programs. The first "one.c" uses the function to translate a sample path works fine. /* gcc -o one one.c This works */...
by dstastny
Mon Dec 18, 2017 9:53 pm
Forum: General AmigaOS
Topic: Appdir
Replies: 2
Views: 1150

Re: Appdir

@salass00

Works for me!

Thanks
Doug
by dstastny
Mon Dec 18, 2017 6:57 pm
Forum: General AmigaOS
Topic: Appdir
Replies: 2
Views: 1150

Appdir

I have been testing out the newer gcc 5.4 and wrote a couple scripts to switch between compilers but am having issues with appdir. On the adtools site it says to clear appdir with delete APPDIR:#? I find this does not work as the actual values are stored in env: and envarc: so unless I delete those ...