Search found 108 matches

by softwarefailure
Mon Feb 08, 2021 3:29 pm
Forum: General Developer Support
Topic: Major memory leak in CreateNewProc()
Replies: 6
Views: 1081

Re: Major memory leak in CreateNewProc()

Thanks, I'm now using

Code: Select all

NP_Output, DupFileHandle(Output()),
NP_Input, DupFileHandle(Input()),
and no NP_CloseOutput/NP_CloseInput and the leak is gone. Thanks a lot!
by softwarefailure
Sat Feb 06, 2021 2:07 pm
Forum: General Developer Support
Topic: Major memory leak in CreateNewProc()
Replies: 6
Views: 1081

Major memory leak in CreateNewProc()

Check out the attached demo code. I think there's a major memory leak in CreateNewProc() when using these lines: NP_Output, Output(), NP_Input, Input(), NP_CloseOutput, 0, NP_CloseInput, 0, without those lines, there is no leak. Also when just one thread is involved, there is no leak either, i.e. if...
by softwarefailure
Sat Feb 06, 2021 2:01 pm
Forum: General Developer Support
Topic: How to free memory allocated by AddTrackable()
Replies: 5
Views: 465

Re: How to free memory allocated by AddTrackable()

Thanks, this really helped me because from the documentation it's not entirely clear what's going on...
by softwarefailure
Sun Jan 31, 2021 2:57 pm
Forum: General Developer Support
Topic: How to free memory allocated by AddTrackable()
Replies: 5
Views: 465

How to free memory allocated by AddTrackable()

I'm using AddTrackable() to track an object that should be destroyed when the task is removed. That works fine. When the task is removed, my destructor function is called and I can destroy the object. But: Once my destructor function has been called and the task has been removed, how should I free t...
by softwarefailure
Thu Sep 24, 2020 6:58 pm
Forum: General Developer Support
Topic: OpenElfTags() - free memory
Replies: 1
Views: 969

OpenElfTags() - free memory

When using OET_MemoryAddr with OpenElfTags(): Can I free the memory as soon as OpenElfTags() succeeds or do I have to keep the buffer until I call CloseElfTags()?
by softwarefailure
Sun Jun 21, 2020 7:47 pm
Forum: Platform: AmigaOne XE and MicroA1-C
Topic: MicroA1 dying :(
Replies: 11
Views: 2082

Re: MicroA1 dying :(

Someone from a different forum suggested replacing the battery and that indeed did the trick... now it's working again! Embarassing, but I didn't think of the battery! I still find it strange though that an empty battery causes a loss of the VGA signal. I'd expect U-Boot settings and system clock st...
by softwarefailure
Tue Jun 02, 2020 8:55 pm
Forum: Platform: AmigaOne XE and MicroA1-C
Topic: MicroA1 dying :(
Replies: 11
Views: 2082

Re: MicroA1 dying :(

@OldFart: Thanks for the offer! I'll try to get some serial output first but I might come back to you if all attempts fail.
by softwarefailure
Fri May 29, 2020 8:55 pm
Forum: Platform: AmigaOne XE and MicroA1-C
Topic: MicroA1 dying :(
Replies: 11
Views: 2082

Re: MicroA1 dying :(

Raziel wrote: Fri May 29, 2020 1:51 pm Are you able to hook up a serial to see where it stops?
Erm, there is no serial port either...
by softwarefailure
Fri May 29, 2020 11:42 am
Forum: Platform: AmigaOne XE and MicroA1-C
Topic: MicroA1 dying :(
Replies: 11
Views: 2082

Re: MicroA1 dying :(

Raziel wrote: Thu May 28, 2020 7:19 pm Sounds like a hardware failure on the graphics card.
Do you maybe have a replacement to test?
Erm, you do know it's a MicroA1... there's no graphics card but it's onboard :(
by softwarefailure
Thu May 28, 2020 6:27 pm
Forum: Platform: AmigaOne XE and MicroA1-C
Topic: MicroA1 dying :(
Replies: 11
Views: 2082

MicroA1 dying :(

Lately, my MicroA1 seems to have contracted some serious issues. I'm not able to boot into OS4 anymore. I'm seeing these issues: 1) When I switch on the machine the HD drive motor often doesn't start 2) Even when it starts, there is still no VGA signal I've tried to remove all peripherals including ...