Search found 152 matches

by Hans
Tue Aug 29, 2017 4:21 am
Forum: General Developer Support
Topic: Silly things kill SDL/MiniGL performance on the WB screen
Replies: 16
Views: 14733

Re: Silly things kill SDL/MiniGL performance on the WB scree

@vapehill @all I think I found the root cause. Still some more diagnostic to do, but as a last resort, I removed a piece of code that updates window title (some stats), and performance is back. So it is not VRAM/pager issue definitely. Glad to hear you figured it out. @Raziel & Salass0 Not to sound ...
by Hans
Mon Aug 28, 2017 4:07 am
Forum: General Developer Support
Topic: Silly things kill SDL/MiniGL performance on the WB screen
Replies: 16
Views: 14733

Re: Compositing kills SDL/MiniGL performance on the WB scree

Textures used by the game are quite small, 2 are 500 KB and one is 1000 KB. I could try 16-bit versions of course. Can I somehow get some statistics from VRAM usage (fragmentation, paging)? I'm afraid not. If graphics.library still uses an ancient pager, should there be a ticket for improving it? I...
by Hans
Sun Aug 27, 2017 12:26 am
Forum: General Developer Support
Topic: Silly things kill SDL/MiniGL performance on the WB screen
Replies: 16
Views: 14733

Re: Compositing kills SDL/MiniGL performance on the WB scree

Decided to check in on this forum for the first time in months... I have a simple 2D game that renders with SDL+MiniGL (Sam440ep + M9 Radeon). Game is playable on both 16/32-bit custom screen, or 16-bit WB screen, but if I change my WB to 32-bit mode with compositing effects, frame rate drops from p...
by Hans
Mon Mar 14, 2016 2:21 am
Forum: General AmigaOS
Topic: Jerky mouse with dockies enabled on X1000/Radeon 9250
Replies: 47
Views: 42683

Re: Jerky mouse with dockies enabled on X1000/Radeon 9250

Regardin my situation, Hans already replied that this is a bug in the Radeon HD driver (DMA) on AmigaONE X1000. Actually, it's DMA in the graphics.libarary, not the driver. A semi-random thought, could you (and anyone else experiencing the jerkiness) try disabling anti-aliased text rendering? I thi...
by Hans
Thu Dec 24, 2015 10:46 pm
Forum: General AmigaOS
Topic: Jerky mouse with dockies enabled on X1000/Radeon 9250
Replies: 47
Views: 42683

Re: Jerky mouse with dockies enabled on X1000/Radeon 9250

... Good question, is someone works / reproduced this annoying problem ? Thank you os4 devs (at least for a reply) I'm sorry to discover that you guys never got a confirmation of this issue from OS4 beta testers/devs. So, let me confirm: yes, beta testers have replicated this issue, and yes, it has...
by Hans
Mon May 25, 2015 11:23 pm
Forum: General AmigaOS
Topic: Warp3D: 2048x2048 texture / W3D_DrawArray problem
Replies: 39
Views: 18998

Re: Warp3D: 2048x2048 texture / W3D_DrawArray problem

Pardon? The first parameter to W3D_Query is the context (and the NULL pointer variant is long "discouraged"). So it should be no problem for you to return a more correct value than 2048 x 2048 based on the context's depth / GPU type at least. I mean, that information should be possible to obtain, r...
by Hans
Thu Apr 16, 2015 2:17 am
Forum: Platform: AmigaOne 500 and Sam series
Topic: Radeon driver v2.7 and R7 250E: no HDMI and no DVI output
Replies: 21
Views: 21471

Re: Radeon driver v2.7 and R7 250E: no HDMI and no DVI outpu

virgola wrote:@Hans
Is it possible for a non beta-tester like me to test a newer unreleased version that might solve the problem?
You'll have to ask Hyperion that.

Hans
by Hans
Wed Apr 15, 2015 10:04 am
Forum: Platform: AmigaOne 500 and Sam series
Topic: Radeon driver v2.7 and R7 250E: no HDMI and no DVI output
Replies: 21
Views: 21471

Re: Radeon driver v2.7 and R7 250E: no HDMI and no DVI outpu

@virgola Looking at your logs, the driver successfully initialises the card (I can see that the initialisation function completes), and then the OS simply stops. It stops round where the graphics library is supposed to start reading the DDC buses to extract monitor information. I've seen this type o...
by Hans
Fri Apr 10, 2015 2:16 am
Forum: Platform: AmigaOne 500 and Sam series
Topic: Radeon driver v2.7 and R7 250E: no HDMI and no DVI output
Replies: 21
Views: 21471

Re: Radeon driver v2.7 and R7 250E: no HDMI and no DVI outpu

@Hans Debug log: I will be able to obtain a serial cable for debug next week. Meanwhile, is it possible to grab the kernel without a serial cable? You can't save the debug log without a serial cable if the system locks up. That's because you won't be able to run dumpdebugbuffer (to save the log) if...
by Hans
Thu Apr 09, 2015 2:11 am
Forum: Platform: AmigaOne 500 and Sam series
Topic: Radeon driver v2.7 and R7 250E: no HDMI and no DVI output
Replies: 21
Views: 21471

Re: Radeon driver v2.7 and R7 250E: no HDMI and no DVI outpu

@virgola If you wait, do you hear the boot sound in the background? Like Raziel said, a debug log would be useful (you may need to use the debug version to get useful info). I also recommend comparing notes with imagodespira. Of interest are the exact graphics card model (including the SKU#), your U...