How to get a partition automounted with an icon on desktop?

AmigaOne X5000 platform specific issues related to Linux only.

How to get a partition automounted with an icon on desktop?

Postby Roland » Sun Aug 11, 2019 6:44 pm

I have tried to get a ntfs partition mounted on startup (in Fienix), with an icon on desktop, but without luck...

"blkid" gives the following info for the partition:

Code: Select all
/dev/sdc12: LABEL="NTFS1" UUID="1883292A49EB3186" TYPE="ntfs" PARTUUID="06b67b03-39b3-47ac-b7a2-7735e48cf955"


I have tested the following lines in "/etc/fstab"

Code: Select all
UUID=06b67b03-39b3-47ac-b7a2-7735e48cf955  /   ntfs   errors=remount-ro   0   0  (or 2)

UUID=1883292A49EB3186   /   ntfs   errors=remount-ro   0   0

PARTUUID=06b67b03-39b3-47ac-b7a2-7735e48cf955   /   ntfs   errors=remount-ro   0   0


None of them worked, the icon for "NTFS1" did not appear on desktop. Some of those lines had the effect that the partition was not anymore visible in 'caja', and could not be mounted 'manually'.

Could someonbe please help... How should I format that line correctly in 'fstab'?
- Roland -
Roland
 
Posts: 299
Joined: Tue May 02, 2017 8:23 am

Re: How to get a partition automounted with an icon on deskt

Postby xeno74 » Mon Aug 12, 2019 9:09 am

Just for info: Our kernels have NTFS support.

Code: Select all
CONFIG_NTFS_FS=y
# CONFIG_NTFS_DEBUG is not set
CONFIG_NTFS_RW=y


Unfortunately I don't use NTFS. I will try to figure out where the issue is.
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 5123
Joined: Fri Mar 23, 2012 8:58 am

Re: How to get a partition automounted with an icon on deskt

Postby xeno74 » Mon Aug 12, 2019 2:00 pm

Roland wrote:I have tried to get a ntfs partition mounted on startup (in Fienix), with an icon on desktop, but without luck...

"blkid" gives the following info for the partition:

Code: Select all
/dev/sdc12: LABEL="NTFS1" UUID="1883292A49EB3186" TYPE="ntfs" PARTUUID="06b67b03-39b3-47ac-b7a2-7735e48cf955"


I have tested the following lines in "/etc/fstab"

Code: Select all
UUID=06b67b03-39b3-47ac-b7a2-7735e48cf955  /   ntfs   errors=remount-ro   0   0  (or 2)

UUID=1883292A49EB3186   /   ntfs   errors=remount-ro   0   0

PARTUUID=06b67b03-39b3-47ac-b7a2-7735e48cf955   /   ntfs   errors=remount-ro   0   0


None of them worked, the icon for "NTFS1" did not appear on desktop. Some of those lines had the effect that the partition was not anymore visible in 'caja', and could not be mounted 'manually'.

Could someonbe please help... How should I format that line correctly in 'fstab'?


The mount point is wrong. It can’t be “/” for the NTFS partition. Please try “/media” instead.
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 5123
Joined: Fri Mar 23, 2012 8:58 am

Re: How to get a partition automounted with an icon on deskt

Postby Roland » Mon Aug 12, 2019 7:07 pm

xeno74 wrote: The mount point is wrong. It can’t be “/” for the NTFS partition. Please try “/media” instead.


Thanks! Got it working... BTW, I noticed that 'LABEL' can be used instead of the long UUID code. But using merely "/media" was not enough, I also had to add the volume to the path in fstab. This is how I have it now:

Code: Select all
LABEL=NTFS1  /media/NTFS1   ntfs defaults   0   2


One side effect when mounting a volume this way, though... The owner of all files on the volume is now 'root'. If I would like to change some attributes of a file (in caja 'file/properties/permissions'), it is not possible from the 'user' account ('open as administrator' is not strong enough). Just tested that even from the 'root' account that is not possible... Changes made in 'permissions' do not stay, they are immediately reverted to the original. Is this how it should be?
- Roland -
Roland
 
Posts: 299
Joined: Tue May 02, 2017 8:23 am

Re: How to get a partition automounted with an icon on deskt

Postby xeno74 » Tue Aug 13, 2019 10:23 am

Roland,

Please try

Code: Select all
LABEL=NTFS1  /media/NTFS1   ntfs    rw,user,noauto,exec,utf8,uid=1000   0   2


My entry:

Code: Select all
UUID=70C07A8E77D9D629 /media/NTFS   ntfs   rw,user,noauto,exec,utf8,uid=1000   0   0


uid=1000 -> My user id

I can mount the NTFS partition with sudo mount /media/NTFS.

/var/log/syslog:

Code: Select all
Aug 13 10:12:58 X5000 ntfs-3g[5316]: Version 2015.3.14AR.1 integrated FUSE 28
Aug 13 10:12:58 X5000 ntfs-3g[5316]: Mounted /dev/sdb1 (Read-Write, label "NTFS", NTFS 3.1)
Aug 13 10:12:58 X5000 ntfs-3g[5316]: Cmdline options: rw,nosuid,nodev,utf8,uid=1000,user,exec
Aug 13 10:12:58 X5000 ntfs-3g[5316]: Mount options: rw,nosuid,nodev,utf8,user,exec,allow_other,nonempty,relatime,default_permissions,fsname=/dev/sdb1,blkdev,blksize=4096
Aug 13 10:12:58 X5000 ntfs-3g[5316]: Global ownership and permissions enforced, configuration type 7


Cheers,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 5123
Joined: Fri Mar 23, 2012 8:58 am

Re: How to get a partition automounted with an icon on deskt

Postby Roland » Wed Aug 14, 2019 7:41 am

xeno74 wrote:Please try

Code: Select all
LABEL=NTFS1  /media/NTFS1   ntfs    rw,user,noauto,exec,utf8,uid=1000   0   2


Unfortunately that did not work here... Booting ends to the emergency mode if I have it in fbdev. I changed the uid to 1001 which is my account.
- Roland -
Roland
 
Posts: 299
Joined: Tue May 02, 2017 8:23 am

Re: How to get a partition automounted with an icon on deskt

Postby xeno74 » Wed Aug 14, 2019 8:37 pm

Roland wrote:Unfortunately that did not work here... Booting ends to the emergency mode if I have it in fbdev. I changed the uid to 1001 which is my account.


Have you seen any error messages in the log file /var/log/syslog?
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 5123
Joined: Fri Mar 23, 2012 8:58 am

Re: How to get a partition automounted with an icon on deskt

Postby xeno74 » Thu Aug 15, 2019 2:18 pm

Roland,

I was able to create and format a NTFS partition on a floppy disk with Fienix today. After that I was able to mount it. Then I created an entry in the file /etc/fstab for this partition. After a reboot I could access the NTFS partition without any problems! :-) I successfully created directories and files with my user.

Further information: Thread USB floppy drive

Cheers,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 5123
Joined: Fri Mar 23, 2012 8:58 am

Re: How to get a partition automounted with an icon on deskt

Postby Roland » Fri Aug 16, 2019 6:46 pm

xeno74 wrote:
Roland wrote:Unfortunately that did not work here... Booting ends to the emergency mode if I have it in fstab. I changed the uid to 1001 which is my account.


Have you seen any error messages in the log file /var/log/syslog?


I found the reason for the problem... While testing different parameters in fstab, I ended to have two visually identical string lines, one of which was originally copied from the suggestion you gave on earlier this thread, the other one input from scratch. The first one caused this booting problem when activated, the latter one worked ok. When I had a look on the fstab file with a hex reader, it revealed the problematic string line had in middle of it a couple of 'special characters' which are not visible on screen!

I do not know how I have succeeded to get those 'inserts' into the string, but obviously they made it unfunctional... I have not encountered this kind of issue before but I suppose it can explain some 'mysterious' problems Linux users encounter from time to time.
- Roland -
Roland
 
Posts: 299
Joined: Tue May 02, 2017 8:23 am


Return to Platform: AmigaOne X5000 - Linux Only

Who is online

Users browsing this forum: Bing [Bot] and 2 guests

cron