Arctic Fox 27.9.12 (Firefox 63.0) a fork of Pale Moon

AmigaOne X1000 platform specific issues related to Linux only.

Re: Arctic Fox 27.9.12 (Firefox 63.0) a fork of Pale Moon

Postby xeno74 » Fri May 17, 2019 7:36 pm

sailorMH wrote:Hi, here is
arcticfox 32bit version outputs:
Code: Select all
tata@amigaone:~/arcticfox$ file arcticfox
arcticfox: ELF 32-bit MSB executable, PowerPC or cisco 4500, version 1 (SYSV), dynamically linked, interpreter /lib/ld.so.1, for GNU/Linux 2.6.15, BuildID[sha1]=671a51aae13c091e03580de87d16989b66314bc7, stripped

Code: Select all
tata@amigaone:~/arcticfox$ ldd arcticfox
   linux-vdso32.so.1 (0x00100000)
   libpthread.so.0 => /lib/powerpc-linux-gnu/libpthread.so.0 (0x0ffc5000)
   libatomic.so.1 => /usr/lib/powerpc-linux-gnu/libatomic.so.1 (0x0ff9e000)
   libdl.so.2 => /lib/powerpc-linux-gnu/libdl.so.2 (0x0ff7a000)
   librt.so.1 => /lib/powerpc-linux-gnu/librt.so.1 (0x0ff51000)
   libstdc++.so.6 => /usr/lib/powerpc-linux-gnu/libstdc++.so.6 (0x0fe05000)
   libm.so.6 => /lib/powerpc-linux-gnu/libm.so.6 (0x0fd30000)
   libgcc_s.so.1 => /lib/powerpc-linux-gnu/libgcc_s.so.1 (0x0fcfa000)
   libc.so.6 => /lib/powerpc-linux-gnu/libc.so.6 (0x0fb58000)
   /lib/ld.so.1 (0x2047c000)


Thank you! :-)
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 5253
Joined: Fri Mar 23, 2012 8:58 am

Re: Arctic Fox 27.9.12 (Firefox 63.0) a fork of Pale Moon

Postby sailorMH » Fri May 17, 2019 7:40 pm

xeno74 wrote:
sailorMH wrote:No, I am used 32-bit ubuntu version (arcticfox-27.9.17-ubuntu10.04-powerpc.tar.bz2), as ubuntu is basicaly debian
I will test the also 64-bit OpenSUSE and Fedora version on weekend, and post results.


Thank you! :-) You need a 64-bit version of Debian (64-bit kernel + 64-bit userland) for testing the 64-bit version of Arctic Fox.

-- Christian

I don't suceed with 64bit version:
Code: Select all
$ ./arcticfox
./arcticfox: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory

Code: Select all
$ file arcticfox
arcticfox: ELF 64-bit MSB executable, 64-bit PowerPC or cisco 7500, version 1 (SYSV), dynamically linked, interpreter /lib64/ld64.so.1, for GNU/Linux 3.2.0, BuildID[sha1]=36ea321a735feb80c16b7489fc94b6957f84cc11, stripped

Code: Select all
$ ldd arcticfox
   linux-vdso64.so.1 (0x00003fff9b700000)
   libpthread.so.0 => /lib64/libpthread.so.0 (0x00003fff9b6b1000)
   libatomic.so.1 => /usr/lib64/libatomic.so.1 (0x00003fff9b696000)
   libdl.so.2 => /lib64/libdl.so.2 (0x00003fff9b682000)
   libstdc++.so.6 => not found
   libm.so.6 => /lib64/libm.so.6 (0x00003fff9b5b7000)
   libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00003fff9b591000)
   libc.so.6 => /lib64/libc.so.6 (0x00003fff9b3c1000)
   /lib64/ld64.so.1 (0x000000005c626000)

alter installing lib64stdc++.6, g++-4.8-multilib, lib64stdc++-4.9-dev I got:
Code: Select all
tata@amigaone:~/Plocha/arcticfox$ ldd arcticfox
./arcticfox: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by ./arcticfox)
   linux-vdso64.so.1 (0x00003fffac060000)
   libpthread.so.0 => /lib64/libpthread.so.0 (0x00003fffac011000)
   libatomic.so.1 => /usr/lib64/libatomic.so.1 (0x00003fffabff6000)
   libdl.so.2 => /lib64/libdl.so.2 (0x00003fffabfe2000)
   libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00003fffabe47000)
   libm.so.6 => /lib64/libm.so.6 (0x00003fffabd7d000)
   libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00003fffabd57000)
   libc.so.6 => /lib64/libc.so.6 (0x00003fffabb88000)
   /lib64/ld64.so.1 (0x000000002ed4c000)


and check GLIBC versions:
Code: Select all
$ strings /usr/lib/powerpc-linux-gnu/libstdc++.so.6 | grep GLIBCXX
GLIBCXX_3.4
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_3.4.8
GLIBCXX_3.4.9
GLIBCXX_3.4.10
GLIBCXX_3.4.11
GLIBCXX_3.4.12
GLIBCXX_3.4.13
GLIBCXX_3.4.14
GLIBCXX_3.4.15
GLIBCXX_3.4.16
GLIBCXX_3.4.17
GLIBCXX_3.4.18
GLIBCXX_3.4.19
GLIBCXX_3.4.20
GLIBCXX_LDBL_3.4
GLIBCXX_LDBL_3.4.7
GLIBCXX_LDBL_3.4.10
GLIBCXX_FORCE_NEW
GLIBCXX_DEBUG_MESSAGE_LENGTH

GLIBCXX_3.4.21 is missing - need I higher version of gc++?
Also I suppose that Debian 8 is 64 bit system, but it seems to be 64bit kernel/32bit userland:
Code: Select all
$ getconf LONG_BIT
32
Pegasos 2: MorphOS, AmigaOS, MintPPC 11, NetBSD, MacOS X (molk), Debian 8
AmigaOne X1000: AmigaOS, MintPPC 11, Debian 8, Lubuntu 16.04
Powermac G5 Quad: MacOS X, Debian 8, Lubuntu 16.04
User avatar
sailorMH
 
Posts: 82
Joined: Wed Aug 28, 2013 7:01 pm
Location: Czech republic

Re: Arctic Fox 27.9.12 (Firefox 63.0) a fork of Pale Moon

Postby xeno74 » Fri May 17, 2019 7:56 pm

Hi SailorMH,

Many thanks for testing! :-) It's normal that it doesn't work because you have a 32-bit userland. I thought you have a 64-bit userland.

Cheers,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 5253
Joined: Fri Mar 23, 2012 8:58 am

Re: Arctic Fox 27.9.12 (Firefox 63.0) a fork of Pale Moon

Postby xeno74 » Sun May 26, 2019 8:43 am

FYI:

caseycullen wrote:SpiderWeb and SpiderMail by Matt (wicknix) are now available in the Fienix software repository.
Fienix News
Thanks!
-Casey


caseycullen wrote:The newest version of Arctic Fox, 27.9.17, has been added to the Fienix software repository.
Fienix News
Thanks,
-Casey
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 5253
Joined: Fri Mar 23, 2012 8:58 am

Re: Arctic Fox 27.9.12 (Firefox 63.0) a fork of Pale Moon

Postby xeno74 » Tue Jul 30, 2019 10:40 am

Hi All,

Wicknix released a pre-release version of Arctic Fox 27.9.18 two days ago.

Wicknix wrote:There's an issue with a Mac specific patch that's holding up .18's release, but for the eager beavers on PPC Linux i just built a "pre-release" version from our master branch. Give it a spin. If anything, you might notice some javascript improvements. Currently around 200 bug fixes have to been added at this point in time.

Download (PPC Linux only): https://drive.google.com/file/d/1WLmKz0 ... sp=sharing

Cheers


Link to the test thread: forums.macrumors.com

Download: arcticfox-27.9.18a1.linux-powerpc.tar.bz2

Please test it.

Thanks,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 5253
Joined: Fri Mar 23, 2012 8:58 am

Re: Arctic Fox 27.9.12 (Firefox 63.0) a fork of Pale Moon

Postby xeno74 » Sat Aug 03, 2019 8:11 pm

SpiderWeb 2.1.0 is now available. This release sits on top of the current UXP-28.6.1 code base.

Download
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 5253
Joined: Fri Mar 23, 2012 8:58 am

Re: Arctic Fox 27.9.12 (Firefox 63.0) a fork of Pale Moon

Postby xeno74 » Mon Aug 05, 2019 10:08 am

Hi All,

I released Arctic Fox 27.9.18a1 for old Linux PowerPC distributions like Ubuntu 10.04 or higher today.

Download: arcticfox-27.9.18a1-ubuntu10.04-powerpc.tar.bz2

For Ubuntu 10.04: You need to install the GCC 4.8 and the libatomic1 via the repository 'ppa:ubuntu-toolchain-r/test'.

Code: Select all
sudo add-apt-repository ppa:ubuntu-toolchain-r/test


Code: Select all
sudo apt-get update; sudo apt-get install gcc-4.8 g++-4.8


For Ubuntu 12.04: You need the libatomic1 package. Download: libatomic-ubuntu12.04-powerpc.tar.bz2

Please copy the file 'libatomic.so.1' to '/usr/lib/powerpc-linux-gnu/' with the following command:

Code: Select all
sudo cp libatomic.so.1 /usr/lib/powerpc-linux-gnu/


Screenshot of Arctic Fox 27.9.18a1 on Ubuntu 10.04.4 LTS PowerPC:

Image

Cheers,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 5253
Joined: Fri Mar 23, 2012 8:58 am

Re: Arctic Fox 27.9.12 (Firefox 63.0) a fork of Pale Moon

Postby xeno74 » Wed Aug 07, 2019 1:33 pm

Hi All,

I released the alpha1 of Arctic Fox 27.9.18 64-bit for openSUSE Tumbleweed PPC64 and for Fedora PPC64 today.

Download: arcticfox-27.9.18a1.linux-powerpc64.tar.bz2

Screenshot of Fedora 27 Server PPC64 with kernel 5.3-rc3-2 and with Arctic Fox 27.9.18a1 64-bit:

Image

Cheers,
Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 5253
Joined: Fri Mar 23, 2012 8:58 am

Re: Arctic Fox 27.9.12 (Firefox 63.0) a fork of Pale Moon

Postby xeno74 » Mon Sep 02, 2019 6:58 pm

Wicknix wrote:Mac 32-bit and 64-bit builds of 27.9.18 are now available. PPC 32-bit Linux version also now available.


Change log: https://github.com/wicknix/Arctic-Fox/releases/tag/27.9.18

Download: arcticfox-27.9.18.linux-powerpc.tar.bz2
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 5253
Joined: Fri Mar 23, 2012 8:58 am

Re: Arctic Fox 27.9.12 (Firefox 63.0) a fork of Pale Moon

Postby xeno74 » Wed Sep 11, 2019 5:36 am

FYI:

caseycullen wrote:I just released Arctic Fox 27.9.18 in the Fienix Software Repository. See Fienix News.
Also, an issue with the Greasemonkey package has been fixed. Please test installing/reinstalling Greasemonkey from the repository.
Let me know if you have any issues.
Thanks!
Casey


Image
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 5253
Joined: Fri Mar 23, 2012 8:58 am

PreviousNext

Return to Platform: AmigaOne X1000 - Linux Only

Who is online

Users browsing this forum: No registered users and 6 guests

cron