Background colour of text under icon

A forum for general AmigaOS 4.x support questions that are not platform-specific

Re: Background colour of text under icon

Postby dzanino » Sun Jul 14, 2019 9:11 am

hi all
thats why I came here to fix this
- tonyw: yes, exactly that is when I click "Ff" button...
- version of Font prefs: V53.6 (05/10/2018|
- version of AmigaOS: release 4.1 update 1
Cannot be it by replacing (updateing) with new ASL requesters? or something like this? not sure if there were some updates lately...

I noticed it by coincindence, when I chose black CANDI theme :)
dzanino
 
Posts: 21
Joined: Fri Aug 17, 2018 7:14 am

Re: Background colour of text under icon

Postby tonyw » Sun Jul 14, 2019 2:11 pm

I think you mean "2011" in the date of the Prefs/Font command. There has not been any update of it since 2011.

I'm pretty sure that changes to the ASL requester can't have this effect. I wonder if it's something caused by CANDI?

Can you insert the original CD, then open the System/Prefs drawer on the CD, and run Font prefs from that? If that's difficult, it might be easier to boot from the CD and select "Continue to Workbench". You should then be able to run a known original version of Font prefs.

In any case that window that you showed (with the "Font Family" list) is not part of the old Prefs/Fonts command. It's a different beast altogether, I think.
cheers
tony
User avatar
tonyw
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 1389
Joined: Wed Mar 09, 2011 2:36 pm
Location: Sydney, Australia

Re: Background colour of text under icon

Postby nbache » Sun Jul 14, 2019 2:36 pm

I'm starting to wonder whether some other component is outdated in dzanino's system, and Prefs/Font is depending on a certain version of that for creating the background/outline etc. stuff. Or something about lack of memory, or the screenmode? Not sure if I'm just rambling, though ... quite puzzling. But yeah, try the one on the CD so we get some more clues.

In the meantime, here's how it looks for me.

Best regards,

Niels
Attachments
Workbench-skærm_14-Jul-19_003.jpg
Fornt prefs with selection window
User avatar
nbache
Beta Tester
Beta Tester
 
Posts: 1389
Joined: Mon Dec 20, 2010 8:25 pm
Location: Copenhagen, Denmark

Re: Background colour of text under icon

Postby broadblues » Sun Jul 14, 2019 6:04 pm

dzanino wrote:iam blind - where?
F39162A8-0A9A-4060-9902-6E807DE9E358.jpeg


Do you have a asl replacement library installed?

Doesn't recent MUI have something like that?
User avatar
broadblues
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 591
Joined: Sat Jun 18, 2011 3:40 am
Location: Portsmouth, UK

Re: Background colour of text under icon

Postby broadblues » Sun Jul 14, 2019 6:12 pm

Yes that *is* the MUI font requester.

MUI 5 installs a replacement ASL . Not sure how or where as I have never allowed it to myself.
User avatar
broadblues
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 591
Joined: Sat Jun 18, 2011 3:40 am
Location: Portsmouth, UK

Re: Background colour of text under icon

Postby salass00 » Mon Jul 15, 2019 7:17 am

Apparently there is a MUI:PatchASL command in S:user-startup that you have to remove/comment out if you want to get the regular ASL requesters back.
User avatar
salass00
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 516
Joined: Sat Jun 18, 2011 4:12 pm
Location: Finland

Re: Background colour of text under icon

Postby nbache » Mon Jul 15, 2019 11:34 am

Yeah - had forgotten all about that MUI ASL "downgrade". Never allowed it myself.

Thanks for reminding us all.

Best regards,

Niels
User avatar
nbache
Beta Tester
Beta Tester
 
Posts: 1389
Joined: Mon Dec 20, 2010 8:25 pm
Location: Copenhagen, Denmark

Re: Background colour of text under icon

Postby dzanino » Mon Jul 15, 2019 2:16 pm

thank you all
I am going to test it as soon as possible
Seems that was the problem

Thank you
dzanino
 
Posts: 21
Joined: Fri Aug 17, 2018 7:14 am

Re: Background colour of text under icon

Postby dzanino » Mon Jul 15, 2019 3:30 pm

Confirming
disabling MUIPatchASL is the magic

Thank you
dzanino
 
Posts: 21
Joined: Fri Aug 17, 2018 7:14 am

Previous

Return to General AmigaOS

Who is online

Users browsing this forum: Google [Bot] and 1 guest

cron