OpenScreen & OpenScreenTags ... Why do they don't work ?

This forum is for general developer support questions.

Re: OpenScreen & OpenScreenTags ... Why do they don't work ?

Postby AmiDARK » Sat Dec 15, 2018 10:36 pm

thomasrapp :
Once again, thanks for your knowledge ...
What I found odd, is that this information is available nowhere in the autodoc concerning graphics library and BestModeID, and Intuition OpenScreen, etc...

EDIT : Tested by replacing 32 with 24 inside the OpenScreen method (to keep 32 in the displayCore structure for my needs.
It works perfectly now.
But how can I be sure that detph will really be 24 + 8 alpha bits instead of 24 without alpha ?

Regards,
Sam440EP - AmigaOS 4.1 Final Edition
AmiDARK
 
Posts: 40
Joined: Thu Oct 20, 2011 10:23 am

Re: OpenScreen & OpenScreenTags ... Why do they don't work ?

Postby broadblues » Sun Dec 16, 2018 4:40 am

But how can I be sure that detph will really be 24 + 8 alpha bits instead of 24 without alpha ?


There are no 24 bit without alpha modes.
User avatar
broadblues
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 591
Joined: Sat Jun 18, 2011 3:40 am
Location: Portsmouth, UK

Re: OpenScreen & OpenScreenTags ... Why do they don't work ?

Postby broadblues » Sun Dec 16, 2018 6:19 pm

Just as a further thought.

If you want bitmaps with alpha channels for your applications usage, you do not need to have a screen with 32bit pixels. You merely want to allocate bitmaps with the correct format ( PIXF_A8R8G8B8 for example) do your alpha based rendering, then blit the contents of your temp bitmap into the windows rastport. Whilst at first glance it may seem more efficient if the window has the 32bit format too, as the alpha part is not used (composited windows with alpha maps have a seperate alpha clip), the loss is not a significant as you might think, especially if you do a fair ammount of rendering before blitting the result inot the window.

This approach enables your app to be run windowed on a 16bit workbench screen on lower end hardware. (Sam440 EP for example!).
User avatar
broadblues
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 591
Joined: Sat Jun 18, 2011 3:40 am
Location: Portsmouth, UK

Re: OpenScreen & OpenScreenTags ... Why do they don't work ?

Postby AmiDARK » Mon Dec 17, 2018 10:55 pm

broadblues : Thank you for your answer, but I'm not sure to really understand what you explained.
Sam440EP - AmigaOS 4.1 Final Edition
AmiDARK
 
Posts: 40
Joined: Thu Oct 20, 2011 10:23 am

Previous

Return to General Developer Support

Who is online

Users browsing this forum: No registered users and 3 guests

cron