AmigaOne X5000 - FreeBSD Only

AmigaOne X5000 platform specific issues related to Linux only.

Re: AmigaOne X5000 - FreeBSD Only

Postby Skateman » Mon Oct 22, 2018 9:15 pm

Could the missing a /chosen node be the issue with the ¨not¨ working X5000 DPAA Ethernet adapter within Ubuntu PPC?

Would be great if just a new dtb would solve the issue :-)
AmigaOne X5000 -> 2GHz / 16GB RAM / Radeon R7 250 / M-Audio 5.1 -> AmigaOS 4.1 FE / Ubuntu Linux
Amiga 1200 -> Recapped / 68ec020 ACA 1221ec / CF HDD / RetroNET connected to the world
User avatar
Skateman
 
Posts: 354
Joined: Thu Aug 10, 2017 9:36 pm
Location: The Netherlands

Re: AmigaOne X5000 - FreeBSD Only

Postby chmeee » Tue Oct 23, 2018 4:04 am

Skateman wrote:Could the missing a /chosen node be the issue with the ¨not¨ working X5000 DPAA Ethernet adapter within Ubuntu PPC?

Would be great if just a new dtb would solve the issue :-)


I highly doubt that, since /chosen is only really used for passing bootargs and stdin/stdout (among a few others). Unless bootargs control the ethernet, I doubt you'd see any benefit, if Ubuntu already boots, but ethernet is nonfunctional.

Anyway, I committed r339632 to FreeBSD, which is the last bit on the FreeBSD side to make that dtb work.
chmeee
 
Posts: 8
Joined: Wed Mar 07, 2018 10:04 pm

Re: AmigaOne X5000 - FreeBSD Only

Postby Skateman » Mon Nov 05, 2018 10:33 pm

@chmeee

Could you give me the output of your command dmesg |grep eth

skateman@X5000LNX:~$ dmesg |grep eth
[ 5.923682] fsl_dpaa_mac ffe4e6000.ethernet: FMan dTSEC version: 0x08240101
[ 5.924476] fsl_dpaa_mac ffe4e6000.ethernet: FMan MAC address: 00:04:a3:6b:41:7c
[ 5.924811] fsl_dpaa_mac ffe4e8000.ethernet: FMan dTSEC version: 0x08240101
[ 5.925202] fsl_dpaa_mac ffe4e8000.ethernet: FMan MAC address: 00:1e:c0:f8:31:b5
[ 5.925455] fsl_dpaa_mac ffe4e0000.ethernet: of_get_mac_address(/soc@ffe000000/fman@400000/ethernet@e0000) failed
[ 5.925665] fsl_dpaa_mac: probe of ffe4e0000.ethernet failed with error -22
[ 5.925831] fsl_dpaa_mac ffe4e2000.ethernet: of_get_mac_address(/soc@ffe000000/fman@400000/ethernet@e2000) failed
[ 5.926035] fsl_dpaa_mac: probe of ffe4e2000.ethernet failed with error -22
[ 5.926205] fsl_dpaa_mac ffe4e4000.ethernet: of_get_mac_address(/soc@ffe000000/fman@400000/ethernet@e4000) failed
[ 5.926431] fsl_dpaa_mac: probe of ffe4e4000.ethernet failed with error -22
[ 5.931246] fsl_dpaa_mac ffe4f0000.ethernet: of_get_mac_address(/soc@ffe000000/fman@400000/ethernet@f0000) failed
[ 5.936167] fsl_dpaa_mac: probe of ffe4f0000.ethernet failed with error -22
[ 5.943283] fsl_dpaa_mac ffe4e6000.ethernet eth0: Probed interface eth0
[ 5.950269] fsl_dpaa_mac ffe4e8000.ethernet eth1: Probed interface eth1
[ 12.659922] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 12.660691] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 12.695396] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[ 12.696141] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[ 93.466321] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 344.816821] device eth0 entered promiscuous mode
[ 370.958485] device eth0 left promiscuous mode
[ 442.274641] asix 1-1.3.4.3:1.0 eth2: register 'asix' at usb-fsl-ehci.0-1.3.4.3, ASIX AX88772B USB 2.0 Ethernet, 00:0e:c6:f4:d3:c7
[ 442.281401] asix 1-1.3.4.3:1.0 enx000ec6f4d3c7: renamed from eth2
[ 512.324022] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 525.058597] device eth0 entered promiscuous mode
[ 559.304853] device eth0 left promiscuous mode

Thanks.
AmigaOne X5000 -> 2GHz / 16GB RAM / Radeon R7 250 / M-Audio 5.1 -> AmigaOS 4.1 FE / Ubuntu Linux
Amiga 1200 -> Recapped / 68ec020 ACA 1221ec / CF HDD / RetroNET connected to the world
User avatar
Skateman
 
Posts: 354
Joined: Thu Aug 10, 2017 9:36 pm
Location: The Netherlands

Re: AmigaOne X5000 - FreeBSD Only

Postby chmeee » Fri Jan 18, 2019 8:08 pm

@Skateman I don't have Linux on mine, so here's the output of dmesg | grep dtsec:

dtsec0: <Freescale Data Path Triple Speed Ethernet Controller> mem 0xe6000-0xe6fff on fman0
dtsec0: Configured for regular mode.
dtsec0: TX hw port 0xab000 initialized.
dtsec0: RX hw port 0x8b000 initialized.
miibus0: <MII bus> on dtsec0
dtsec0: bpf attached
dtsec0: Ethernet address: 00:50:c2:20:db:11
dtsec1: <Freescale Data Path Triple Speed Ethernet Controller> mem 0xe8000-0xe8fff on fman0
dtsec1: Configured for regular mode.
dtsec1: TX hw port 0xac000 initialized.
dtsec1: RX hw port 0x8c000 initialized.
miibus1: <MII bus> on dtsec1
dtsec1: bpf attached
dtsec1: Ethernet address: 00:50:c2:20:db:12
dtsec2: <Freescale Data Path Triple Speed Ethernet Controller> mem 0xe0000-0xe0fff on fman0
dtsec2: Could not load local-mac-addr property from DTS
device_attach: dtsec2 attach returned 6
dtsec2: <Freescale Data Path Triple Speed Ethernet Controller> mem 0xe2000-0xe2fff on fman0
dtsec2: Could not load local-mac-addr property from DTS
device_attach: dtsec2 attach returned 6
dtsec2: <Freescale Data Path Triple Speed Ethernet Controller> mem 0xe4000-0xe4fff on fman0
dtsec2: Could not load local-mac-addr property from DTS
device_attach: dtsec2 attach returned 6
dtsec2: <Freescale Data Path Triple Speed Ethernet Controller> mem 0xf0000-0xf0fff on fman0
dtsec2: Could not load local-mac-addr property from DTS
device_attach: dtsec2 attach returned 6
Sending DHCP Discover packet from interface dtsec0 (00:50:c2:20:db:11)
Sending DHCP Discover packet from interface dtsec1 (00:50:c2:20:db:12)
dtsec0: link state changed to UP
dtsec1: link state changed to DOWN
Received DHCP Offer packet on dtsec0 from 192.168.1.1 (accepted)
Received DHCP Offer packet on dtsec0 from 192.168.1.1 (ignored)
Sending DHCP Request packet from interface dtsec0 (00:50:c2:20:db:11)
Received DHCP Ack packet on dtsec0 from 192.168.1.1 (accepted)
DHCP timeout for interface dtsec1
dtsec0 at 192.168.1.140 server 192.168.1.1
Adjusted interface dtsec0
Shutdown interface dtsec1
chmeee
 
Posts: 8
Joined: Wed Mar 07, 2018 10:04 pm

Re: AmigaOne X5000 - FreeBSD Only

Postby Skateman » Fri Jan 18, 2019 8:37 pm

Thanks a lot.

How did you manage to generate the dmesg output without having linux ? Uboot ??
AmigaOne X5000 -> 2GHz / 16GB RAM / Radeon R7 250 / M-Audio 5.1 -> AmigaOS 4.1 FE / Ubuntu Linux
Amiga 1200 -> Recapped / 68ec020 ACA 1221ec / CF HDD / RetroNET connected to the world
User avatar
Skateman
 
Posts: 354
Joined: Thu Aug 10, 2017 9:36 pm
Location: The Netherlands

Re: AmigaOne X5000 - FreeBSD Only

Postby chmeee » Fri Jan 18, 2019 9:05 pm

It came from FreeBSD, so I don't know how useful it is to you.

I found the other day one remaining problem with the FreeBSD dTSEC driver, which I have a patch for, just haven't committed. It's only relevant in 64-bit mode, but that's how I run FreeBSD on my X5000. Without the patch, nginx doesn't work. I plan to commit the patch tonight or tomorrow.
chmeee
 
Posts: 8
Joined: Wed Mar 07, 2018 10:04 pm

Re: AmigaOne X5000 - FreeBSD Only

Postby Skateman » Fri Jan 18, 2019 9:23 pm

At this point i wont help me that much...but then again all info might fall into place one day.

Good to see that the adapter gets probed and works like it should within FreeBSD. (only the Mac addresses are still not the original X5K macs )
AmigaOne X5000 -> 2GHz / 16GB RAM / Radeon R7 250 / M-Audio 5.1 -> AmigaOS 4.1 FE / Ubuntu Linux
Amiga 1200 -> Recapped / 68ec020 ACA 1221ec / CF HDD / RetroNET connected to the world
User avatar
Skateman
 
Posts: 354
Joined: Thu Aug 10, 2017 9:36 pm
Location: The Netherlands

Re: AmigaOne X5000 - FreeBSD Only

Postby daz » Sun Jan 27, 2019 5:58 pm

Skateman wrote:At this point i wont help me that much...but then again all info might fall into place one day.

Good to see that the adapter gets probed and works like it should within FreeBSD. (only the Mac addresses are still not the original X5K macs )

Not sure what you mean about mac addresses, the ones in his dmesg look correct to me - all the ones I've seen printed on boards and programmed into mac roms start with 00:50:c2.. like his do.

FYI the ethernet was probed and worked correctly when we used the Freescale linux SDK to build kernels, so a fix is possible, we just don't know what it is yet.

Regards
Darren
daz
Beta Tester
Beta Tester
 
Posts: 311
Joined: Tue Dec 21, 2010 8:32 pm

Re: AmigaOne X5000 - FreeBSD Only

Postby xeno74 » Sun Jan 27, 2019 6:01 pm

daz wrote:
Skateman wrote:At this point i wont help me that much...but then again all info might fall into place one day.

Good to see that the adapter gets probed and works like it should within FreeBSD. (only the Mac addresses are still not the original X5K macs )

Not sure what you mean about mac addresses, the ones in his dmesg look correct to me - all the ones I've seen printed on boards and programmed into mac roms start with 00:50:c2.. like his do.

FYI the ethernet was probed and worked correctly when we used the Freescale linux SDK to build kernels, so a fix is possible, we just don't know what it is yet.

Regards
Darren


Could you please release your latest Freescale kernel?

-- Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 5253
Joined: Fri Mar 23, 2012 8:58 am

Re: AmigaOne X5000 - FreeBSD Only

Postby Skateman » Sun Jan 27, 2019 8:51 pm

daz wrote:
Skateman wrote:At this point i wont help me that much...but then again all info might fall into place one day.

Good to see that the adapter gets probed and works like it should within FreeBSD. (only the Mac addresses are still not the original X5K macs )

Not sure what you mean about mac addresses, the ones in his dmesg look correct to me - all the ones I've seen printed on boards and programmed into mac roms start with 00:50:c2.. like his do.

FYI the ethernet was probed and worked correctly when we used the Freescale linux SDK to build kernels, so a fix is possible, we just don't know what it is yet.

Regards
Darren


Hi Darren,

The later batches of the X5000 boards, do not have any Mac addresses printed on them. The Mac addresses starting with the 00:50 are all IEEE Registration Authority macs, but is not the real Hardware macs of the component on the board. This is a know issue at Amigakit where i bought my system. After contacting amigakit i was given the solution to get hold of the real macs that belongs to the hardware on the board. See below.



Date Submitted: Tuesday 23 January, 2018
Hi,

Currently its a known issue with the current uboot, which is being investigated.
A work around, is to reflash old firmware, take note of macs, then reflash new firmware and add them manually to uboot.

Ok, you need Win32 Disk Imager. Please download that on your PC.
One downloaded, run and insert your SD card. Download and unzip this file;

http://technical.leamancomputing.com/Te ... s_5020.zip <---------OLD FIRMWARE
http://technical.leamancomputing.com/Te ... 7-4-17.zip <---------CURRENT FIRMWARE

Extract and point Win32 Disk Imager to the bin file. Then click "WRITE". Make sure you have the correct drive selected before pressing "WRITE".

Once its written, place in motherboard. Boot, go to Startup Menu and select system info. It will display MAC addresses (stored internally in chips). Note them down. Power down and insert old SD card.
Boot back up and go into Startup Menu and select "Command Line". Now type; set ethaddr "YOUR NOTED MAC ADDRESS" press return to temp store command, then do same for ethaddr1. Once done. Type saveenv and then press enter. It should now permanantly store the values.

You can check by typing printenv and then press Retur n. It should have MAC addresses stored.



So now if i lookup my mac address 00:04:a3:6b:41:7c the outcome is Microchip Technology Inc which is the correct hardware vendor of the onboard Ethernet adapter as can be found in the X5000 manual.

Then again, using a IEEE Registration Authority mac should not be the problem, but i just wanted to have the correct values that belong to the hardware of my X5000.
AmigaOne X5000 -> 2GHz / 16GB RAM / Radeon R7 250 / M-Audio 5.1 -> AmigaOS 4.1 FE / Ubuntu Linux
Amiga 1200 -> Recapped / 68ec020 ACA 1221ec / CF HDD / RetroNET connected to the world
User avatar
Skateman
 
Posts: 354
Joined: Thu Aug 10, 2017 9:36 pm
Location: The Netherlands

PreviousNext

Return to Platform: AmigaOne X5000 - Linux Only

Who is online

Users browsing this forum: No registered users and 0 guests

cron