How to play DVD Movies on X1000

AmigaOne X1000 platform specific issues.

How to play DVD Movies on X1000

Postby amigasociety » Sat Feb 18, 2012 5:49 am

I insert a DVD and it appears on the desktop. I then launch DVplayer and select OPEN DVD/CD, the DVD light on drive blinks, but no movie plays. It does this forever and seems to almost take over much of the CPU power as launching others apps, etc... go real slow minutes later.

So, how do I play DVDs on the X1000?

tj
Happy owner of several Amiga systems including:

AmigaOne X5000
Amiga A1222 Tabor
User avatar
amigasociety
 
Posts: 306
Joined: Thu Feb 02, 2012 8:09 pm
Location: Northern California

Re: How to play DVD Movies on X1000

Postby Slayer » Sat Feb 18, 2012 6:05 am

First things first

What are your DVDRom specs and have you tried a selection DVDs as a comparison?

I just booted up AOS4.1.5 FC and used the version of DvPLayer supplied to play the first DVD I inserted which happened to be a training DVD for driving :D
~Yes I am a Kiwi, No, I did not appear as an extra in 'Lord of the Rings'~
1x AmigaOne X5000 2.0GHz 2gM RadeonR9280X AOS4.x
3x AmigaOne X1000 1.8GHz 2gM RadeonHD7970 AOS4.x
User avatar
Slayer
Beta Tester
Beta Tester
 
Posts: 851
Joined: Tue Dec 21, 2010 5:19 am
Location: New Zealand

Re: How to play DVD Movies on X1000

Postby tonyw » Sat Feb 18, 2012 7:05 am

If you try to play a protected DVD but don't have the DVCSS libraries and codecs installed, it will hang like that because the drive gives "errors" and the driver is retrying because nothing seems wrong.

So if it is a commercial DVD, it's probably protected. I can't remember what has to be loaded and installed, but for legal reasons you'll have to download them yourself. I'm sure someone will quote the files needed and where to get them.
cheers
tony
User avatar
tonyw
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 1361
Joined: Wed Mar 09, 2011 2:36 pm
Location: Sydney, Australia

Re: How to play DVD Movies on X1000

Postby Slayer » Sat Feb 18, 2012 7:19 am

Yes, grab this

http://os4depot.net/index.php?function= ... player.lha

hopefully this solves your problem otherwise it could be those annoying region problems some people have encountered
~Yes I am a Kiwi, No, I did not appear as an extra in 'Lord of the Rings'~
1x AmigaOne X5000 2.0GHz 2gM RadeonR9280X AOS4.x
3x AmigaOne X1000 1.8GHz 2gM RadeonHD7970 AOS4.x
User avatar
Slayer
Beta Tester
Beta Tester
 
Posts: 851
Joined: Tue Dec 21, 2010 5:19 am
Location: New Zealand

Re: How to play DVD Movies on X1000

Postby ChrisH » Sat Feb 18, 2012 11:06 am

@amigasociety
There are several things which need to be correct to be able to play most commercial DVDs, which are usually encrypted. So it would be better if you can find some "Region 0" (unencrypted) DVDs to test first. Any DVD recorded by a home DVD recorder will be Region 0, but some (usually more obscure) commercial DVDs can be Region 0. Also dodgy pirate DVDs (e.g. from Hong Kong) are usually Region 0.

If Region 0 works, then the problem is probably DVD encryption & region encoding (which are basically the same thing). In that case you need to ensure that (a) DVPlayer has the right plugins to decode the DVDs, and (b) that your DVD drive has the correct region set (there is a tool on OS4Depot for checking & setting this).

P.S. Also make sure that you have installed all the extra audio codecs for DVPlayer, which are required for certain DVDs.
User avatar
ChrisH
Beta Tester
Beta Tester
 
Posts: 915
Joined: Mon Dec 20, 2010 10:09 pm

Re: How to play DVD Movies on X1000

Postby Slayer » Sat Feb 18, 2012 11:13 am

~Yes I am a Kiwi, No, I did not appear as an extra in 'Lord of the Rings'~
1x AmigaOne X5000 2.0GHz 2gM RadeonR9280X AOS4.x
3x AmigaOne X1000 1.8GHz 2gM RadeonHD7970 AOS4.x
User avatar
Slayer
Beta Tester
Beta Tester
 
Posts: 851
Joined: Tue Dec 21, 2010 5:19 am
Location: New Zealand

Re: How to play DVD Movies on X1000

Postby amigasociety » Sat Feb 18, 2012 7:02 pm

Getting video now but no audio.

Installed the avcodec_lib and dvddvplayer files as an FYI.

So now video but no audio.

From main menu tried audio boost check box made no difference.

So what does it take to get audio from the DVDs?

Is this a X1000 MB not using audio port yet and we are using a 3rd party sound card thing?

Anyone else playing DVDs with audio on stock X1000 FC?

tj
Happy owner of several Amiga systems including:

AmigaOne X5000
Amiga A1222 Tabor
User avatar
amigasociety
 
Posts: 306
Joined: Thu Feb 02, 2012 8:09 pm
Location: Northern California

Re: How to play DVD Movies on X1000

Postby AmigaNG » Sat Feb 18, 2012 7:22 pm

Pleased you asked the same question i have. PS: Dvplayer plays sound of the AmigaOS vid just fineon my system any way, so I did find it odd no audio when I played a DVD.
2012 - the year I got a new Amiga and the world ended.....a good year.
User avatar
AmigaNG
 
Posts: 28
Joined: Thu Feb 16, 2012 4:17 pm

Re: How to play DVD Movies on X1000

Postby Slayer » Sun Feb 19, 2012 12:33 am

The final part

create this directory in Libs:

avcodecs

eg sys:libs/avcodes

download these two files

http://os4depot.net/index.php?function= ... vcodec.lha
http://os4depot.net/index.php?function= ... vcodec.lha

There is only 1 file you need out of each of these archives and that resides in the bin directory of each seperate archive, copy this file to your newly created avcodes directory

hence there should be the following 2 files inside

a52.codec
dca.codec

reset your machine and you shall have music, sweet sweet music ;)
~Yes I am a Kiwi, No, I did not appear as an extra in 'Lord of the Rings'~
1x AmigaOne X5000 2.0GHz 2gM RadeonR9280X AOS4.x
3x AmigaOne X1000 1.8GHz 2gM RadeonHD7970 AOS4.x
User avatar
Slayer
Beta Tester
Beta Tester
 
Posts: 851
Joined: Tue Dec 21, 2010 5:19 am
Location: New Zealand

Re: How to play DVD Movies on X1000

Postby amigasociety » Sun Feb 19, 2012 4:20 am

Success! Thanks much.

Now I can enjoy flicks on the nice 27" Samsung Display while I do some work.

TJ
Happy owner of several Amiga systems including:

AmigaOne X5000
Amiga A1222 Tabor
User avatar
amigasociety
 
Posts: 306
Joined: Thu Feb 02, 2012 8:09 pm
Location: Northern California

Next

Return to Platform: AmigaOne X1000

Who is online

Users browsing this forum: No registered users and 2 guests