Advice needed

AmigaOne X5000 platform specific issues related to Linux only.

Advice needed

Postby kilaueabart » Mon Jan 21, 2019 7:00 pm

For a few days now I have noticed a lot of the following while booting and shutting down Ubuntu:
Code: Select all
[  289.426606] usb 2-1-port4: attempt power cycle
[  290.928175] usb 2-1.4: new full-speed USB device number 125 using fsl-ehci
[  291.004216] usb 2-1.4: device descriptor read/64, error -32
[  291.183304] usb 2-1.4: device descriptor read/64, error -32
Running dmesg brings up a hundred or so. I managed to kill a couple of hours not finding a clear solution with Google.

Wondering if it might be an Ubuntu thing, I booted fienix with the same results, but when I ran dmesg there I was told to run fsck because /dev/sdb1 and /dev/sdc1 were "not properly unmounted ..." Trying to run fsck in fienix got me a "no such command" reply, and an attempt to install it failed, so back to Ubuntu, where I had this result:
Code: Select all
bart@X5000:~$ sudo fsck /dev/sdb1
fsck from util-linux 2.27.1
fsck.fat 3.0.28 (2015-05-16)
0x41: Dirty bit is set. Fs was not properly unmounted and some data may be corrupt.
1) Remove dirty bit
2) No action

Not knowing what a dirty bit is (I use a lot of kernels with a dirty something or other) I was afraid to remove it, and "2" brought me a new option:
Code: Select all
There are differences between boot sector and its backup.
This is mostly harmless. Differences: (offset:original/backup)
  65:01/00, 71:55/20, 72:42/20, 73:55/20, 74:4e/20, 75:54/20, 76:55/20
1) Copy original to backup
2) Copy backup to original
3) No action

I chickened out again, and got a final option:
Code: Select all
Reserved field in VFAT long filename slot is not 0 (but 0x61).
1: Fix.
2: Leave it.

fsck /dev/sdc1 got sdb1's first and last options followed by a new one:
Code: Select all
A new long file name starts within an old one.
  It could be that the LFN start bit is wrong here
  if "perian.ps" seems to match "".
1: Delete previous LFN
2: Leave it as it is.
3: Clear start bit and concatenate LFNs

Another possibility that occurs to me is to let GParted try to fix those partitions. Neither is terribly important. /dev/sdb1 is mainly left over from earlier Ubuntu boots; I use /dev/sdc1 a lot to pass info among my systems. But then I am not sure that either of these device problems is related to the device descriptor read errors I am plagued with.

Advice?
User avatar
kilaueabart
 
Posts: 613
Joined: Mon Mar 05, 2012 3:36 am

Re: Advice needed

Postby xeno74 » Mon Jan 21, 2019 9:58 pm

Did you remove the USB stick while the X5000 runs? Were there any problems with shutting down the X5000?

— Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 5161
Joined: Fri Mar 23, 2012 8:58 am

Re: Advice needed

Postby Skateman » Mon Jan 21, 2019 10:20 pm

You could also move the Kernel files to your SD card...

viewtopic.php?f=58&t=3707&p=41033&hilit=mmc#p41033

I have done this a while ago and works perfect.
AmigaOne X5000 -> 2GHz / 16GB RAM / Radeon R7 250 / M-Audio 5.1 -> AmigaOS 4.1 FE / Ubuntu Linux
Amiga 1200 -> Recapped / 68ec020 ACA 1221ec / CF HDD / RetroNET connected to the world
User avatar
Skateman
 
Posts: 333
Joined: Thu Aug 10, 2017 9:36 pm
Location: The Netherlands

Re: Advice needed

Postby kilaueabart » Wed Jan 23, 2019 2:10 am

Skateman wrote:You could also move the Kernel files to your SD card...

I think I tried to do this once some time ago. Not sure whether I was in any degree successful. GParted shows /dev/mmcblk0p1 as a slightly used 2.73 GiB space between two unallocated partitions of 512 iB each.
The content of /dev/mmcblk0p1 lists as:
Code: Select all

cyrus-4.13.11-jm.config
cyrus-4.19.0-rc1-jm-config
cyrus_5020.dtb
cyrus_p5020_eth_poweroff.dtb
installer.scr
lost+found
System.map
Ubuntu-Mate_Installer_Uboot_Script.txt
uImage-4.18
uImage-4.19
uImage-cyrus
uRamdisk
X5000_U-Boot_Commands.txt

Opening SD card on Desktop shows the same files along with size and dates (which run from Dec 2017 to Aug 2018). How close is this to what you are suggesting? If that is already it, how would I address it in my Ubuntu and fienix run scripts? "fatload usb 0:1" looks at one of my thumb drives. Well, I guess I will go ahead and try "ext4ls mmc 0:1" in the meantime, wondering if "ext4ls" substitutes for "fatload."
User avatar
kilaueabart
 
Posts: 613
Joined: Mon Mar 05, 2012 3:36 am

Re: Advice needed

Postby kilaueabart » Thu Jan 24, 2019 2:51 am

xeno74 wrote:Did you remove the USB stick while the X5000 runs? Were there any problems with shutting down the X5000?

The first time I read this, I took it as a suggestion: Remove the thumb drive and see if that solves the problem. I didn't try it right away because of the difficulty in finding out which drive I should try.

Rereading today, it sounds more like, "Maybe you caused the problem by removing a USB drive while the computer was running." If so, the answer to the question is no. I have not removed any drives.

Somehow I previously managed to get kernels and the cyrus .dtb onto my SD card, although I don't think I ever used them for booting as I wanted to. I tried to do so yesterday with the "ext4ls mmc 0:1" someone suggested second-handedly in this thread, but UBoot apparently didin't understand what I wanted it to do.

More puzzling: I can't figure out how to add newer kernels to my SD card. I tried "sudo cp" and got no error message, but no change on the SD card. I'd also like to delete some of the junk on the card, in case I can sooner or later use it instead of the thumbdrive, but I haven't been able to figure that out either.

Oh, and the second question. Starting last night, shutting down takes a bit longer. It keeps telling me it is running something for 1 min 30 sec, over and over, mixed with the device descriptor read error.
User avatar
kilaueabart
 
Posts: 613
Joined: Mon Mar 05, 2012 3:36 am


Return to Platform: AmigaOne X5000 - Linux Only

Who is online

Users browsing this forum: No registered users and 2 guests