Fienix - New PowerPC Distro

AmigaOne X5000 platform specific issues related to Linux only.

Re: Fienix - New PowerPC Distro

Postby Roland » Fri Jan 25, 2019 4:09 pm

caseycullen wrote:Are you using Fienix?

Sure.

Open Arctic Fox. Click Tools > Add-ons. This will open the Add-ons Manager.
Click on "Extensions". Make sure you see "Greasemonkey".
Click on "Plugins". Make sure you see "VLC Web Plugin" and it is set to "Always Activate".
Click on "User Scripts". My guess is that you do not have "ViewTube" and "ViewTube+" installed.
If you do not see ViewTube and ViewTube+ under User Scripts, go to http://sebaro.pro/viewtube/.
On the top of the page you will see download icons for both of these user scripts. When you click on them it should bring up a dialog where you can click Install. Do that for both ViewTube and ViewTube+.
Let me know if you have any issues.

Thanks, got the scripts installed! Now I can see in Youtube the 'Get' botton... But clicking it did not download the video directly, but there appeared another button beside it, and clicking that run the video in a new window, and clicking that with the right mouse button showed a menu which had the option "Save to disk...". Is all that the 'normal' way to do it, or is there still an issue...?
- Roland -
Roland
 
Posts: 272
Joined: Tue May 02, 2017 8:23 am

Re: Fienix - New PowerPC Distro

Postby Roland » Fri Jan 25, 2019 4:20 pm

caseycullen wrote:Arctic Fox has been upgraded to 12.9.14 in the Fienix repository. It has many bugfixes and updates, and some webpage rendering issues have been fixed (such as github). Please test the latest, greatest Arctic Fox :)
-Casey

Installed and tested! There is still some issue with Livestream videos... With the 12.9.13 I was able to see videos from the National broadcast company, but no sound. When trying the same with 12.9.14 the browser just closes itself, no error messages. The same happens even with the home page of that company...

Ubuntu 16.04.5 and Arctic Fox 12.9.14 (Christian's package) do not have that issue, it is only with Fienix.
- Roland -
Roland
 
Posts: 272
Joined: Tue May 02, 2017 8:23 am

Re: Fienix - New PowerPC Distro

Postby caseycullen » Sun Jan 27, 2019 6:42 am

That is how the "Get" button works.
-Casey

Roland wrote:
caseycullen wrote:Are you using Fienix?

Sure.

Open Arctic Fox. Click Tools > Add-ons. This will open the Add-ons Manager.
Click on "Extensions". Make sure you see "Greasemonkey".
Click on "Plugins". Make sure you see "VLC Web Plugin" and it is set to "Always Activate".
Click on "User Scripts". My guess is that you do not have "ViewTube" and "ViewTube+" installed.
If you do not see ViewTube and ViewTube+ under User Scripts, go to http://sebaro.pro/viewtube/.
On the top of the page you will see download icons for both of these user scripts. When you click on them it should bring up a dialog where you can click Install. Do that for both ViewTube and ViewTube+.
Let me know if you have any issues.

Thanks, got the scripts installed! Now I can see in Youtube the 'Get' botton... But clicking it did not download the video directly, but there appeared another button beside it, and clicking that run the video in a new window, and clicking that with the right mouse button showed a menu which had the option "Save to disk...". Is all that the 'normal' way to do it, or is there still an issue...?
caseycullen
 
Posts: 217
Joined: Sat Dec 17, 2016 8:12 am
Location: Madison, WI USA

Re: Fienix - New PowerPC Distro

Postby caseycullen » Sun Jan 27, 2019 6:44 am

Opening a Livestream doesn't close the browser for me, but I cannot hear audio. Interesting you can hear audio when running on Ubuntu...
Christian, any ideas about this?
-Casey

Roland wrote:
caseycullen wrote:Arctic Fox has been upgraded to 12.9.14 in the Fienix repository. It has many bugfixes and updates, and some webpage rendering issues have been fixed (such as github). Please test the latest, greatest Arctic Fox :)
-Casey

Installed and tested! There is still some issue with Livestream videos... With the 12.9.13 I was able to see videos from the National broadcast company, but no sound. When trying the same with 12.9.14 the browser just closes itself, no error messages. The same happens even with the home page of that company...

Ubuntu 16.04.5 and Arctic Fox 12.9.14 (Christian's package) do not have that issue, it is only with Fienix.
caseycullen
 
Posts: 217
Joined: Sat Dec 17, 2016 8:12 am
Location: Madison, WI USA

Re: Fienix - New PowerPC Distro

Postby xeno74 » Sun Jan 27, 2019 2:39 pm

caseycullen wrote:Opening a Livestream doesn't close the browser for me, but I cannot hear audio. Interesting you can hear audio when running on Ubuntu...
Christian, any ideas about this?
-Casey


It's the same with Fienix on my AmigaOne X1000. Opening a livestream doesn't close Arctic Fox but I cannot hear audio either. The livestream works with audio on ubuntu MATE 16.04.5 LTS PowerPC. I tested it with the livestream by DW-TV (https://www.dw.com/de/media-center/live ... ?channel=1). Unfortunately I don't know why the audio of the livestream doesn't work on Fienix.

-- Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 4883
Joined: Fri Mar 23, 2012 8:58 am

Re: Fienix - New PowerPC Distro

Postby Roland » Mon Jan 28, 2019 11:09 am

xeno74 wrote:It's the same with Fienix on my AmigaOne X1000. Opening a livestream doesn't close Arctic Fox but I cannot hear audio either. The livestream works with audio on ubuntu MATE 16.04.5 LTS PowerPC. I tested it with the livestream by DW-TV (https://www.dw.com/de/media-center/live ... ?channel=1). Unfortunately I don't know why the audio of the livestream doesn't work on Fienix.


I found out that the problem of livestream (or even the home page of the National broadcast company) closing Arctic Fox is NOT Fienix specific but it depends on how the 'Preferences/Content/Load Images:' has been set. If it is set to 'Automatically' or 'Originating server only' the problems exists. If it is set to 'Never', videos or the home page do not close Arctic Fox. Here is the link to the company's home page: http://areena.yle.fi/tv . Does it behave the same way in your machine, if you test the different 'Load images:' settings?
- Roland -
Roland
 
Posts: 272
Joined: Tue May 02, 2017 8:23 am

Re: Fienix - New PowerPC Distro

Postby caseycullen » Mon Jan 28, 2019 7:33 pm

Visiting that site closes Arctic Fox for me as well. Error: "/usr/bin/arcticfox: line 3: 12943 Segmentation fault ./arcticfox"

Arctic Fox does not close if "Load Images: Never", but the video does not load either. Does the video load for you if you set "Load Images: Never"? This makes me think that maybe the problem is with how Arctic Fox tries to handle that media type.

I also tried to disable Greasemonkey to make sure that extension wasn't causing the issue, but it makes no difference.

Just to clarify, does Arctic Fox close if visiting that site on Ubuntu?

-Casey

Roland wrote:I found out that the problem of livestream (or even the home page of the National broadcast company) closing Arctic Fox is NOT Fienix specific but it depends on how the 'Preferences/Content/Load Images:' has been set. If it is set to 'Automatically' or 'Originating server only' the problems exists. If it is set to 'Never', videos or the home page do not close Arctic Fox. Here is the link to the company's home page: http://areena.yle.fi/tv . Does it behave the same way in your machine, if you test the different 'Load images:' settings?
caseycullen
 
Posts: 217
Joined: Sat Dec 17, 2016 8:12 am
Location: Madison, WI USA

Re: Fienix - New PowerPC Distro

Postby Skateman » Mon Jan 28, 2019 10:43 pm

caseycullen wrote:Visiting that site closes Arctic Fox for me as well. Error: "/usr/bin/arcticfox: line 3: 12943 Segmentation fault ./arcticfox"

Arctic Fox does not close if "Load Images: Never", but the video does not load either. Does the video load for you if you set "Load Images: Never"? This makes me think that maybe the problem is with how Arctic Fox tries to handle that media type.

I also tried to disable Greasemonkey to make sure that extension wasn't causing the issue, but it makes no difference.

Just to clarify, does Arctic Fox close if visiting that site on Ubuntu?

-Casey

Roland wrote:I found out that the problem of livestream (or even the home page of the National broadcast company) closing Arctic Fox is NOT Fienix specific but it depends on how the 'Preferences/Content/Load Images:' has been set. If it is set to 'Automatically' or 'Originating server only' the problems exists. If it is set to 'Never', videos or the home page do not close Arctic Fox. Here is the link to the company's home page: http://areena.yle.fi/tv . Does it behave the same way in your machine, if you test the different 'Load images:' settings?



Arctic Fox does also crash on Ubuntu 16.04.5 LTS when visiting http://areena.yle.fi/tv

The error: 28 21:39:08 X5000LNX kernel: [ 609.139851] arcticfox[5860]: bad frame in handle_rt_signal32: 00000000110f056b nip 0ddaab98 lr 00100430

Firefox survived... but the memory usage is massive! 270MB just loading the site...

Image
AmigaOne X5000 -> 2GHz / 16GB RAM / Radeon R7 250 / M-Audio 5.1 -> AmigaOS 4.1 FE / Ubuntu Linux
Amiga 1200 -> Recapped / 68ec020 ACA 1221ec / CF HDD / RetroNET connected to the world
User avatar
Skateman
 
Posts: 311
Joined: Thu Aug 10, 2017 9:36 pm
Location: The Netherlands

Re: Fienix - New PowerPC Distro

Postby caseycullen » Mon Jan 28, 2019 11:01 pm

Thanks for testing; I'll make the developer aware.
-Casey

Skateman wrote:Arctic Fox does also crash on Ubuntu 16.04.5 LTS when visiting http://areena.yle.fi/tv

The error: 28 21:39:08 X5000LNX kernel: [ 609.139851] arcticfox[5860]: bad frame in handle_rt_signal32: 00000000110f056b nip 0ddaab98 lr 00100430
caseycullen
 
Posts: 217
Joined: Sat Dec 17, 2016 8:12 am
Location: Madison, WI USA

Re: Fienix - New PowerPC Distro

Postby Roland » Tue Jan 29, 2019 12:42 pm

caseycullen wrote:Visiting that site closes Arctic Fox for me as well. Error: "/usr/bin/arcticfox: line 3: 12943 Segmentation fault ./arcticfox"

Arctic Fox does not close if "Load Images: Never", but the video does not load either. Does the video load for you if you set "Load Images: Never"? This makes me think that maybe the problem is with how Arctic Fox tries to handle that media type.


At least last time I tested with a direct link to a video it loaded when "Load images:" was 'Never'. The only problem was the missing sound...

Just to clarify, does Arctic Fox close if visiting that site on Ubuntu?


Yes, when the image loading is enabled. Have not been able to test with Fedora27 as there videos do not work at all. Maybe an altivec dependency problem, or missing codecs...
- Roland -
Roland
 
Posts: 272
Joined: Tue May 02, 2017 8:23 am

PreviousNext

Return to Platform: AmigaOne X5000 - Linux Only

Who is online

Users browsing this forum: No registered users and 2 guests