Gigabit ethernet ports

AmigaOne X5000 platform specific issues related to Linux only.

Re: Gigabit ethernet ports

Postby Spectre660 » Tue Apr 25, 2017 8:46 pm

daz wrote:
Spectre660 wrote:This appears to be exactly the same as the original dtb which is on the Ubuntu MATE Live USB .
So maybe the issue is with the actual .configs used to compile the kernels.

1350d37eb24c3465d6e255f4f6883610 *cyrus_5020.dtb
1350d37eb24c3465d6e255f4f6883610 *cyrus_5020_ethernet.dtb

Yes, these are the ones supplied with the original fsl-sdk-1.7 kernel based on 3.8. It worked on quite a few later kernels too. Something has changed in the kernel source, I'm not sure what.

I am investigating.

Regards
Darren


Remember that the original patches have not been applied since kernel 4.4 so this may be when the problem originated.

This may be the only thing changed to support the Cyrus in the mainline kernel so the onboard Ethernet may have been forgotten.
https://git.kernel.org/pub/scm/linux/ke ... 4bde25eb15
Spectre660
 
Posts: 1260
Joined: Sat Jun 18, 2011 3:16 pm
Location: Montserrat

Re: Gigabit ethernet ports

Postby marcus » Fri Apr 28, 2017 6:43 pm

This commit may be relevant:
https://git.kernel.org/pub/scm/linux/ke ... edcf69e29d
It adds PHY topology info to a lot of QorIQ boards, but not to the Cyrus one...
marcus
 
Posts: 53
Joined: Wed Nov 07, 2012 9:07 pm

Re: Gigabit ethernet ports

Postby Spectre660 » Fri Apr 28, 2017 10:54 pm

@Marcus
I cross compiling an X5000 4.9.25 kernel using the original patches before the 4.x branch if you want to give it a try.
Disclaimer :Totally untested as I don't have an X5000.
https://drive.google.com/open?id=0BxoZd ... EdkeFdkUm8
Spectre660
 
Posts: 1260
Joined: Sat Jun 18, 2011 3:16 pm
Location: Montserrat

Re: Gigabit ethernet ports

Postby marcus » Sun Apr 30, 2017 1:26 pm

@Spectre660

Well, here is what I did try:

* Get the 4.9.25 sources from kernel.org
* Apply the patch from your archive (some chunks failed though...)
* Build with my own kernel config (but enable CONFIG_CYRUS)
* Use my own DTB

Not really any improvement though. fsl_mac appears in dmesg like before, but fsl_dpa is gone, so I don't get any actual interfaces for ifconfig.

With the "original" DTB I don't even get fsl_mac.
marcus
 
Posts: 53
Joined: Wed Nov 07, 2012 9:07 pm

Re: Gigabit ethernet ports

Postby Spectre660 » Sun Apr 30, 2017 1:47 pm

@Marcus

Perhaps the .configuration from one of of Daz's kernels were the Ethernet works may be the best starting point.
Also knowing if his kernel was compiled from a main line branch or a special Freescale branch might shed some light .
My patches were taken from a patched 3.18 kernel source archive.
Spectre660
 
Posts: 1260
Joined: Sat Jun 18, 2011 3:16 pm
Location: Montserrat

Re: Gigabit ethernet ports

Postby marcus » Thu Jul 20, 2017 5:55 pm

I got some time do dig more into this, so I tried building kernel version 4.4.0 and 4.5.0, and booting them with the device tree present in the upstreams kernel sources for the respective version.

None of them gave me working gigabit ethernet; although the dmesg for 4.5.0 looked rather promising, no devices manifested in ifconfig.

So if there indeed exists a kernel build with working fsl ethernet, it would be very informative to learn

* Which kernel version sources were used
* Which patches to kernel code and/or DTS files were applied
* What configuration was used

to produce it. There's so many things that could be fiddled with that it seems impossible to progress without some kind of baseline...
marcus
 
Posts: 53
Joined: Wed Nov 07, 2012 9:07 pm

Previous

Return to Platform: AmigaOne X5000 - Linux Only

Who is online

Users browsing this forum: No registered users and 1 guest