(X)(L)ubuntu (MATE) 17.04 Zesty Zapus

AmigaOne X5000 platform specific issues related to Linux only.

(X)(L)ubuntu (MATE) 17.04 Zesty Zapus

Postby xeno74 » Fri Dec 23, 2016 10:48 am

Please look here: X1000 thread

This thread is also concerned to the X5000.
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 2932
Joined: Fri Mar 23, 2012 8:58 am

Re: (X)(L)ubuntu (MATE) 17.04 Zesty Zapus

Postby caseycullen » Tue Dec 27, 2016 6:20 am

xeno74 wrote:Please look here: X1000 thread

This thread is also concerned to the X5000.


I can apparently only post in the X5000 board...

Anyways, regarding:
"Phoronix wrote: With Debian Stretch dropping 32-bit PowerPC as a release architecture, Ubuntu is following a similar maneuver and will not be making 32-bit PPC images of future releases."

Since both the X1000 and X5000 are 64-bit, do you think it might be advantageous to consider opensuse, since they support ppc64 (and not just ppc64el like Debian is doing)?
caseycullen
 
Posts: 54
Joined: Sat Dec 17, 2016 8:12 am
Location: Madison, WI USA

Re: (X)(L)ubuntu (MATE) 17.04 Zesty Zapus

Postby JohnFante » Tue Dec 27, 2016 9:44 am

xeno74 wrote:Please look here: X1000 thread

This thread is also concerned to the X5000.


Great :-D

The guide covers upgrading 16.10. Does that mean that we have to upgrade the 16.04LTS to 16.10 first?

And is there something we have be aware of in that regard?
X5000 :-)
User avatar
JohnFante
Beta Tester
Beta Tester
 
Posts: 137
Joined: Tue Sep 04, 2012 7:48 am
Location: Copenhagen, Denmark

Re: (X)(L)ubuntu (MATE) 17.04 Zesty Zapus

Postby xeno74 » Tue Dec 27, 2016 10:45 am

JohnFante wrote:
xeno74 wrote:Please look here: X1000 thread

This thread is also concerned to the X5000.


Great :-D

The guide covers upgrading 16.10. Does that mean that we have to upgrade the 16.04LTS to 16.10 first?


Yes, that's right. Here are the upgrade instructions: (X)(L)ubuntu (MATE) 16.10 Yakkety Yak

JohnFante wrote:And is there something we have be aware of in that regard?


The firmware commands are all for the X1000. Please replace them with X5000 firmware commands.
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 2932
Joined: Fri Mar 23, 2012 8:58 am

Re: (X)(L)ubuntu (MATE) 17.04 Zesty Zapus

Postby xeno74 » Tue Dec 27, 2016 11:06 am

caseycullen wrote:
xeno74 wrote:Please look here: X1000 thread

This thread is also concerned to the X5000.


I can apparently only post in the X5000 board...


Yes, that's correct.

caseycullen wrote:Anyways, regarding:
"Phoronix wrote: With Debian Stretch dropping 32-bit PowerPC as a release architecture, Ubuntu is following a similar maneuver and will not be making 32-bit PPC images of future releases."


Unfortunately that is also correct but I will update my installed development version of ubuntu MATE 17.04 as long as possible. After that I will try to release an unofficial ubuntu MATE 17.04 USB img for the X5000 and X1000.

caseycullen wrote:Since both the X1000 and X5000 are 64-bit, do you think it might be advantageous to consider opensuse, since they support ppc64 (and not just ppc64el like Debian is doing)?


The userland of openSUSE and Fedora are 64-bit. Both of them are full 64-bit systems. Both work on the X5000 and X1000 but be aware, that openSUSE and Fedora are experimental and aren't supported. openSUSE and Fedora for the X1000 and X5000 are alpha software! They are only for testing and tinkering!

openSUSE Tumbleweed PPC64 on an AmigaONE X5000:

Image
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 2932
Joined: Fri Mar 23, 2012 8:58 am

Re: (X)(L)ubuntu (MATE) 17.04 Zesty Zapus

Postby JohnFante » Fri Dec 30, 2016 12:15 pm

xeno74 wrote:
JohnFante wrote:
xeno74 wrote:Please look here: X1000 thread

This thread is also concerned to the X5000.


Great :-D

The guide covers upgrading 16.10. Does that mean that we have to upgrade the 16.04LTS to 16.10 first?


Yes, that's right. Here are the upgrade instructions: (X)(L)ubuntu (MATE) 16.10 Yakkety Yak

JohnFante wrote:And is there something we have be aware of in that regard?


The firmware commands are all for the X1000. Please replace them with X5000 firmware commands.


I have upgraded to 16.10 on my X5000 but have found two problems where at least one of them makes the system more or less unuseable.

At least one of the problems I think is related to my kernel (I can only get the RC5 kernel that is supplied with the the 16.04 to run on my Radeon 270X) but I can not figure out what the other one is caused by.

The problem related to my kernel is that I get an error at the final stage of the upgrade saying that it can not run "cryptosetup". That is - as far as I know - related to an old kernel.

The other problem is that it can not start caja (the file browser) on boot. It tried to open and the icon comes up in the buttom panel but something goes wrong (no errrors) and then it continues to open the program five or six times at the same time. I have tried to install and change to the "nemo" filebrowser but without any luck. This last error makes the system more or less unuseable.

Unless you have a magic tip it is back to 16.04 LTS.
X5000 :-)
User avatar
JohnFante
Beta Tester
Beta Tester
 
Posts: 137
Joined: Tue Sep 04, 2012 7:48 am
Location: Copenhagen, Denmark

Re: (X)(L)ubuntu (MATE) 17.04 Zesty Zapus

Postby caseycullen » Fri Jan 06, 2017 5:28 am

I had ubuntu MATE running nicely on my X5000 from the SATA SSD. I tried to test an update on a USB first but I don't think I had enough freespace.

Attempted to update to 16.10. Followed instructions posted here. After "apt-get dist-upgrade" the upgrade proceeded, but a few times during the upgrade I noticed "update-initramfs is disabled since it is on read-only media"

When the upgrade finished there was this error:
"Errors were encountered while processing:
cryptsetup
ubiquity
ubiquity-frontend-gtk
E: Subprocess /usr/bin/dpkg returned an error code (1)"

I rebooted. System appears to startup OK to the point where the mouse cursor appears on a black screen, then flashes back and forth between the mouse cursor and a terminal screen that reads:
"[OK] Started TLP system startup/shutdown
[OK] Started update UTMP about System Runlevel Changes"

I can press Ctrl+Alt+F1 to enter terminal. I logged in and tried "update-initramfs", which gave the error "update-initramfs is disabled since running on read-only media"

Tried rebooting again, same thing happened - flash between black screen with mouse cursor and terminal with error message.

This is an old bug, but could it be related to this?

Any other ideas?
caseycullen
 
Posts: 54
Joined: Sat Dec 17, 2016 8:12 am
Location: Madison, WI USA

Re: (X)(L)ubuntu (MATE) 17.04 Zesty Zapus

Postby xeno74 » Fri Jan 06, 2017 12:54 pm

caseycullen wrote:Any other ideas?


I think the upgrade wasn't successful. Could you please check your free space with df -h?

Maybe you can do the sudo apt-get dist-upgrade again or maybe only the sudo apt-get upgrade. Sometimes LightDM doesn't start because it isn't configured. Please run sudo dpkg-reconfigure lightdm to configure LightDM.

I will forward your posting to the other team members.
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 2932
Joined: Fri Mar 23, 2012 8:58 am

Re: (X)(L)ubuntu (MATE) 17.04 Zesty Zapus

Postby caseycullen » Sat Jan 14, 2017 10:46 pm

Just FYI, tried upgrade from 16.04 to 16.10 again, but this time I wanted to test the GUI upgrade tool. Same results with this cryptsetup issue. I tried to "dpkg -configure -a" but it didn't help. Screenshot for your reference. Has anyone else experienced this issue?
Image
caseycullen
 
Posts: 54
Joined: Sat Dec 17, 2016 8:12 am
Location: Madison, WI USA

Re: (X)(L)ubuntu (MATE) 17.04 Zesty Zapus

Postby caseycullen » Wed Jan 18, 2017 4:57 am

I was able to upgrade to 17.04 by using the Debian-based installer for 16.04, then dist-upgrade to 16.10, and again to 17.04. I had to remove packages lsvpd and ppc64-diag because they were causing dpkg configuration issues; they do not seem necessary for normal operation anyway. I also upgraded to kernel 4.10-rc4 (Sinan) with no issues.

I am running into an issue with Compiz.
Using Compiz when running the 4.10-rc4 kernel results in this:
Image

Using Compiz when running the 4.4.8 kernel results in this:
Image

Using the "Marco" Compton GPU Composter seems to work perfectly.
caseycullen
 
Posts: 54
Joined: Sat Dec 17, 2016 8:12 am
Location: Madison, WI USA

Next

Return to Platform: AmigaOne X5000 - Linux Only

Who is online

Users browsing this forum: No registered users and 1 guest