Page 2 of 3

Re: AmigaOS only boots from install DVD

PostPosted: Wed Jul 03, 2019 12:35 am
by tonyw
That's right, SLB was only for the SE/XE and Sams. The X-1000, X-5000 and A-1222 use "amigaboot".

Don, this is a puzzler. Would it be possible to try another drive in place of the SanDisk SSD?

It can't be the fact that it's an SSD since I have a Western Digital SSD in my X-5040, but there are SSDs and SSDs... It's just possible that U-Boot has a problem reading it, while AmigaOS hasn't.

Re: AmigaOS only boots from install DVD

PostPosted: Wed Jul 03, 2019 7:50 am
by trixie
tonyw wrote:It can't be the fact that it's an SSD since I have a Western Digital SSD in my X-5040

I, too, have a SSD disk in my X5000/020 (a Crucial MX500), and it works wonders.

Re: AmigaOS only boots from install DVD

PostPosted: Wed Jul 03, 2019 2:36 pm
by OldFart
@donfirth

Does (your version of) UBoot support booting from NGS\00 partitions?

Just a thought.

OldFart

Re: AmigaOS only boots from install DVD

PostPosted: Thu Jul 04, 2019 1:20 am
by tonyw
It's amigaboot (in the SD card) that supports it, and the answer for an X-5000 is "yes, of course".

Re: AmigaOS only boots from install DVD

PostPosted: Fri Jul 05, 2019 5:43 am
by donfirth
OldFart wrote:@donfirth

Does (your version of) UBoot support booting from NGS\00 partitions?

Just a thought.

OldFart

Thanks for the though.

Apparently It does not.
Yesterday I found I couldn't even boot from CD so I looked into messages about the U-Boot.
The topic "Change uboot anim count" shows commands I just don't have.
It turns out my U-Boot is over 4 years old and only supports the Standard file system.
Any way trying to change amigabootmenu_animcycles and saveenv got my CD working again.
A fresh install with Standard File system with everything checked when formatting does the trick.

Thanks everyone for your input.
It's great to have a working computer again.

Now the question is how do I get the latest U-Boot to update my system.

Re: AmigaOS only boots from install DVD

PostPosted: Fri Jul 05, 2019 12:59 pm
by tonyw
When the animation starts, press the "M" key twice to get to the U-Boot prompt.

Then type "boota" and you should see the heading for amigaboot: something like "AmigaOS 4.x U-Boot Bootloader V53.xx".

Please tell me what version you have. I can't believe that it doesn't support NGFS volumes - support was built in long before any X-5000s were sold to the public.

Re: AmigaOS only boots from install DVD

PostPosted: Fri Jul 05, 2019 4:41 pm
by donfirth
tonyw wrote:When the animation starts, press the "M" key twice to get to the U-Boot prompt.

Then type "boota" and you should see the heading for amigaboot: something like "AmigaOS 4.x U-Boot Bootloader V53.xx".

Please tell me what version you have. I can't believe that it doesn't support NGFS volumes - support was built in long before any X-5000s were sold to the public.

I was in the Beta program - which was more confusing than anything else.
I am just getting back to the Amiga X5000 after letting it sit for some time.

When I preform the procedure you stated It boots up without the delay and I see a progress of # symbols.
Listing the loading modules.
I don't notice any relevant information.

Re: AmigaOS only boots from install DVD

PostPosted: Sat Jul 06, 2019 1:38 am
by tonyw
That's because you let it run by itself. I want you to do the steps by hand, as I listed them.

When you type "boota", the first thing you will see is the heading at top of a clean new screen, then a list of bootable volumes (may be only one), and an arrow at the far left side, indicating which volume will supply the Kickstart modules.
If you hit the space bar quickly, the process will freeze so that you can read the top line. You can then hit the Enter key to continue the boot process.

Re: AmigaOS only boots from install DVD

PostPosted: Sat Jul 06, 2019 2:30 pm
by donfirth
tonyw wrote:That's because you let it run by itself. I want you to do the steps by hand, as I listed them.

When you type "boota", the first thing you will see is the heading at top of a clean new screen, then a list of bootable volumes (may be only one), and an arrow at the far left side, indicating which volume will supply the Kickstart modules.
If you hit the space bar quickly, the process will freeze so that you can read the top line. You can then hit the Enter key to continue the boot process.


V53.9
The problem was amigaboot_quiet was set to Y
It took a while to figure out
setenv amigaboot_quiet N
saveenv

Re: AmigaOS only boots from install DVD

PostPosted: Sun Jul 07, 2019 6:28 am
by tonyw
Yeah, that version is now four years old. I don't know what is being delivered with X-5000s these days, but my X-5040 had amigaboot V53.21 when delivered. I'm currently trying to get V53.27 ready for release.

Perhaps AmigaKit can give you a later SD card image?