Page 1 of 2

Is it possible to use the TG-3468 with the X5000?

PostPosted: Wed Apr 24, 2019 9:22 pm
by daveyw
https://www.tp-link.com/uk/home-network ... r/tg-3468/

From what I've read, it has an 8168 chipset. I bought one last year, but couldn't get it to work. Should it be able to?

Re: Is it possible to use the TG-3468 with the X5000?

PostPosted: Wed Apr 24, 2019 10:29 pm
by Skateman
i have used a similair card for a while and worked... http://www.amigascene.nl/uploads/newbb/ ... 296cbf.jpg

I will try to find the box and let you know what type it is. (if i can still find it)

Re: Is it possible to use the TG-3468 with the X5000?

PostPosted: Sat May 04, 2019 2:19 pm
by smf
This is the ranger output from my TP link PCIE card.

Image

It has been working great for years.
I dont know if it's a TG-3468 since i dont have the box anymore.

The driver looks for the following PCI ID's
VENDOR DEVICE
==============
0x10ec 0x8169
0x10ec 0x8136
0x10ec 0x8167
0x10ec 0x8168
0x10ec 0x8169
0x1186 0x4300
0x1259 0xc107
0x16ec 0x0116

But if yours is having some other id you can add it with an enviroment variable.
Take a look at the rtl8169_dev.doc.

Re: Is it possible to use the TG-3468 with the X5000?

PostPosted: Wed May 08, 2019 7:29 pm
by Skateman
I found the box and i can confirm that the TG-3468 will work in the AmigaOne X5000 for both linux and AmigaOS 4.1FE

Re: Is it possible to use the TG-3468 with the X5000?

PostPosted: Sat May 11, 2019 4:32 am
by daveyw
Thanks. When I tried it, I just put it in and didn't do any further config. I have some time off after thee 20th, so I can experiment then. Knowing that this will allow me to expand my Linux RAM is a renewed impetus to get it working.

Re: Is it possible to use the TG-3468 with the X5000?

PostPosted: Mon May 13, 2019 8:54 pm
by Skateman
Since there is a 0S4.1FE driver for the X5K onboard DPAA adapter i stopped using the TG-3468.
I am using a cheap usb to ethernet adapter for linux now.
If you are interested in the Card just let me know.

Re: Is it possible to use the TG-3468 with the X5000?

PostPosted: Mon May 13, 2019 11:44 pm
by daveyw
Skateman wrote:Since there is a 0S4.1FE driver for the X5K onboard DPAA adapter i stopped using the TG-3468.
I am using a cheap usb to ethernet adapter for linux now.
If you are interested in the Card just let me know.


Thanks, but I already have one - just can't get it to work.

I was dissatisfied with the performance of the onboard Ethernet, connecting to my NAS is noticeably slower so I don't use it.

Re: Is it possible to use the TG-3468 with the X5000?

PostPosted: Sat May 18, 2019 8:36 pm
by PJS
LOL

As I just posted in the X1K area, I'm using that exact card in my X5K...

TP-Link TG-3468
https://www.stormcomputers.com.au/produ ... b-chipset/

According to Ranger, it shows up as:

Device = 0x8168 Rev 0x06
Vendor = 0x10EC (N/A)

I'm using it with this driver:

rtl8169.device 53.6 (02/22/2017)

It looks like it's still available for $13:

https://www.amazon.com/TP-Link-Gigabit- ... B003CFATNI

Good luck,

PJS

Re: Is it possible to use the TG-3468 with the X5000?

PostPosted: Sun May 19, 2019 12:16 am
by daveyw
PJS wrote:I'm using it with this driver:

rtl8169.device 53.6 (02/22/2017)

Good luck,

PJS


Oh, now that's interesting. I have 53.5 on my X5000. I have checked my boot CD and it's 53.5 as well.

Where can I get 53.6 from?

Skateman, are you able to confirm which driver you are using in your X5000?

Re: Is it possible to use the TG-3468 with the X5000?

PostPosted: Sun May 19, 2019 12:22 am
by daveyw
PJS wrote:LOL

As I just posted in the X1K area, I'm using that exact card in my X5K...


Thanks for the heads-up. Strangely, I cannot reply in the X1000 thread, so I can only monitor the replies.