X5000

AmigaOne X5000 platform specific issues.

Re: X5000

Postby Raziel » Sat Feb 16, 2019 9:34 am

Oh...
Hmm, maybe the .db file is trashed and Odyssey doesn't write to it and also cannot read it.

I'd make a backup of that .db file, delete it and then surf to a site with a password entry.
Maybe recreating the whole .db (manually unfortunately) will fix it.

I just realized that the .db file stores the passwords in human readable form :-(
If slaughterhouses had glass walls, everyone would be a vegetarian. ~ Sir Paul McCartney
-
Did everything just taste purple for a second? ~ Philip J. Fry
-
Ain't got no cash, ain't got no style, ladies vomit when I smile. ~ Dr. John Zoidberg
User avatar
Raziel
 
Posts: 912
Joined: Sat Jun 18, 2011 5:00 pm
Location: a story that hasn't been written yet

Re: X5000

Postby xenic » Sun Feb 17, 2019 8:20 pm

Raziel wrote:Oh...
Hmm, maybe the .db file is trashed and Odyssey doesn't write to it and also cannot read it.

I'd make a backup of that .db file, delete it and then surf to a site with a password entry.
Maybe recreating the whole .db (manually unfortunately) will fix it.


If Odyssey is installed on an NGFS (as originally installed) partition, shutting down or rebooting the system without quitting Odyssey first will result in corruption of any .db files written during the current session. Unless you can get a more recent version of NGFS you should install Odyssey on an SFS2 partition.

I just realized that the .db file stores the passwords in human readable form :-(

That's why I disabled password storage a long time ago. I'm not sure but I think that unchecking "Save form credentials" and "Enable form autofill" in Odyssey "Settings/Privacy" will stop password saving.

People should also be aware that if they have "Clipviewer" set to save it's history to hard-disk, copying or cutting personal info like paswords can store them on hard-disk in human readable form.
AmigaOne X1000 with 2GB memory - OS4.1 FE
xenic
 
Posts: 1160
Joined: Sun Jun 19, 2011 1:06 am

Re: X5000

Postby daveyw » Mon Feb 18, 2019 7:46 am

Yup, I tried opening my passwords file in SQL Lite Manager and it displays "1654: Misuse of function!"

I'm aware that the file is human readable - indeed, since it became trashed I have replied upon that to find my old passwords. ;)

I'm not too worried about security - I think anyone other than another Amiga user would be baffled by the OS and unlikely to snoop anything out.
User avatar
daveyw
 
Posts: 233
Joined: Mon Sep 12, 2011 8:44 pm

Re: X5000

Postby kas1e » Thu Feb 21, 2019 12:23 pm

What i notice myself, is that when i install Odyssey on public NGFS (that one which come with x5000), then i never-ever have favicons for the sites in the tabs after i exit/run odyssey again. I can't test it on the latest NGFS at moment, but with public one there is for sure issue of this kind.
kas1e
Beta Tester
Beta Tester
 
Posts: 481
Joined: Sat Jun 18, 2011 8:56 am

Re: X5000

Postby cha05e90 » Fri Feb 22, 2019 4:00 pm

kas1e wrote:What i notice myself, is that when i install Odyssey on public NGFS (that one which come with x5000), then i never-ever have favicons for the sites in the tabs after i exit/run odyssey again. I can't test it on the latest NGFS at moment, but with public one there is for sure issue of this kind.

It's a known - ahem - "situation" with sqlite based software. We had the same problem a couple of years ago with Timberwolf's sqlite data and JXFS. It's not really a X5000 problem but a problem with writing in a sqlite db file with certain filesystems. I don't know much about FS technology, but this problem seem not to occur with FFS or SFS.
X1000|II/G4|440ep|2000/060|2000/040|1000
User avatar
cha05e90
 
Posts: 89
Joined: Fri Jun 17, 2011 11:15 pm
Location: Germany

Re: X5000

Postby hlt » Fri Feb 22, 2019 4:17 pm

Sorry for off-topic, however is there any chance that we will see Odyssey 1.25 with JIT on AmigaOS? I can see it is available on MOS...
hlt
 
Posts: 3
Joined: Mon Oct 29, 2018 9:13 am

Re: X5000

Postby tonyw » Sat Feb 23, 2019 1:59 am

cha05e90 wrote:It's not really a X5000 problem but a problem with writing in a sqlite db file with certain filesystems. I don't know much about FS technology, but this problem seem not to occur with FFS or SFS.


That sounds as though something was written that "worked" on FFS and SFS, but depends on undocumented FS quirks that don't exist on newer FS like NGFS. It is significant that both FFS and SFS fail the test programs for file systems, test programs that did not exist when the older FS were written.
cheers
tony
User avatar
tonyw
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 1380
Joined: Wed Mar 09, 2011 2:36 pm
Location: Sydney, Australia

Re: X5000

Postby kas1e » Sun Feb 24, 2019 7:34 am

@hlt
Sorry for off-topic, however is there any chance that we will see Odyssey 1.25 with JIT on AmigaOS? I can see it is available on MOS...

Nope, sources of 1.25 not available, as well as JIT version developed by another person, and sources of this version also not available.

@TonyW
That sounds as though something was written that "worked" on FFS and SFS, but depends on undocumented FS quirks that don't exist on newer FS like NGFS. It is significant that both FFS and SFS fail the test programs for file systems, test programs that did not exist when the older FS were written.


Not sure what you mean there as sqlite don't use any undocumented FS quirks, its just a port without specific amiga changes. And Odyssey's favicons (and all that slite db stuff) works not only on ffs/sfs/sfs2 on amigaos4, but also on morphos's sfs and aros's filesystems too. I can't test for now latest NGFS, but did odyssey's favicons not works on latest NGFS too, and instead of real images fallback to default ones ? If so, roots needs to be find and to be fixed
kas1e
Beta Tester
Beta Tester
 
Posts: 481
Joined: Sat Jun 18, 2011 8:56 am

Re: X5000

Postby tonyw » Sun Feb 24, 2019 12:07 pm

kas1e wrote:I can't test for now latest NGFS, but did odyssey's favicons not works on latest NGFS too, and instead of real images fallback to default ones ? If so, roots needs to be find and to be fixed


I agree, it must be fixed (if there is something wrong). Can you describe a fault? Something I can reproduce? The favicons seem to be saved OK on my system, along with all the ".db" files.
cheers
tony
User avatar
tonyw
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 1380
Joined: Wed Mar 09, 2011 2:36 pm
Location: Sydney, Australia

Re: X5000

Postby nbache » Sun Feb 24, 2019 1:42 pm

Tony, isn't this the one you fixed in 54.52?

Best regards,

Niels
User avatar
nbache
Beta Tester
Beta Tester
 
Posts: 1372
Joined: Mon Dec 20, 2010 8:25 pm
Location: Copenhagen, Denmark

PreviousNext

Return to Platform: AmigaOne X5000

Who is online

Users browsing this forum: No registered users and 1 guest