Adelielinux

AmigaOne X1000 platform specific issues related to Linux only.

Adelielinux

Postby TearsOfMe » Thu May 03, 2018 11:30 am

Have found these Linux distro.

https://adelielinux.org/about.html

Seems small and i like to now if it may works with the X1000 ?

Greetings
Thomas
TearsOfMe
 
Posts: 26
Joined: Sat Jul 07, 2012 6:34 pm
Location: Westerwald (Germany)

Re: Adelielinux

Postby xeno74 » Thu May 03, 2018 2:37 pm

TearsOfMe wrote:Have found these Linux distro.

https://adelielinux.org/about.html

Seems small and i like to now if it may works with the X1000 ?

Greetings
Thomas


Very interesting! It seems it based on Gentoo PPC32/PPC64. I don't know if it works on a X1000.

-- Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 4236
Joined: Fri Mar 23, 2012 8:58 am

Re: Adelielinux

Postby TearsOfMe » Thu May 03, 2018 6:36 pm

I was able to install it.
It works so far but no xserver in the image and i was not able to install one.
TearsOfMe
 
Posts: 26
Joined: Sat Jul 07, 2012 6:34 pm
Location: Westerwald (Germany)

Re: Adelielinux

Postby mechanic » Sat May 05, 2018 6:26 pm

@TearsOfMe

Did you use the setup-xorg-base command?

It might take some fiddle-ing around as Adelie probably does not have a PA6T. Check out Alpine Linux website as Adelie (at least) is using their package manager.
A-Eon A1X1000
User avatar
mechanic
 
Posts: 488
Joined: Sat Jun 25, 2011 10:22 pm

Re: Adelielinux

Postby TearsOfMe » Sun May 06, 2018 8:14 pm

I install it by mounting the iso and copying the files, so no install routine used and that maybe makes problems.
I get ssl errors and cannot get apk working :(

IMG_20180506_200818_315.JPG
TearsOfMe
 
Posts: 26
Joined: Sat Jul 07, 2012 6:34 pm
Location: Westerwald (Germany)

Re: Adelielinux

Postby mechanic » Sun May 06, 2018 11:00 pm

Copying files will not work.

Either the ISO needs to boot or you would need to dd an image to your HD. Sorry. :cry:
A-Eon A1X1000
User avatar
mechanic
 
Posts: 488
Joined: Sat Jun 25, 2011 10:22 pm

Re: Adelielinux

Postby TearsOfMe » Thu May 10, 2018 6:26 pm

Boot the iso with qemu on linux and get the same problem.
Seems the dist site has problems with ssl connections.
TearsOfMe
 
Posts: 26
Joined: Sat Jul 07, 2012 6:34 pm
Location: Westerwald (Germany)

Re: Adelielinux

Postby vox » Wed Jun 20, 2018 7:54 am

mechanic wrote:Copying files will not work.
Either the ISO needs to boot or you would need to dd an image to your HD. Sorry. :cry:


Is there a way to boot Linux CD installs via X1000 CFE?

I see on old AEON ubuntu CD basically a batch file is called that run the kernel and initrd.

Should some rooT=/CDROM/... initrd path be setted? Surely looking over different distros needs a different solutions, but
since amigaboot.of was made could similar LILO style boot loader be created for x1000?
User avatar
vox
 
Posts: 170
Joined: Thu Jun 23, 2011 3:19 pm
Location: Belgrade Country:Serbia


Return to Platform: AmigaOne X1000 - Linux Only

Who is online

Users browsing this forum: Google [Bot] and 7 guests