Youtube with Ubuntu?

AmigaOne X1000 platform specific issues related to Linux only.

Youtube with Ubuntu?

Postby kilaueabart » Sat Oct 01, 2016 4:24 am

I've noticed that I can't view youtube videos on MATE 16.04.1. I had the idea that maybe I had heard that was a general problem, but when I googled to find out, I found no mention of problems.

To the apparent contrary, I found something Christian had written on ubuntuforums.com way back on May 11:
YouTube HD videos work with ViewTube in fullscreen!!!!!! (High Definition MP4 VLC HD MP4)


Is it then a problem with my own install? (This is the first thing I have found that Odyssey does better than Firefox on my X1000.)
User avatar
kilaueabart
 
Posts: 548
Joined: Mon Mar 05, 2012 3:36 am

Re: Youtube with Ubuntu?

Postby xeno74 » Sat Oct 01, 2016 6:16 am

Image

YouTube videos in HD with ViewTube

Installation instructions for ubuntu MATE 16.04.1 PowerPC

  1. Install VLC and the VLC browser plugin with the following command:
    Code: Select all
    sudo apt-get install browser-plugin-vlc
  2. Start Firefox and install the add-on Greasemonkey
  3. Restart Firefox
  4. After that, add the ViewTube script to Greasemonkey

Image
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 4238
Joined: Fri Mar 23, 2012 8:58 am

Re: Youtube with Ubuntu?

Postby xeno74 » Thu Sep 13, 2018 11:20 am

Image

YouTube videos in HD with ViewTube

New installation instructions for ubuntu MATE 16.04.5 PowerPC

  1. Install VLC and the VLC browser plugin with the following command:
    Code: Select all
    sudo apt-get install browser-plugin-vlc
  2. Start Firefox and install the add-on Greasemonkey version 3.11
  3. Restart Firefox
  4. After that, add the ViewTube script to Greasemonkey version 3.11

Image
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 4238
Joined: Fri Mar 23, 2012 8:58 am

Re: Youtube with Ubuntu?

Postby xenic » Thu Sep 13, 2018 9:53 pm

xeno74 wrote:YouTube videos in HD with ViewTube

I installed browser-plugin-vlc and GreaseMonkey but ViewTube says it needs at least Firefox v48. My Firefox is v47 so I don't know if it's safe to try to install ViewTube. Did you install it with Firefox v47?
AmigaOne X1000 with 2GB memory - OS4.1 FE
xenic
 
Posts: 1149
Joined: Sun Jun 19, 2011 1:06 am

Re: Youtube with Ubuntu?

Postby xeno74 » Fri Sep 14, 2018 8:57 am

xenic wrote:I installed browser-plugin-vlc and GreaseMonkey but ViewTube says it needs at least Firefox v48. My Firefox is v47 so I don't know if it's safe to try to install ViewTube. Did you install it with Firefox v47?
Yes, I installed it with Firefox 47 without any problems. I didn’t see this ViewTube message. I will update it today to the latest version.

Downloads: addons.mozilla.org
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 4238
Joined: Fri Mar 23, 2012 8:58 am

Re: Youtube with Ubuntu?

Postby xeno74 » Fri Sep 14, 2018 10:04 am

I updated ViewTube to the latest version today. (see screenshot)

Image

@xenic
Could you please post a screenshot of the ViewTube message?

Thanks
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 4238
Joined: Fri Mar 23, 2012 8:58 am

Re: Youtube with Ubuntu?

Postby xenic » Fri Sep 14, 2018 4:34 pm

xeno74 wrote:Could you please post a screenshot of the ViewTube message?

Maybe my statement was misleading. The message wasn't 'IN' ViewTube; The message is on a WEB page I found by searching scripts from Greasemonkey. However, the message is also on the WEB page link you provided. Below each version on that page is the text "Works with Firefox for Android 48.0 and later, Firefox 48.0 and later".
AmigaOne X1000 with 2GB memory - OS4.1 FE
xenic
 
Posts: 1149
Joined: Sun Jun 19, 2011 1:06 am

Re: Youtube with Ubuntu?

Postby xeno74 » Sat Sep 15, 2018 8:04 am

Good to know. I can confirm, that it works with the Firefox 47. Thank you for the hint.
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 4238
Joined: Fri Mar 23, 2012 8:58 am


Return to Platform: AmigaOne X1000 - Linux Only

Who is online

Users browsing this forum: No registered users and 7 guests

cron