(X)(L)ubuntu (MATE) 16.10 Yakkety Yak

AmigaOne X1000 platform specific issues related to Linux only.

Re: (X)(L)ubuntu (MATE) 16.10 Yakkety Yak

Postby xeno74 » Tue Aug 23, 2016 12:47 pm

kilaueabart wrote:
THW wrote:@kilaueabart:

No, the address has not changed on the drive, it depends on which drive configuration you have in your computer.
Linux mounts the drives permanent (fstab) or temporary.
I didn't think any address had been changed on the flash drive itself, just how Ubuntu is addressing it.
I copied a 16.04 image to /dev/sde. GParted saw 16.04 immediately thereafter on /dev/sde2. Yesterday GParted saw no /dev/sde whatsoever, but it saw that 16.04 on /dev/sdf2. Today it is calling it /dev/sde2 again. Something is changing back and forth. Not the address?

Please look in the fstab-file on the root partition in /etc/fstab with an editor e.g. pluma.
Here you can see what drive name would be given during the installation and the UUID.
I can only find the address and UUID of the version of Ubuntu I am currently running. I'm not sure how to find that info for an unmounted disk or partition, if that is what I need. More instructions, please.


I was able to boot Julian's ubuntu MATE 16.04 from the USB flash drive with the new longterm kernel 4.1.31 and with the initrd.img-4.1.31. I use the label Ubuntu_16.04.

  1. Code: Select all
    ramdisk -z -addr=0x2400000 -fatfs usbdisk0:initrd.img-4.1.31
  2. Code: Select all
    setenv bootargs "root=LABEL=Ubuntu_16.04"
  3. Code: Select all
    boot -elf- noints -fatfs usbdisk0:vmlinux-4.1

Please note: CFE firmware does not recognise USB devices on power-up unless they are connected to the first USB port which is reserved for the keyboard. Unless you have a USB hub connected to the first port which allows you to connect both the keyboard and USB disk, you will need to insert the USB disk AFTER you have entered CFE.
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 5322
Joined: Fri Mar 23, 2012 8:58 am

Re: (X)(L)ubuntu (MATE) 16.10 Yakkety Yak

Postby kilaueabart » Wed Aug 24, 2016 4:19 am

xeno74 wrote:...
I was able to boot Julian's ubuntu MATE 16.04 from the USB flash drive with the new longterm kernel 4.1.31 and with the initrd.img-4.1.31. I use the label Ubuntu_16.04.

This got my hopes up again. My guess was that the three lines listed were to be typed into CFE. But when I typed
Code: Select all
ramdisk -z -addr=0x2400000 -fatfs usbdisk0:initrd.img-4.1.31
I was told:
Code: Select all
Could not load usbdisk0:initrd.img-4.1.31: File not found.
But it shows up clearly when I open the disk in Ubuntu.
Code: Select all
setenv bootargs "root=LABEL=Ubuntu_16.04"
No problem reported with this.
Code: Select all
boot -elf- noints -fatfs usbdisk0:vmlinux-4.1
This one brought me another "File not found." Well, that seemed reasonable. I had only put initrd.img-4.1.31 on the drive, so I went back and added the vmlinux-4.1 that had come with it. Then I tried just the last two lines, since I knew the first of the three gets me an error message.
O-ho! Very exciting! Line after line of processing this and that, but it finally came to an end with "Unable to mount root on unknown-block(0,0)." Maybe a dozen lines above that message I saw, "Please append a correct "root=" boot option." I suppose "root=LABEL=Ubuntu_16.04" doesn't work because I can't make the first line work?

Please note: CFE firmware does not recognise USB devices on power-up unless they are connected to the first USB port which is reserved for the keyboard. Unless you have a USB hub connected to the first port which allows you to connect both the keyboard and USB disk, you will need to insert the USB disk AFTER you have entered CFE.
I discovered that if I plug the USB drive in after I boot MATE, Ubuntu_16.04 shows up on the Desktop alongside AMIGAONE and Sam4xx, and GParted shows it mounted. If I plug it in before booting, only the latter two are mounted. Unfortunately waiting until CFE is up before plugging it in doesn't help with booting 16.04.
User avatar
kilaueabart
 
Posts: 638
Joined: Mon Mar 05, 2012 3:36 am

Re: (X)(L)ubuntu (MATE) 16.10 Yakkety Yak

Postby zappa2009 » Wed Aug 24, 2016 10:20 pm

kilaueabart wrote:I discovered that if I plug the USB drive in after I boot MATE, Ubuntu_16.04 shows up on the Desktop alongside AMIGAONE and Sam4xx, and GParted shows it mounted. If I plug it in before booting, only the latter two are mounted. Unfortunately waiting until CFE is up before plugging it in doesn't help with booting 16.04.


Bevor you load the initrd from usbdisk0 check if usbdisk0 are present.

Code: Select all
dir -fatfs usbdisk0:

If you got an fail then unplug and replug the usb-stick.
X1000 RadeonHD5450 4GB (2x2GB) DDR2-PC2-8500 Kingston HyperX 5-5-5-5-15 OS4.1.6 & Lubuntu13.04/mintppc11 with Kernel 3.8.7/3.9
User avatar
zappa2009
 
Posts: 230
Joined: Tue Jun 21, 2011 1:17 pm

Re: (X)(L)ubuntu (MATE) 16.10 Yakkety Yak

Postby kilaueabart » Thu Aug 25, 2016 2:47 am

zappa2009 wrote:...
Bevor you load the initrd from usbdisk0 check if usbdisk0 are present.

Code: Select all
dir -fatfs usbdisk0:
If you got an fail then unplug and replug the usb-stick.

I think this is a major clue to my problem, but I have no idea how to fix it.

The command you suggest gets me a list of files which show up in the AMIGAONE section of the drive when I open it in Ubuntu Desktop, except what CFE calls TABOR2.DTB shows up as tabor2.dtb, lower case, and CFE sees a .Trash-1000 folder that doesn't appear in AMIGAONE. No sign of any vmlinux!

But when I click the up-arrow ("Show the parent folder") from AMIGAONE, I get this list:
Code: Select all
AMIGAONE 10 items  folder
Sam4xx ... folder
Ubuntu_16.04 ... folder
vmlinux-4.1.31-AmigaOne_X1000 ... folder
initrd.img-4.1.31  Gzip archive
vmlinux-4.1  executable
vmlinux-4.1.31-AmigaONE_X1000.tar.gz

So the file in question is indeed on the flash drive, but it must be in the wrong place. I don't know how I should fix this, but I have just now slid the Gzip and the executable file into AMIGAONE, and will reboot and try the "ramdisk -z ..." sequence again. If that if obviously the wrong thing to do, I hope you will help me again. Thank you.

[Later] I gave it two shots, both failed with
Code: Select all
Kernel panic -- not syncing: Attempted to kill init! exitcode=0x 00000100
The messages in the first try included something about there being no 4.1.24_A-EON-AmiigaONE_X1000_NEMO. I didn't find that line the second time, but toward the end it complained
Code: Select all
can't execute /sbin/init accessing corrupted shared library
Maybve I should just give up for now.
User avatar
kilaueabart
 
Posts: 638
Joined: Mon Mar 05, 2012 3:36 am

Re: (X)(L)ubuntu (MATE) 16.10 Yakkety Yak

Postby zappa2009 » Thu Aug 25, 2016 10:35 pm

Hi kilaueabart

The initrd.img-4.1.31 are in the Folder vmlinux-4.1.31-AmigaOne_X1000 !!
Check this first:
Code: Select all
dir -fatfs usbdisk0:vmlinux-4.1.31-AmigaONE_X1000

There are all you need ;)

Just move then out to the root of Your AmigaOne Partition or change the Path to the initrd4.1.31

Code: Select all
ramdisk -z -addr=0x24000000 -fatfs usbdisk0:vmlinux-4.1.31-AmigaONE_X1000/initrd.img-4.1.31


But remember the Kernels Name are vmlinux-4.1 (and not vmlinux-4.1.31)

So in Your case you must load it this Way:

Code: Select all
setenv bootargs "root=LABEL=Ubuntu_16.04"

Code: Select all
boot -elf -noints -fatfs usbdisk0:vmlinux-4.1.31-AmigaONE_X1000/vmlinux-4.1
X1000 RadeonHD5450 4GB (2x2GB) DDR2-PC2-8500 Kingston HyperX 5-5-5-5-15 OS4.1.6 & Lubuntu13.04/mintppc11 with Kernel 3.8.7/3.9
User avatar
zappa2009
 
Posts: 230
Joined: Tue Jun 21, 2011 1:17 pm

Re: (X)(L)ubuntu (MATE) 16.10 Yakkety Yak

Postby kilaueabart » Fri Aug 26, 2016 5:43 am

You're going to a lot of trouble on my behalf, zappa2009, and I greatly appreciate it. But I fear I misled you with the list of files that I get looking at the flash drive from my working 16.04.1. I should have posted the results of
Code: Select all
dir -fatfs usbdisk0:
which are in fact different:
Code: Select all
nemo_4.1.24.config
uImage-tabor
cyrus_5020.dtb
vmlinux
TABOR2.DTB
Sam_Documentation
.trash-1000
tabor-4.4.10-JM.config
uImage-cyrus
Disk.info
Sam_Documentation.info
There is no vmlinux-4.1.31-AmigaONE_X1000, and
Code: Select all
 dir -fatfs usbdisk0:vmlinux-4.1.31-AmigaONE_X1000
gets me
Code: Select all
Could not get directory listing: File not found
*** command status = -18

But I wonder if that vmlinux (24639336) could be what I need? Just for fun, I am going to try
Code: Select all
ramdisk -z -addr=0x2400000 -fatfs usbdisk0:vmlinux
and see what happens. Stand by.
User avatar
kilaueabart
 
Posts: 638
Joined: Mon Mar 05, 2012 3:36 am

Re: (X)(L)ubuntu (MATE) 16.10 Yakkety Yak

Postby zappa2009 » Mon Aug 29, 2016 8:09 pm

Hi kilaueabart

I see on your Boot-Partition there are no 4.1.31 Kernel or initrd.
You need to extract it from Xeno-s http://www.xenosoft.de/vmlinux-4.1.31-A ... 000.tar.gz Archive and copy this to your Boot-Partition.
X1000 RadeonHD5450 4GB (2x2GB) DDR2-PC2-8500 Kingston HyperX 5-5-5-5-15 OS4.1.6 & Lubuntu13.04/mintppc11 with Kernel 3.8.7/3.9
User avatar
zappa2009
 
Posts: 230
Joined: Tue Jun 21, 2011 1:17 pm

Re: (X)(L)ubuntu (MATE) 16.10 Yakkety Yak

Postby kilaueabart » Mon Aug 29, 2016 11:53 pm

zappa2009 wrote:I see on your Boot-Partition there are no 4.1.31 Kernel or initrd.
You need to extract it from Xeno-s http://www.xenosoft.de/vmlinux-4.1.31-A ... 000.tar.gz Archive and copy this to your Boot-Partition.

Both of those files are in USBdisk0:AMIGAONE = /dev/sde1. I don't know how to create a Boot-Partition. GParted says I have 6.90 GiB of room for partitions, but says I can only make Primary or Extended partitions in it. How do I make a Boot partition?

Maybe you mean put them in Ubuntu_16.04/boot? I just did that, and am about to reboot and see if it makes a difference.
User avatar
kilaueabart
 
Posts: 638
Joined: Mon Mar 05, 2012 3:36 am

Re: (X)(L)ubuntu (MATE) 16.10 Yakkety Yak

Postby kilaueabart » Tue Aug 30, 2016 2:56 am

kilaueabart wrote:
zappa2009 wrote:I see on your Boot-Partition there are no 4.1.31 Kernel or initrd.
You need to extract it from Xeno-s http://www.xenosoft.de/vmlinux-4.1.31-A ... 000.tar.gz Archive and copy this to your Boot-Partition.

Both of those files are in USBdisk0:AMIGAONE = /dev/sde1. I don't know how to create a Boot-Partition. GParted says I have 6.90 GiB of room for partitions, but says I can only make Primary or Extended partitions in it. How do I make a Boot partition?

Maybe you mean put them in Ubuntu_16.04/boot? I just did that, and am about to reboot and see if it makes a difference.


[Later]OK, I thought the idea that a boot folder might be a Boot Partition was kind of silly. Anyway, since Christian's original instructions, which don't quite work, are
Code: Select all
setenv bootargs "root=/dev/sdd2 quiet ro splash rootdelay=5" ("d2" = "e2" in my case)
boot -elf -noints -fatfs cf0:vmlinux-4.8
it shouldn't make any difference whether a 4.1.31 Kernel or initrd are available anywhere or not. My problem must be more fundamental.

I don't think I'm going to be able to help with the testing. I hope he got plenty of help from others.
User avatar
kilaueabart
 
Posts: 638
Joined: Mon Mar 05, 2012 3:36 am

Re: (X)(L)ubuntu (MATE) 16.10 Yakkety Yak

Postby xeno74 » Mon Sep 12, 2016 1:07 pm

Hi All,

I have great news! I updated my ubuntu MATE 16.10 today. There was an update of systemd. ;-) After a reboot, the stable longterm kernel 4.1.32 works again with systemd on ubuntu MATE 16.10.
If you want to use the stable longterm kernel 4.1.32 with ubuntu MATE 16.10, please update systemd. ;-)

Image

Cheers,

Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 5322
Joined: Fri Mar 23, 2012 8:58 am

PreviousNext

Return to Platform: AmigaOne X1000 - Linux Only

Who is online

Users browsing this forum: No registered users and 3 guests

cron