Kernel 4.6

AmigaOne X1000 platform specific issues related to Linux only.

Re: Kernel 4.6

Postby jdupuis » Sun May 08, 2016 6:17 am

OperatingSys.png
OpenGL.png
GlxGearsVblank0.png


Here I am in Ubuntu Mate 16.04, Kernel 4.6 rc6 and an Asus Radeon HD R7 250X GPU hooked up to an Asus ProArt 1900 X 1200 display via HDMI. Glxgears went from the low 300 frames range to the high 500 frames range! Quite significant to me. :D P.A. Semi Ethernet working! System restarts nicely as well. 4.6 works far better in Mate than 12.04. Thank you Christian! Great work!

Hat's Off and Cheers!!

John
C= A500 2 megs RAM with A590 w/40 MB SCSI HD and Workbench 1.3
C= A3000 25 MHz with Workbench 3.1
AmigaOne X1000 4 GB RAM, XFX Radeon HD 6670 1GB GDDR5 GPU and AmigaOS 4.1 FE/Ubuntu 12.04.5 LTS/Ubuntu Mate 16.04 LTS
Sam460ex 2GB DDR2 800 MHz RAM, XFX Radeon HD 5450 2GB GDDR3 GPU, 3114 SATA Raid, ENVY24HT sound card and AmigaOS 4.1 FE
User avatar
jdupuis
 
Posts: 223
Joined: Sat May 09, 2015 8:19 am
Location: Baton Rouge, Louisiana USA

Re: Kernel 4.6

Postby xeno74 » Sun May 08, 2016 7:49 am

Hi John,

This was really a big test. Many thanks for testing. Great test. :-) Fantastic!

Have a nice weekend!

Cheers,

Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 5322
Joined: Fri Mar 23, 2012 8:58 am

Re: Kernel 4.6

Postby jdupuis » Sun May 08, 2016 5:24 pm

xeno74 wrote:Hi John,

This was really a big test. Many thanks for testing. Great test. :-) Fantastic!

Have a nice weekend!

Cheers,

Christian


You're welcome!
Please give me a known kernel version that I may download and terminal commands to boot Ubuntu 12.04.05 LTS DVD. I tried 4.1.20, 4.1.21, 4.6.5 and 4.6.6. using the standard "ramdisk -addr=" boot routine and Kernels on CF Card with my R7 250X. Looks like a no-go. I do have the Ubuntu Mate 7zip saved for reinstallation. Just can't boot up DVD. I'm using HDMI. Don't know if DVI will make a big difference here. Thanks Christian!
<edit>
"(initramfs) mount: mounting aufs on /root failed: No such device
aufs mount failed"
This is the boot error after the Ubuntu 12.04 splash screen.

Cheers!!
C= A500 2 megs RAM with A590 w/40 MB SCSI HD and Workbench 1.3
C= A3000 25 MHz with Workbench 3.1
AmigaOne X1000 4 GB RAM, XFX Radeon HD 6670 1GB GDDR5 GPU and AmigaOS 4.1 FE/Ubuntu 12.04.5 LTS/Ubuntu Mate 16.04 LTS
Sam460ex 2GB DDR2 800 MHz RAM, XFX Radeon HD 5450 2GB GDDR3 GPU, 3114 SATA Raid, ENVY24HT sound card and AmigaOS 4.1 FE
User avatar
jdupuis
 
Posts: 223
Joined: Sat May 09, 2015 8:19 am
Location: Baton Rouge, Louisiana USA

Re: Kernel 4.6

Postby xeno74 » Sun May 08, 2016 5:56 pm

John,

Here you are: kernel_live_remix_dvd.html

Cheers,

Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 5322
Joined: Fri Mar 23, 2012 8:58 am

Re: Kernel 4.6

Postby jdupuis » Mon May 09, 2016 2:20 am

xeno74 wrote:John,

Here you are: kernel_live_remix_dvd.html

Cheers,

Christian


Hi Christian!

Thank you. Further testing today. Radeon R7 250X still installed. Booted Ubuntu 12.04 LTS DVD with Kernel 4.0.7. Wiped out my install on "sdc" with GParted and performed a new install of Ubuntu 12.04 LTS. Restarted with Kernel 4.6.6. After accomplishing Updates (285), logged out - logged in. Restarted with 4.6.6. Everything went smooth. System stable. Working! X1000 with R7 250X GPU/P.A. Semi Ethernet

Cheers!!

John
C= A500 2 megs RAM with A590 w/40 MB SCSI HD and Workbench 1.3
C= A3000 25 MHz with Workbench 3.1
AmigaOne X1000 4 GB RAM, XFX Radeon HD 6670 1GB GDDR5 GPU and AmigaOS 4.1 FE/Ubuntu 12.04.5 LTS/Ubuntu Mate 16.04 LTS
Sam460ex 2GB DDR2 800 MHz RAM, XFX Radeon HD 5450 2GB GDDR3 GPU, 3114 SATA Raid, ENVY24HT sound card and AmigaOS 4.1 FE
User avatar
jdupuis
 
Posts: 223
Joined: Sat May 09, 2015 8:19 am
Location: Baton Rouge, Louisiana USA

Re: Kernel 4.6

Postby xeno74 » Mon May 09, 2016 6:35 am

jdupuis wrote:Hi Christian!

Thank you. Further testing today. Radeon R7 250X still installed. Booted Ubuntu 12.04 LTS DVD with Kernel 4.0.7. Wiped out my install on "sdc" with GParted and performed a new install of Ubuntu 12.04 LTS. Restarted with Kernel 4.6.6. After accomplishing Updates (285), logged out - logged in. Restarted with 4.6.6. Everything went smooth. System stable. Working! X1000 with R7 250X GPU/P.A. Semi Ethernet

Cheers!!

John


John,

Fantastic news! It's good to know, that the A-EON Live Remix DVD boots with the kernel 4.0.7. :-) Many thanks for testing.

@All

I have recently released the RC7 of kernel 4.6 today.

New:


Download: vmlinux-4.6-rc7-AmigaONE_X1000.tar.gz

Screenshot of the RC7 with Firefox 47:

Image

Please test it.

Thanks in advance,

Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 5322
Joined: Fri Mar 23, 2012 8:58 am

Re: Kernel 4.6

Postby jdupuis » Mon May 09, 2016 11:51 am

Hi Christian,

More testing with the R7 250x GPU and Kernel 4.6 rc6. Wiped out my original 16.04 install and prepared the Hard Drive for Julian's Southern Islands disk image. After copying and booting up it was a bit clunky starting out, but worked. Ubuntu Mate 16.04 SI disk image after config and upgrade is good. Smooth scrolling in Firefox. Glxgears looks good as well. P.A. Semi Ethernet stable. So to sum up.
I performed a new install of Ubuntu 12.04 booting DVD with Kernel 4.0.7. After which I booted Ubuntu 12.04 with Kernel 4.6 rc6. Downloaded and unpacked Julian's SI disk image and performed a new install of Ubuntu Mate 16.04 booting with 4.6 rc6. All is well.
X1000, Radeon HD R7 250X, Ubuntu 12.04 DVD and Kernels 4.0.7/4.6 rc6

It is fair to say that this is huge. With just the 12.04 DVD, the downloaded 16.04 SI disk image and two Kernels (4.0.7 and 4.6 rc6), I was able to do two complete Linux installs on my X1000 with the R7 250X GPU! An awesome stride has been made in less than a year!

Do I smell a fresh pressed Ubuntu Mate 16.04 LTS installation DVD on the horizon from AmigaKit? :)

Cheers!!

John
C= A500 2 megs RAM with A590 w/40 MB SCSI HD and Workbench 1.3
C= A3000 25 MHz with Workbench 3.1
AmigaOne X1000 4 GB RAM, XFX Radeon HD 6670 1GB GDDR5 GPU and AmigaOS 4.1 FE/Ubuntu 12.04.5 LTS/Ubuntu Mate 16.04 LTS
Sam460ex 2GB DDR2 800 MHz RAM, XFX Radeon HD 5450 2GB GDDR3 GPU, 3114 SATA Raid, ENVY24HT sound card and AmigaOS 4.1 FE
User avatar
jdupuis
 
Posts: 223
Joined: Sat May 09, 2015 8:19 am
Location: Baton Rouge, Louisiana USA

Re: Kernel 4.6

Postby xeno74 » Tue May 10, 2016 5:34 am

jdupuis wrote:Hi Christian,

More testing with the R7 250x GPU and Kernel 4.6 rc6. Wiped out my original 16.04 install and prepared the Hard Drive for Julian's Southern Islands disk image. After copying and booting up it was a bit clunky starting out, but worked. Ubuntu Mate 16.04 SI disk image after config and upgrade is good. Smooth scrolling in Firefox. Glxgears looks good as well. P.A. Semi Ethernet stable. So to sum up.
I performed a new install of Ubuntu 12.04 booting DVD with Kernel 4.0.7. After which I booted Ubuntu 12.04 with Kernel 4.6 rc6. Downloaded and unpacked Julian's SI disk image and performed a new install of Ubuntu Mate 16.04 booting with 4.6 rc6. All is well.
X1000, Radeon HD R7 250X, Ubuntu 12.04 DVD and Kernels 4.0.7/4.6 rc6

It is fair to say that this is huge. With just the 12.04 DVD, the downloaded 16.04 SI disk image and two Kernels (4.0.7 and 4.6 rc6), I was able to do two complete Linux installs on my X1000 with the R7 250X GPU! An awesome stride has been made in less than a year!

Do I smell a fresh pressed Ubuntu Mate 16.04 LTS installation DVD on the horizon from AmigaKit? :)

Cheers!!

John


John,

Thank you for your explanation and for testing the installation. Well done! :-)

Could you please test the RC7 of kernel 4.6 too?

Unfortunately there isn't any ubuntu MATE 16.04 LTS DVD on horizon from AmigaKit.

Thanks in advance,

Christian
http://www.amigalinux.org
http://www.supertuxkart-amiga.de

Running Linux on AmigaONEs can require some tinkering.
User avatar
xeno74
 
Posts: 5322
Joined: Fri Mar 23, 2012 8:58 am

Re: Kernel 4.6

Postby jdupuis » Tue May 10, 2016 10:28 am

Christian,

Hey, it didn't hurt to ask about a DVD, just merely curious.

I'm in early to work today and I'll be out early. I will test the new Kernel this afternoon. I have a couple of simple questions, but I will wait to ask those after testing and in a separate Topic. I'll report this evening CST.

Cheers!!

John
C= A500 2 megs RAM with A590 w/40 MB SCSI HD and Workbench 1.3
C= A3000 25 MHz with Workbench 3.1
AmigaOne X1000 4 GB RAM, XFX Radeon HD 6670 1GB GDDR5 GPU and AmigaOS 4.1 FE/Ubuntu 12.04.5 LTS/Ubuntu Mate 16.04 LTS
Sam460ex 2GB DDR2 800 MHz RAM, XFX Radeon HD 5450 2GB GDDR3 GPU, 3114 SATA Raid, ENVY24HT sound card and AmigaOS 4.1 FE
User avatar
jdupuis
 
Posts: 223
Joined: Sat May 09, 2015 8:19 am
Location: Baton Rouge, Louisiana USA

Re: Kernel 4.6

Postby jdupuis » Tue May 10, 2016 11:23 pm

xeno74 wrote:
jdupuis wrote:Hi Christian,

More testing with the R7 250x GPU and Kernel 4.6 rc6. Wiped out my original 16.04 install and prepared the Hard Drive for Julian's Southern Islands disk image. After copying and booting up it was a bit clunky starting out, but worked. Ubuntu Mate 16.04 SI disk image after config and upgrade is good. Smooth scrolling in Firefox. Glxgears looks good as well. P.A. Semi Ethernet stable. So to sum up.
I performed a new install of Ubuntu 12.04 booting DVD with Kernel 4.0.7. After which I booted Ubuntu 12.04 with Kernel 4.6 rc6. Downloaded and unpacked Julian's SI disk image and performed a new install of Ubuntu Mate 16.04 booting with 4.6 rc6. All is well.
X1000, Radeon HD R7 250X, Ubuntu 12.04 DVD and Kernels 4.0.7/4.6 rc6

It is fair to say that this is huge. With just the 12.04 DVD, the downloaded 16.04 SI disk image and two Kernels (4.0.7 and 4.6 rc6), I was able to do two complete Linux installs on my X1000 with the R7 250X GPU! An awesome stride has been made in less than a year!

Do I smell a fresh pressed Ubuntu Mate 16.04 LTS installation DVD on the horizon from AmigaKit? :)

Cheers!!

John


John,

Thank you for your explanation and for testing the installation. Well done! :-)

Could you please test the RC7 of kernel 4.6 too?

Unfortunately there isn't any ubuntu MATE 16.04 LTS DVD on horizon from AmigaKit.

Thanks in advance,

Christian



Hi Christian,

Radeon HD R7 250X GPU with Kernel 4.6 r7 /Ubuntu 12.04 /Ubuntu Mate 16.04. Works!
Ubuntu 16.04 (S.I.) Disk Image. Glxgears Good - 564 Frames in 5.0 seconds = 112.635 FPS. P.A. Semi Ethernet stable. Ubuntu 12.04 LTS 515 Frames (no updated Mesa installed). P.A. Semi Ethernet stable.
Kernel 4.6 r7 boots like 4.6.6. starts out a list of parses and Ubuntu Mate shows Kernel Modules loading [Fail] and Braille [Fail]. No show of problems due to this, however. Ghosting pointer problem seems a little better in 12.04 LTS with this Kernel. Ubuntu Mate runs well and is leaving 12.04 in it's dust.

Cheers!!

John
C= A500 2 megs RAM with A590 w/40 MB SCSI HD and Workbench 1.3
C= A3000 25 MHz with Workbench 3.1
AmigaOne X1000 4 GB RAM, XFX Radeon HD 6670 1GB GDDR5 GPU and AmigaOS 4.1 FE/Ubuntu 12.04.5 LTS/Ubuntu Mate 16.04 LTS
Sam460ex 2GB DDR2 800 MHz RAM, XFX Radeon HD 5450 2GB GDDR3 GPU, 3114 SATA Raid, ENVY24HT sound card and AmigaOS 4.1 FE
User avatar
jdupuis
 
Posts: 223
Joined: Sat May 09, 2015 8:19 am
Location: Baton Rouge, Louisiana USA

PreviousNext

Return to Platform: AmigaOne X1000 - Linux Only

Who is online

Users browsing this forum: No registered users and 2 guests

cron