Network-Penetrationtests & Network-Streaming Problem

AmigaOne X1000 platform specific issues.

Network-Penetrationtests & Network-Streaming Problem

Postby zappa2009 » Fri Oct 18, 2013 7:58 pm

Hello Hello ;)

I have some strange Freezes and Audio-hangs while i play Flac from my NAS.
Software are AmigaAmp3 and/or DaPlayer. (I test it on my XE too same Problemes as on my X1000) and the Netmon-docky.

AmigaAmp3 starts playing a Flac and then after fewseconds or after 1-3 Minutes no Sound and AmigaAMP3 freezes.
While this Freeze the whole System does nothing except the Mouse. But after 3 ot 4 Minutes Sound comes back to Live and AmigaAMP3 do play where it stops.

While this I see the Netmon-docky show the downloadrate goes from 0kb/s to 300kb/s again and again until the Freeze comes.

I have made some Serial-Logs so I hope you can see whats wrong.
See in the .zip please .

I found only one thats strange: the libgcc.so is read-write but should read-only or reverse I dont know.
Attachments
X1000-Logs.zip
There are 3 Logs inside.
(98.87 KiB) Downloaded 210 times
X1000 RadeonHD5450 4GB (2x2GB) DDR2-PC2-8500 Kingston HyperX 5-5-5-5-15 OS4.1.6 & Lubuntu13.04/mintppc11 with Kernel 3.8.7/3.9
User avatar
zappa2009
 
Posts: 230
Joined: Tue Jun 21, 2011 1:17 pm

Re: Network-Penetrationtests & Network-Streaming Problem

Postby zzd10h » Sat Oct 19, 2013 12:19 am

Certainly not related, but...

I had too problem with my x1000 when transfering a lot of datas from my NAS, networks hanged.

I had no problem with my Pegasos2 when doing the same transfers.

i suspect the x1000 stock-sound card (CMI8738)

my thread on the subject
viewtopic.php?f=33&t=1379&p=17093&hilit=Smbfs#p17086

If it's not relevant for you, try to use NetDock and aTunes ;)
http://apps.amistore.net/zTools
X1000 - AmigaOS 4.1.6 / 4.1 FE
zzd10h
 
Posts: 546
Joined: Sun Sep 16, 2012 6:40 am
Location: France

Re: Network-Penetrationtests & Network-Streaming Problem

Postby Raziel » Sat Oct 19, 2013 2:10 pm

The more interesting question is...how do you access your NAS?

Samba?
smbfs?
Through your browser?

I dont think the MediaPlayers are the ones whih crash but the underlying fs/software to access your NAS has some flaws!?
If slaughterhouses had glass walls, everyone would be a vegetarian. ~ Sir Paul McCartney
-
Did everything just taste purple for a second? ~ Philip J. Fry
-
Ain't got no cash, ain't got no style, ladies vomit when I smile. ~ Dr. John Zoidberg
User avatar
Raziel
 
Posts: 925
Joined: Sat Jun 18, 2011 5:00 pm
Location: a story that hasn't been written yet

Re: Network-Penetrationtests & Network-Streaming Problem

Postby zappa2009 » Sat Oct 19, 2013 6:09 pm

Hi I use smbfs for connecting my NAS .
The NAS is a Dlink-DND313 and can SMB and FTP. But with FTP i had the Problem with Specialchars like Ä Ö Ü cause my main Language is German (with Austrian Slang! )

Atunes use AmigaAMP3 or TuneNet for Playing so its the same thing as use AmigaAMP3/TuneNET stand alone.

Soundcard is HD-Audio but an Soundblaster is also inside but disabled. I can remove and test only with HD-Audio.

The Networkcard is the RTL6139 which came installed in my X1000 from Amigakit. But i can try with a RTL6169S .Its a physical Gigabit which OS4.1 can use it too ;)

I remove the Soundblaster and use only the HD-Audio.

But i think its a general Network-problem.
Copy a Flac with 30-50MB freeze the System !
Video if i play a Flac with AmigaAMP3
video-2013-10-19-17-39-15.mp4.zip
Video from NetDock showing the flippy Download rate.
(4.51 MiB) Downloaded 219 times
X1000 RadeonHD5450 4GB (2x2GB) DDR2-PC2-8500 Kingston HyperX 5-5-5-5-15 OS4.1.6 & Lubuntu13.04/mintppc11 with Kernel 3.8.7/3.9
User avatar
zappa2009
 
Posts: 230
Joined: Tue Jun 21, 2011 1:17 pm

Re: Network-Penetrationtests & Network-Streaming Problem

Postby zzd10h » Sat Oct 19, 2013 6:32 pm

it will not resolve your problem but there is newer version of netdock who wastes less space.
http://apps.amistore.net/zTools
X1000 - AmigaOS 4.1.6 / 4.1 FE
zzd10h
 
Posts: 546
Joined: Sun Sep 16, 2012 6:40 am
Location: France

Re: Network-Penetrationtests & Network-Streaming Problem

Postby zappa2009 » Sat Oct 19, 2013 6:44 pm

Oh the Netdock is ok so for me ;)

I think smbfs is the problem :(

If i download a Flac form my nas using Timberwolf I can copy a Flac (Just using FTP and the IP from my NAS as URL) without any Problems.

Hm If someone Know an Flac compatible Plugin that work with Timberwolf ?

Can AmigaAMP3 handle play thru FTP ?

Where can i set more Buffer for the Network-stack ?
X1000 RadeonHD5450 4GB (2x2GB) DDR2-PC2-8500 Kingston HyperX 5-5-5-5-15 OS4.1.6 & Lubuntu13.04/mintppc11 with Kernel 3.8.7/3.9
User avatar
zappa2009
 
Posts: 230
Joined: Tue Jun 21, 2011 1:17 pm

Re: Network-Penetrationtests & Network-Streaming Problem

Postby zappa2009 » Tue Oct 22, 2013 6:02 pm

No one has an Idea what i can do ?
X1000 RadeonHD5450 4GB (2x2GB) DDR2-PC2-8500 Kingston HyperX 5-5-5-5-15 OS4.1.6 & Lubuntu13.04/mintppc11 with Kernel 3.8.7/3.9
User avatar
zappa2009
 
Posts: 230
Joined: Tue Jun 21, 2011 1:17 pm

Re: Network-Penetrationtests & Network-Streaming Problem

Postby Raziel » Wed Oct 23, 2013 9:16 pm

zappa2009 wrote:No one has an Idea what i can do ?

I use AmigaAmp for playback from my NAS (smbs driven), longest check was 30 songs in a row without problems.
Also copying large files aint a problem

You can enhance the stack (smbfs-speific) within the smbfs line you use to log into your NAS (CACHE=somthing)
Im not at my miggy right now, but if you check the samba docs there are all the options layed out
I i dont forget ill post the line i use here

Also be sure to check for te latest smbfs version, there was one you an download from the sourceforge site (not sure if it ever made it onto he depot)

Dont give up just yet...we get you online without poblems ;-)
If slaughterhouses had glass walls, everyone would be a vegetarian. ~ Sir Paul McCartney
-
Did everything just taste purple for a second? ~ Philip J. Fry
-
Ain't got no cash, ain't got no style, ladies vomit when I smile. ~ Dr. John Zoidberg
User avatar
Raziel
 
Posts: 925
Joined: Sat Jun 18, 2011 5:00 pm
Location: a story that hasn't been written yet

Re: Network-Penetrationtests & Network-Streaming Problem

Postby nbache » Wed Oct 23, 2013 10:31 pm

Raziel wrote:You can enhance the stack (smbfs-speific) within the smbfs line you use to log into your NAS (CACHE=somthing)
Im not at my miggy right now, but if you check the samba docs there are all the options layed out
I i dont forget ill post the line i use here
There is a "CACHE=CACHESIZE/N/K" argument, but it deals with a directory cache, so I'm guessing it won't do much for the reading of one big file from the server.

Best regards,

Niels
User avatar
nbache
Beta Tester
Beta Tester
 
Posts: 1387
Joined: Mon Dec 20, 2010 8:25 pm
Location: Copenhagen, Denmark

Re: Network-Penetrationtests & Network-Streaming Problem

Postby zappa2009 » Wed Oct 23, 2013 11:17 pm

smbfs 1.74 from OS4depot and SourceForge are the same.
I set the Cache to his maximum but it do not really help. While Streaming / Copy the System-Freezes are shorter but still there.

But why does Timberwolf can download a CD.iso and the normal system not ?

Timberwolf download with FTP from my NAS. Copy manuelly in a shell with FTP hangs.

My Flac-Files are not really Big just 30 - 70 MB.

I still think the Networkstack is the Problem.
X1000 RadeonHD5450 4GB (2x2GB) DDR2-PC2-8500 Kingston HyperX 5-5-5-5-15 OS4.1.6 & Lubuntu13.04/mintppc11 with Kernel 3.8.7/3.9
User avatar
zappa2009
 
Posts: 230
Joined: Tue Jun 21, 2011 1:17 pm

Next

Return to Platform: AmigaOne X1000

Who is online

Users browsing this forum: No registered users and 2 guests