USB2 speed working on X1000 (printing)?

AmigaOne X1000 platform specific issues.

Re: USB2 speed working on X1000 (printing)?

Postby xenic » Tue Feb 26, 2013 11:11 pm

blmara wrote:I tried to make USBPRT: by copying PRT: mountlist and changing the device to usbprinter.device. But still the printer seems not to understand the AmiPDF-created file as PCL graphics but prints junk texts. I'm not good at mountlists, should I change some other parameters in the mountlist?


You've got the right idea. I copied the PAR: DosDriver (mountfile) and changed the device to usbprinter.device and boosted the stacksize parameter to 16384. Changing a copy of the PRT: DosDriver should work the same. I can't really test sending the AmiPDF LaserJet file output because I don't have a laser printer. However, you might try typing the file to USBPRT: instead of copying it. Try something like " type mylaserjetfile >USBPRT: " and see if that helps.

In the past I have changed the printer prefs to use the printtofile.device and then typed the resulting file to USBPRT: and that seemed to work.
AmigaOne X1000 with 2GB memory - OS4.1 FE
xenic
 
Posts: 1160
Joined: Sun Jun 19, 2011 1:06 am

Re: USB2 speed working on X1000 (printing)?

Postby blmara » Wed Feb 27, 2013 12:04 am

Ok. So now I changed Workbench printer to HP Laserjet 5, device: printtofile.device, greyscale, 300x300. And went to AmiPDF to print with the WorkBench driver, it produced the file (92184 bytes) very quickly. Then used 'type file >usbprt:'. As before, printer light blinked and blinked, and after exactly 10 minutes of waiting I interrupted the process by pressing the green button of printer. Result: it printed almost the whole form, to the level 'Päiväys'. For some reason it is very slow. If I interrupt the process earlier, the result is smaller part of the form. Tested also with the old HP_Deskjet_970C driver, it produces file almost the same size (90k), but that file prints nothing.

So, really there is a problem. The resulted file is very small, it cannot be even USB 1.1 but somehow the things happen very slowly inside (?) the printer. No such problem if same printer is used with Wind-ows. I'm puzzled!

Marko
blmara
 
Posts: 63
Joined: Thu Jun 23, 2011 10:03 am

Re: USB2 speed working on X1000 (printing)?

Postby xenic » Wed Feb 27, 2013 7:42 pm

blmara wrote:So, really there is a problem. The resulted file is very small, it cannot be even USB 1.1 but somehow the things happen very slowly inside (?) the printer. No such problem if same printer is used with Wind-ows. I'm puzzled!
Marko


Since I don't have a laserjet, I can't test your problem myself. However, have you considered the fact that you are trying to print to a newer laserjet with an old driver designed for a different laserjet? Newer HP printers use newer language and may not be very backward compatable. Over a year ago I had to replace my HP Photosmart with a newer model and the Amiga driver did not work as well as it had with my previous HP printer. I had to write a script to send a code to the the printer after printing a document so the printer would know the print job was done. The Amiga driver was later fixed so that my script was no longer needed. I'll give you the script to to try. It may have no effect on your problem or possibly have the same effect as pushing the panel buttons. Just run the script after you have printed to the Laserjet from AmiPDF or after you have typed the file produced by the printttofile device to the USBPRT: dos device.

Code: Select all
; Script to reset printer after a file is printed or typed to USBPRT:
echo "*E%-12345X" TO T:pout NOLINE
type T:pout TO USBPRT:
delete T:pout
AmigaOne X1000 with 2GB memory - OS4.1 FE
xenic
 
Posts: 1160
Joined: Sun Jun 19, 2011 1:06 am

Re: USB2 speed working on X1000 (printing)?

Postby BCPedigo » Wed Feb 27, 2013 11:36 pm

This may or may not be related. On a Windows machine, printing from Adobe Reader to network printers is very slow on an HP 5000 (which apparently has a very small buffer or slow processor) taking several minutes if there are complex graphics. On a newer HP 5200 the printing of the same pdf is much much faster. It appears that printing pdfs in general require laser printers to have larger buffers & more processing power, don't know if this applies to ink jets as well or whither usb is a factor or not.
AmigaOne XE-g3 Early Bird
AmigaOne X1000 FC
User avatar
BCPedigo
 
Posts: 6
Joined: Fri Dec 14, 2012 6:38 pm
Location: Indianapolis, Indiana U.S.A.

Re: USB2 speed working on X1000 (printing)?

Postby 328gts » Mon Mar 04, 2013 3:59 pm

@ blmara

so can you print both text & graphics??

Your printer is most likely a DOT4 printer like my HP LaserJet 1012 so follow this 'tiny' thread over at amigans.net http://www.amigans.net/modules/xforum/viewtopic.php?start=0&topic_id=3273&viewmode=flat&order=ASC&type=&mode=0. ;)

quick synopsis: rwo started a dot4 driver but it had limited success with text only. Jump to a few months back and terminills is working on getting gutenprint from linux to work on AROS which in turn could work on OS4.1 (he now has a Samflex to work with). I've tested gutenprint on my netobbok running AspireOS and it's the first time ever I've been able to print both text & graphics on my DOT4 USB printer so things are coming together.
A1-X1000 setup: Corsair GS800 800w PSU, Western Digital 250 GB SATA HDD (model:WD2500YS), 4GB Ram, Radeon HD7950-3GB GDDR5- Dual Slot, Lite-On RW DVD/CD, On-Board Nemo sound,8139B NIC, Catweasel MK4+
User avatar
328gts
 
Posts: 541
Joined: Thu Feb 10, 2011 6:53 pm
Location: Toronto, Canada

Previous

Return to Platform: AmigaOne X1000

Who is online

Users browsing this forum: No registered users and 1 guest

cron