AutoDocs: speedbar_gc errors & dicrepancies

Have a question about our Software Developer Kit? Ask them here.

AutoDocs: speedbar_gc errors & dicrepancies

Postby OldFart » Mon Jan 30, 2012 8:51 pm

Chapter . . .: SBM_SETNODEATTRS

Section . . .: Attributes:
Tag SBNA_MXGroup

Information to be changed:
Datatype of ti_Value should be WORD

Section . . .: Result:
SBNA_MXGroup (WORD) (V41)
Set the mutual exclude group a button belongs to. This setting
implies the SBNA_Toggle attribute is TRUE also. Note, a single
speedbar can contain several MX groups and mixtures of toggles
and normal selections.

The default is ~0, meaning not in any MX group.
Sleeping X5000, eagerly awaiting awakening
Dead MicroA1
A1200 in ElBox, c/w Blizzard '040 @ 50MHz + SCSI module, ZIV-board c/w (o.a.) cv64/3d + flickerdoubler + FastATA-ZIV + Lots of SCSI gear (for sale, willing to split)
RaspBerry Pi 2B, 3B & 4B (4Gb)
User avatar
OldFart
 
Posts: 54
Joined: Tue Jul 12, 2011 3:56 pm
Location: Groningen, Netherlands

Re: AutoDocs: speedbar_gc errors & dicrepancies

Postby tonyw » Tue Jan 31, 2012 12:52 am

All tags are uint32 (a full longword), as defined by "typedef ULONG Tag" and "struct TagItem" (See include/utility/tagitem.h).

Although only the lower 16 bits of the longword are used in this case, it still has to be a full 32 bit longword, otherwise the next Tag in the TagList will be misaligned.

Also don't forget that ALL TagLists must be terminated with a ", TAG_END);" or ", TAG_DONE);".
cheers
tony
User avatar
tonyw
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 1385
Joined: Wed Mar 09, 2011 2:36 pm
Location: Sydney, Australia


Return to SDK Support

Who is online

Users browsing this forum: No registered users and 1 guest