Cairo sdk

Have a question about our Software Developer Kit? Ask them here.

Cairo sdk

Postby YesCop » Wed Oct 26, 2011 11:43 pm

Hi,
I am going to create two threads about cairo, one here and one in the developper forum.
I created an account to have some answers that I didn't have elsewhere. In the same time, here I am sure that brothers gods will hear me...
About SDK, I would know why there is no static version of libcairo and some others libraries attached to it (libpixman-1, fontconfig...).
Second, is it possible in the waiting next version of sdk, the cairo library is buld against newer versions of lib like png15.

These remarks could help me to get rid of the warnings I have when I compile a cairo source (see below).
Of course the libz and libpng exist as a plain object or a link.
Naturally, if somebody has a solution now, I will take it.

I have some others (interesting ?) questions about cairo. don't be ashame, go there ! ;)

Thanks
YesCop
Code: Select all
ppc-amigaos-gcc -mcrt=newlib -O2 -Wall -I/SDK/Local/common/include/cairo   -c -o test.o test.c
test.c: In function 'main':
test.c:73: warning: 'op' is used uninitialized in this function
ppc-amigaos-gcc -mcrt=newlib -o test -use-dynld test.o -lcairo -lpixman-1 -lpng12 -lz -lfreetype -lfontconfig -lexpat -lpthread
ld: warning: libpng.so, needed by /SDK/local/newlib/lib/libcairo.so, not found (try using -rpath or -rpath-link)
ld: warning: libz.so, needed by /SDK/local/newlib/lib/libcairo.so, not found (try using -rpath or -rpath-link)
User avatar
YesCop
 
Posts: 44
Joined: Wed Oct 26, 2011 12:45 am
Location: Caen, France

Return to SDK Support

Who is online

Users browsing this forum: No registered users and 2 guests