Strange libz behaviour

Have a question about our Software Developer Kit? Ask them here.

Strange libz behaviour

Postby Raziel » Sat Feb 09, 2013 12:46 am

I haven't done much with this library, actually it only gets used here in ports that use libpng...but then the beast bites.

I had problems getting anything to build with that library (not sure if it is sdk material or third party)
I got a ld warning that libz is needed by libpng but everything was installed fine.

Snoopy gave the answer then:

The SDK is looking for libz here:
Code: Select all
01242 : ld              : FAIL = Open("gcc:ppc-amigaos/lib/libz.so",OLD) = [0x00000000] [56uS]
01243 : ld              : FAIL = Open("gcc:ppc-amigaos/lib/libz.so",OLD) = [0x00000000] [47uS]
01244 : ld              : FAIL = Open("gcc:lib/libz.so",OLD) = [0x00000000] [46uS]
01245 : ld              : FAIL = Open("usr:local/lib/libz.so",OLD) = [0x00000000] [63uS]
01246 : ld              : FAIL = Open("lib:libz.so",OLD) = [0x00000000] [45uS]
01247 : ld              : FAIL = Open("usr:lib/libz.so",OLD) = [0x00000000] [44uS]
01248 : ld              : FAIL = Open("gcc:ppc-amigaos/lib/libz.so",OLD) = [0x00000000] [47uS]
01249 : ld              : FAIL = Open("gcc:ppc-amigaos/lib/libz.so",OLD) = [0x00000000] [46uS]
01250 : ld              : FAIL = Open("gcc:lib/libz.so",OLD) = [0x00000000] [45uS]
01251 : ld              : FAIL = Open("usr:local/lib/libz.so",OLD) = [0x00000000] [46uS]
01252 : ld              : FAIL = Open("lib:libz.so",OLD) = [0x00000000] [44uS]
01253 : ld              : FAIL = Open("usr:lib/libz.so",OLD) = [0x00000000] [44uS]


while all other libs are looked for in the PATH and the path i gave with -L

Why libz isn't found is beyond me.

I worked around this issue with assigning a lib: to sdk:local/newlib/lib in user-startup.

If anyone can tell me how i can properly fix this, i'd be grateful.
If slaughterhouses had glass walls, everyone would be a vegetarian. ~ Sir Paul McCartney
-
Did everything just taste purple for a second? ~ Philip J. Fry
-
Ain't got no cash, ain't got no style, ladies vomit when I smile. ~ Dr. John Zoidberg
User avatar
Raziel
 
Posts: 925
Joined: Sat Jun 18, 2011 5:00 pm
Location: a story that hasn't been written yet

Return to SDK Support

Who is online

Users browsing this forum: No registered users and 1 guest

cron