Page 1 of 2

AmigaOS4.1 ???

PostPosted: Tue May 10, 2011 2:13 pm
by zool
Is there a way to run the game on AmigaOS4.1 ?

Re: AmigaOS4.1 ???

PostPosted: Tue May 10, 2011 2:53 pm
by Thomas Frieden
Heretic 2 is currently not supported on AmigaOS 4.1. It might run with the WarpUp emulation that is avaiable, but this is not officially supported.

Re: AmigaOS4.1 ???

PostPosted: Sat Jun 18, 2011 10:07 am
by ChrisH
Thomas Frieden wrote:Heretic 2 is currently not supported on AmigaOS 4.1. It might run with the WarpUp emulation that is avaiable, but this is not officially supported.

In my tests (and others are the same I think) the best you can get is corrupt graphics (looks like the pixel format is not supported) followed by it crashing after a few minutes. Looks like it would not be too hard for you to get it properly working....

Re: AmigaOS4.1 ???

PostPosted: Sat Jun 18, 2011 9:07 pm
by nubechecorre
I don't know how these things work but i guess that it has something to do with the license of the game.. i do not know if they can update the game to make it work under amiga os 4.1.. Originally Hyperion bought the license from activision/raven games for Amiga OS 3.9..

But it's only a guess.. :)

Re: AmigaOS4.1 ???

PostPosted: Tue Jun 21, 2011 9:08 pm
by RobMattin
nubechecorre wrote:I don't know how these things work but i guess that it has something to do with the license of the game.. i do not know if they can update the game to make it work under amiga os 4.1.. Originally Hyperion bought the license from activision/raven games for Amiga OS 3.9..

But it's only a guess.. :)



I don't think there are any licensing issues. I'm pretty sure that shortly after Hyperion got the OS4 contract Ben was saying there would be OS4 versions. I think there were problems with Worms Armageddon since that license was tied to Gateway's AmigaNG.

I would like to see an OS4 port of Heretic 2 since I never got around to completing it.

Re: AmigaOS4.1 ???

PostPosted: Wed Jun 22, 2011 10:21 am
by Thomas Frieden
The only thing I can say is that Heretic 2 is currently not supported on OS4, and this is not likely to change.

Re: AmigaOS4.1 ???

PostPosted: Thu Jun 23, 2011 2:09 pm
by ChrisH
Thomas Frieden wrote:this is not likely to change.

Many thanks for letting us know we should not get our hopes up.

I'm a lot more interested in Timberwolf anyway :)

Re: AmigaOS4.1 ???

PostPosted: Thu Jun 23, 2011 10:29 pm
by Karlos
Whilst not supported, I can confirm that at least the demo version runs on my classic 4.1 installation (was installed under OS3.x). However, it does DSI on exit.

Re: AmigaOS4.1 ???

PostPosted: Fri Jun 24, 2011 12:00 am
by nubechecorre
Could anyone explain me how can this and all the others Hyperion's game run under MOS? Is there some kind of wrapper? if so, could it possible to do the same under Amiga OS? :)

Re: AmigaOS4.1 ???

PostPosted: Fri Jun 24, 2011 1:07 am
by Karlos
nubechecorre wrote:Could anyone explain me how can this and all the others Hyperion's game run under MOS? Is there some kind of wrapper?

Yes. The wrapper (presumably) provides all the functions provided by powerpc.library, handles the WarpOS argument-passing conventions (which is slightly different to the common powerpc ABI specification) and delegates any 68K code in the fat executable to the built-in 68K emulation (trance) and does a bit of housework in the middle of it all.

if so, could it possible to do the same under Amiga OS? :)

Yes. Take the above paragraph and substitute "MOS" for "OS4" and "trance" for "petunia" and that's pretty much what you have already :)