Shogo OS4: Program doesn't properly close

Shogo OS4: Program doesn't properly close

Postby Corporal Up The Nuts » Tue Mar 19, 2019 11:17 pm

Hello


The game doesn't completely close when I tried to close it via the Exit option in the Main Menu.

The game makes a confirmation sound, but the game window doesn't close
the game stops refreshing the screen but the music keeps on playing.

The system doesn't crash, I can still switch screens via Left Amiga+N and continue using the system with the music still playing in the background.


My machine is an AmigaOne XE with a 7457 @1066Mhz, 1024MB Ram, Radeon 9250 128MB 64 bit
with AmigaOS 4.1.FE Update 1 on SmartFileSystem on Sil0680 PATA controller

No "DMA fixes" installed


*Edit* The same thing seems to happen when I choose the Custom Level option in the Main Menu,
game stops refreshing, music keeps on playing
Corporal Up The Nuts
 
Posts: 11
Joined: Sat May 10, 2014 1:30 pm

Re: Shogo OS4: Program doesn't properly close

Postby samo79 » Sun Mar 31, 2019 1:29 am

Same problem here on my Sam440 Flex and AmigaOS 4.1 FE Update 1 ... but it's not always reproducible so i don't exactly know where to check ...
i also noted that Shogo tend to crash at startup in case the audio is already busy with something else in background (AmigaAMP for example) using the same Unit port for both (tested with AHI set to Unit 0)
User avatar
samo79
 
Posts: 540
Joined: Sat Jun 18, 2011 12:13 am
Location: Italy

Re: Shogo OS4: Program doesn't properly close

Postby Goos » Sun Mar 31, 2019 1:24 pm

samo79 wrote:Same problem here on my Sam440 Flex and AmigaOS 4.1 FE Update 1 ... but it's not always reproducible so i don't exactly know where to check ...
i also noted that Shogo tend to crash at startup in case the audio is already busy with something else in background (AmigaAMP for example) using the same Unit port for both (tested with AHI set to Unit 0)


Thank you for your hint to AmigaAMP, I can reproduce that here.

EDIT: Will be fixed in Version 1.6
User avatar
Goos
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 16
Joined: Mon Oct 03, 2011 3:24 pm

Re: Shogo OS4: Program doesn't properly close

Postby samo79 » Sun Mar 31, 2019 3:58 pm

Thanks :-)

Perhaps the "exit" problem might be related to the VSync ?
I've toggle off it from the launcher and now the game seems closing normally after pressing exit .. need more test yo be sure aniway
User avatar
samo79
 
Posts: 540
Joined: Sat Jun 18, 2011 12:13 am
Location: Italy


Return to Shogo

Who is online

Users browsing this forum: No registered users and 1 guest

cron