Page 1 of 1

System not stable

PostPosted: Mon Oct 02, 2017 11:52 pm
by amc
Dear all,
I finally purchased AmigaOS 4.1 FE for Pegasos 2 but after a straightforward install I'm getting too many Grim Reapers Guru Mediation 0x80000003 Data Storage Interrupt. My system is:

- Pegasos II SmartFirmware 1.1 (up050404), CPU PowerPC G4 1 GHz board rev. 1.1
- 1GB RAM 2x 512MB DDR400
- ATI Radeon 9250 128MB V/D/VO AGP
- HDD 160GB (master) and LG DVD RAM (slave) with 80-pin cable (not cable select settings)
- Amiga OS FE 4.1 Update 1
- 100Mbit/s onboard Ethernet using DHCP

HDD has four partitions: boot 1GB (FFS), DH0 15 GB (FFS), SWAP 8GB and DH1 50GB, (FFS). Unformatted space available.

I'm experiencing random Grim Reapers as mentioned, especially (but not only) during disk access, for example while using SDK GCC, or trying to load Timberwolf, at the some point (in this case). I tried to debug and go deeper and in one case crashed module was "newlib", but this is a too much poor statistic to state it always depends on it.

Sometimes the machine freezes completely during graphical operations, like zooming an area in AmiPDF or resizing a Multiview window while playing an animation.

It's annoying and frustrating as I would like to enjoy my AmigaOS machine!

Since I have much spare hardware, I have tried many combinations, like replacing the video card or using slower RAM or a smaller capacity hard drive but it doesn't seem crashes depend on these parts.

Could someone please provide a bit of support? Please let me know what additional information is required.

Thank you

Re: System not stable

PostPosted: Mon Oct 09, 2017 1:34 pm
by smf
I'we had my Pegasos II since they were still manufactured and have many times experienced that they got unstable.
Every time it has been due to bad contacts or bad ram.
I have had bad contact with a pci card, the cpu card and also the ram, and once i had to buy new ram.

I usually run a memtester when it get's unstable and let it run for several hours. ... tester.lzx

afaik you also need the latest motherboard revision to run it stable with two memory modules.

The fact that you're using FFS as filesystem should not impact stability, it will only make it much slower.

Re: System not stable

PostPosted: Thu Oct 12, 2017 7:54 pm
by amc
Dear smf,
thank you for your answer.

In the meanwhile I have performed some further investigations and I found that board revision is "2B", I believe it's not the latest.

I'm awaiting for a new heat sink for the G4 and when it will arrive I'll disassemble the board and clean all the slots. I'll perform the memory test when I'll be sure that CPU will be correctly cooled, at the moment I'm not.

I'm also experiencing checksum read errors from the hdd, DH1 partition, but I previously tested it with badblocks command in a Linux environment and it stated the disk is good. I'm guessing whether it could depend on MaxTransfer and Mask values in partitions definitions as I remember that in classic Amigas they were the first cause for bad data transferring and data corruption, but I don't know if they are still in use with the new release and filesystems.

Thank you

Re: System not stable

PostPosted: Tue Oct 24, 2017 10:31 am
by lazi
In the past I had weird freezes on my Peg2, especially random filesystem errors.
The conclusion was bad power supply contact on the motherboard.
The ATX power connector clearly feels loose. I heard that somebody replaced it on the motherboard to solve such problems.

One time a PSU change solved my problem, another time just made the plug a bit tighter.