AmigaOne 500 locks up after removing sii3512

This forum is for all AmigaOne 500, Sam440 and Sam460 specific issues.

AmigaOne 500 locks up after removing sii3512

Postby pioneer » Sat Mar 17, 2012 3:39 pm

I have an AmigaOne 500. It has a sii3512 PCI SATA card with two ports. A Kingston SSD drive and a DVD drive are connected to the two ports. I'd like to pull the sii3512 card and connect the SSD drive to the onboard SATA port and leave the DVD drive disconnected for now. I'd like to try using a Sound Blaster 512 in the PCI slot since the onboard audio doesn't work very well. I pulled the sii3512 card and connected the SSD drive to the motherboard. I have OS4 on an SD which I can boot from if necessary. I modified the boot sequence so this is all working. It boots okay until it gets to the OS4 splash screen, then it locks up and won't go any farther. I also tried bypassing startup-sequence and it locks up at the AmigaDOS window. I'm wondering if anyone knows why it's locking up and what I can do about it.
pioneer
 
Posts: 7
Joined: Sun Mar 04, 2012 5:15 am

Re: AmigaOne 500 locks up after removing sii3512

Postby Spectre660 » Sat Mar 17, 2012 4:26 pm

Two questions for clarity .
What are you booting kickstart from ? The SD Card or the SSD ?
And what are you trying to boot OS4 from? . the SD card or the SSD ?
Spectre660
 
Posts: 1489
Joined: Sat Jun 18, 2011 3:16 pm
Location: Montserrat

Re: AmigaOne 500 locks up after removing sii3512

Postby Christopher Follett » Sat Mar 17, 2012 4:34 pm

pioneer wrote:I have an AmigaOne 500. It has a sii3512 PCI SATA card with two ports. A Kingston SSD drive and a DVD drive are connected to the two ports. I'd like to pull the sii3512 card and connect the SSD drive to the onboard SATA port and leave the DVD drive disconnected for now. I'd like to try using a Sound Blaster 512 in the PCI slot since the onboard audio doesn't work very well. I pulled the sii3512 card and connected the SSD drive to the motherboard. I have OS4 on an SD which I can boot from if necessary. I modified the boot sequence so this is all working. It boots okay until it gets to the OS4 splash screen, then it locks up and won't go any farther. I also tried bypassing startup-sequence and it locks up at the AmigaDOS window. I'm wondering if anyone knows why it's locking up and what I can do about it.


Have you commented out the SII card in kicklayout?
Resolute and Industrious
Grand ruler of the yellow people and the Ultimate Amiga Empire

http://www.ultimateamiga.co.uk (Home of SONY PSP Amiga Emulator and AMOS Factory)
__________________
Customer Help & Support: http://www.amigakit.com/help

http://www.amigakit.com - the Amiga store

New Products
User avatar
Christopher Follett
AmigaKit
AmigaKit
 
Posts: 650
Joined: Mon Feb 21, 2011 6:56 pm
Location: Wales, UK

Re: AmigaOne 500 locks up after removing sii3512

Postby pioneer » Sun Mar 18, 2012 5:36 am

I can boot from the SD card. It is a copy of the AmigaOS4.1 update 2 install CD. There are some other things I can't do. I booted from the SD card with the SSD drive connected to the onboard SATA port. I tried to modify the kicklayout file on the SSD drive, commenting out all the drivers but the sam460sata one. When I tried to save the file the computer locked up. I tried using media toolbox. It said the drive was modified, even though I didn't modify it. So it tried saving the congifuration and the computer locked up. Later I discovered that it also messed up my partitions at the same time, wiping everything out. When I tried to resave the RDB, which it said was corrupted I got a guru. The pattern looks like whenever I try to save anything to the drive of any sort the computer locks up. I reinserted the sii3512 card and managed to get the drive straighten out, although I'll have to reinstall everything. It also locks up when trying to set up a different hard drive. Im thinking my SAM 460 motherboard has a bad SATA port.
pioneer
 
Posts: 7
Joined: Sun Mar 04, 2012 5:15 am

Re: AmigaOne 500 locks up after removing sii3512

Postby Christopher Follett » Sun Mar 18, 2012 12:35 pm

pioneer wrote:I can boot from the SD card. It is a copy of the AmigaOS4.1 update 2 install CD. There are some other things I can't do. I booted from the SD card with the SSD drive connected to the onboard SATA port. I tried to modify the kicklayout file on the SSD drive, commenting out all the drivers but the sam460sata one. When I tried to save the file the computer locked up. I tried using media toolbox. It said the drive was modified, even though I didn't modify it. So it tried saving the congifuration and the computer locked up. Later I discovered that it also messed up my partitions at the same time, wiping everything out. When I tried to resave the RDB, which it said was corrupted I got a guru. The pattern looks like whenever I try to save anything to the drive of any sort the computer locks up. I reinserted the sii3512 card and managed to get the drive straighten out, although I'll have to reinstall everything. It also locks up when trying to set up a different hard drive. Im thinking my SAM 460 motherboard has a bad SATA port.


Have you altered jumper 16?
As the PCI-E x1 port and Onboard Sata share stuff. They become exclusive, you have to enable sata in uboot and make sure j16 is set right.
Resolute and Industrious
Grand ruler of the yellow people and the Ultimate Amiga Empire

http://www.ultimateamiga.co.uk (Home of SONY PSP Amiga Emulator and AMOS Factory)
__________________
Customer Help & Support: http://www.amigakit.com/help

http://www.amigakit.com - the Amiga store

New Products
User avatar
Christopher Follett
AmigaKit
AmigaKit
 
Posts: 650
Joined: Mon Feb 21, 2011 6:56 pm
Location: Wales, UK

Re: AmigaOne 500 locks up after removing sii3512

Postby mechanic » Sun Mar 18, 2012 3:00 pm

@Pioneer

What filesystem are you using on the SSD?
A-Eon A1X1000
User avatar
mechanic
 
Posts: 495
Joined: Sat Jun 25, 2011 10:22 pm

Re: AmigaOne 500 locks up after removing sii3512

Postby pioneer » Sun Mar 18, 2012 3:26 pm

The jumper is on and Uboot is set to SATA-2. This is what the docs say to do. My SSD drive has SFS/02. I was able to save a couple of small files. Now I'm thinking it's the driver. If it is it's very flakey, not usable at all. I may have to give this up until the driver is improved.
pioneer
 
Posts: 7
Joined: Sun Mar 04, 2012 5:15 am

Re: AmigaOne 500 locks up after removing sii3512

Postby pioneer » Sun Apr 15, 2012 4:12 am

I solved the lockup problem by finding a 3-1/2-inch hard drive that the build-in SATA interface supports. It didn't like the Kingston SSD drive and a Toshiba laptop drive. Both were 2-1/2-inch drives. The solution was easy, but not really obvious.
pioneer
 
Posts: 7
Joined: Sun Mar 04, 2012 5:15 am


Return to Platform: AmigaOne 500 and Sam series

Who is online

Users browsing this forum: No registered users and 2 guests