Kinda disapointed, need to share my views

This forum is for all AmigaOne 500, Sam440 and Sam460 specific issues.

Re: Kinda disapointed, need to share my views

Postby ssolie » Mon Mar 19, 2012 8:12 pm

Hans wrote:I know that some people refuse to accept my development priorities and insist on believing that implementing overlay should be trivial. However, overlay is a major task which affects only DvPlayer and MPlayer, whereas 3D drivers affect every single 3D game, and will open up a whole new world of possibilities thanks to the powerful shader units in modern cards. 3D support comes first.

I agree with your priorities 100%. It is far more important to have hardware accelerated 3D added to AmigaOS.

Some say the customer is already right. Well, sometimes they are not 100% right. ;)
ExecSG Team Lead
User avatar
ssolie
Beta Tester
Beta Tester
 
Posts: 1010
Joined: Mon Dec 20, 2010 9:51 pm
Location: Canada

Re: Kinda disapointed, need to share my views

Postby Spectre660 » Mon Mar 19, 2012 8:48 pm

There is always the option to use a PCI radeon 9250, Internal SATA for the Hardrive and USB DVD drive for those who must have Overlay now.

ssolie wrote:
Hans wrote:I know that some people refuse to accept my development priorities and insist on believing that implementing overlay should be trivial. However, overlay is a major task which affects only DvPlayer and MPlayer, whereas 3D drivers affect every single 3D game, and will open up a whole new world of possibilities thanks to the powerful shader units in modern cards. 3D support comes first.

I agree with your priorities 100%. It is far more important to have hardware accelerated 3D added to AmigaOS.

Some say the customer is already right. Well, sometimes they are not 100% right. ;)
Spectre660
 
Posts: 1489
Joined: Sat Jun 18, 2011 3:16 pm
Location: Montserrat

Re: Kinda disapointed, need to share my views

Postby Delta » Fri Mar 23, 2012 2:24 am

Got some spare time to restart my system from scratch, installed only the software I knew was working OK. Flushed samba (never been abkle to connect to win7 or my NAS anyways...)

@davebraco
here's the result of idetool:

6.Workbench:> idetool -l sii3114ide.device
-------------------Unit 0 information------------------------
Flags : $000001A7 - present, LBA48 used, supports DMA, ATA, supports acoustic mgmt, supports cache flush, interrupts used,
Xfer mode : best pio 12 (PIO 4, 16 MB/s) / best dma 70 (UDMA 6, 133 MB/s) / current 12 (PIO 4, 16 MB/s)
Total blocks : 625142448
Blocksize : 512
Power mode : 2 / idle (ready for operation)
IO1 / IO2 / BMCR @ : $1000 / $100A / $1020
*** Error opening device sii3114ide.device / unit 1
*** Error opening device sii3114ide.device / unit 2
-------------------Unit 3 information------------------------
Flags : $0000011D - present, supports DMA, removable media, ATAPI, interrupts used,
Xfer mode : best pio 12 (PIO 4, 16 MB/s) / best dma 69 (UDMA 5, 100 MB/s) / current 12 (PIO 4, 16 MB/s)
Total blocks : 0
Blocksize : 0
SCSI devtyp : 5
Packet size : 12
Current medium read speed : x 65535 ('65535' stands for max.)
Current medium write speed : x 65535 (idem)
Power mode : 2 / idle (ready for operation)
IO1 / IO2 / BMCR @ : $1010 / $101A / $1028
*** Error opening device sii3114ide.device / unit 4
*** Error opening device sii3114ide.device / unit 5
*** Error opening device sii3114ide.device / unit 6
*** Error opening device sii3114ide.device / unit 7
*** Error opening device sii3114ide.device / unit 8
*** Error opening device sii3114ide.device / unit 9
*** Error opening device sii3114ide.device / unit 10
*** Error opening device sii3114ide.device / unit 11
*** Error opening device sii3114ide.device / unit 12
*** Error opening device sii3114ide.device / unit 13
*** Error opening device sii3114ide.device / unit 14
*** Error opening device sii3114ide.device / unit 15

Any hint?
-=Delta
User avatar
Delta
 
Posts: 25
Joined: Sat Dec 17, 2011 6:31 pm

Re: Kinda disapointed, need to share my views

Postby Hans » Fri Mar 23, 2012 2:50 am

Delta wrote:Got some spare time to restart my system from scratch, installed only the software I knew was working OK. Flushed samba (never been abkle to connect to win7 or my NAS anyways...)

Our version of Samba and smbfs is too old to work with Windows 7. They have a new version of the SMB/CIFS protocol which Samba doesn't support.

Delta wrote:@davebraco
here's the result of idetool:

6.Workbench:> idetool -l sii3114ide.device
-------------------Unit 0 information------------------------
Flags : $000001A7 - present, LBA48 used, supports DMA, ATA, supports acoustic mgmt, supports cache flush, interrupts used,
Xfer mode : best pio 12 (PIO 4, 16 MB/s) / best dma 70 (UDMA 6, 133 MB/s) / current 12 (PIO 4, 16 MB/s)
Total blocks : 625142448
Blocksize : 512
Power mode : 2 / idle (ready for operation)
IO1 / IO2 / BMCR @ : $1000 / $100A / $1020
*** Error opening device sii3114ide.device / unit 1
*** Error opening device sii3114ide.device / unit 2
-------------------Unit 3 information------------------------
Flags : $0000011D - present, supports DMA, removable media, ATAPI, interrupts used,
Xfer mode : best pio 12 (PIO 4, 16 MB/s) / best dma 69 (UDMA 5, 100 MB/s) / current 12 (PIO 4, 16 MB/s)
Total blocks : 0
Blocksize : 0
SCSI devtyp : 5
Packet size : 12
Current medium read speed : x 65535 ('65535' stands for max.)
Current medium write speed : x 65535 (idem)
Power mode : 2 / idle (ready for operation)
IO1 / IO2 / BMCR @ : $1010 / $101A / $1028
*** Error opening device sii3114ide.device / unit 4
*** Error opening device sii3114ide.device / unit 5
*** Error opening device sii3114ide.device / unit 6
*** Error opening device sii3114ide.device / unit 7
*** Error opening device sii3114ide.device / unit 8
*** Error opening device sii3114ide.device / unit 9
*** Error opening device sii3114ide.device / unit 10
*** Error opening device sii3114ide.device / unit 11
*** Error opening device sii3114ide.device / unit 12
*** Error opening device sii3114ide.device / unit 13
*** Error opening device sii3114ide.device / unit 14
*** Error opening device sii3114ide.device / unit 15

Any hint?


Do you have the sii3114ide_xfer env-var set in UBoot? If not, try setting it to 0000. You'll find more details in SYS:Documentation/IDE/sii3114ide_dev.doc. That will set your hard-drive to use the best transfer mode available.

Hans
Last edited by Hans on Fri Mar 23, 2012 3:56 am, edited 1 time in total.
http://hdrlab.org.nz/ - Amiga OS 4 projects, programming articles and more. Home of the RadeonHD driver for Amiga OS 4.x project.
User avatar
Hans
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 703
Joined: Tue Dec 21, 2010 10:25 pm
Location: New Zealand

Re: Kinda disapointed, need to share my views

Postby davebraco » Fri Mar 23, 2012 2:58 am

Your HardDisk and OpticalDrive are in PIO mode, slow and CPU eating.

Two solutions...
1 (please check sys:documentation/IDE/idetool)
idetool -x sii3114ide.device 0 70 >NIL:
idetool -x sii3114ide.device 3 69 >NIL: (but I think that it was better to set the optical drive to DMA 1 or 2 to be able to watch DVD Video)
You can safely try it by entering these lines in a shell, and then use idetool -l sii3114ide.device to check if it worked.

2 (please check sys:documentation/IDE/sii3114ide_dev.doc)
NVSetVar sii3114ide_xfer G00F (idem for the optical drive)
in a shell (or directly add this line in uboot console with the setenv/saveenv command)

First one, will tell the device to go to DMA mode at each boot (you can add these lines in the user-startup for exemple), Second one, will write it into the Sam's bios.

You don't need samba to access your NAS, use smbfs from OS4Depot. Add you NAS ip address and alias in sys:prefs/internet hosts section.
Here is the command line I use in a script :
smbfs >nil: workgroup=NQNT volumename=daCie user=davebraco password=mypassword service=//hipserv/nosfichiers/

EDIT : Beated by Hans
µA1 256mo SATA -> lend to a dev
A1200PPC 256Mo MediatorTX Radeon9250 SATA RTL8029 SOLO-1
Sam440ep 533mhz 512mo 64Go SSD
Sam460ex 1150mhz 2Go RadeonHD 6570LP ENVY24HT
AmigaOne X1000 4Go SSD R9 270X Catweasel MK4
AmigaOne X5000 -> work in progress
User avatar
davebraco
Beta Tester
Beta Tester
 
Posts: 139
Joined: Sat Jun 18, 2011 8:06 am
Location: Belgium

Re: Kinda disapointed, need to share my views

Postby Delta » Fri Mar 23, 2012 3:47 am

You guys rock!

I can see my NAS and transfer files, I can watch a DVD without crossing my fingers in hope it won't crash :)

Thanks!
-=Delta
User avatar
Delta
 
Posts: 25
Joined: Sat Dec 17, 2011 6:31 pm

Re: Kinda disapointed, need to share my views

Postby Hans » Fri Mar 23, 2012 3:57 am

Delta wrote:You guys rock!

I can see my NAS and transfer files, I can watch a DVD without crossing my fingers in hope it won't crash :)

Thanks!

Oh, so that's why DVD playback was horribly slow for you. Glad you've got things working better now.

Hans
http://hdrlab.org.nz/ - Amiga OS 4 projects, programming articles and more. Home of the RadeonHD driver for Amiga OS 4.x project.
User avatar
Hans
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 703
Joined: Tue Dec 21, 2010 10:25 pm
Location: New Zealand

Re: Kinda disapointed, need to share my views

Postby Delta » Fri Mar 23, 2012 4:12 am

Oh, so that's why DVD playback was horribly slow for you. Glad you've got things working better now.

Hans


Would seem so because it got much better after following Davebraco's instructions.

Now i'm still dreaming of seeing Quake2 run on this machine but I guess its one step at a time ;)
-=Delta
User avatar
Delta
 
Posts: 25
Joined: Sat Dec 17, 2011 6:31 pm

Re: Kinda disapointed, need to share my views

Postby vox » Mon Jul 16, 2012 6:17 pm

Much more joy to solve problems, then to just put things back to ebay.

Well SAM boards are quite limited, and make many nerve breakdowns but then again, once you get
the hardware setup right, OS is rock solid, hardware and OS hardware compatibility is other issue.

Audio is kind of issue, as well as onboard SATA which is kind of sad, because if only onboard SATA2
was dual connector and fast, you could put a PCI sound card and overcome all trouble.

A lot can be done to improve the system, agreed that lack of decent and needed OS components
is kind of ... lame. Hope Steven and friends would consider adding more and more libs on disk,
or autoupdate feature that would add the most necessary, kind of like AmiUpdate or its time that
apps could download it from net nowadays


I do know RadeonHD is not fully used, this will improve with AmigaOS 4.2

If you prefer, you can switch back to PCI Radeon 9250 and onboard SATA with only one SATA2 device ... meanwhile.
Or use Wazp3D library to play some 3D titles

Hang on and enjoy what you can, soon with OS 4.2 you will see how great AmigaOne 500 system is,
combined with 1GHz CPU, up to 2GB fast RAM, SATA2 and RadeonHD gfx
------------------------------------------
Future MOS user pon SAM460ex
https://www.facebook.com/rasvoja
https://www.youtube.com/user/rasvoja
http://socdevelopment.wordpress.com/
User avatar
vox
 
Posts: 173
Joined: Thu Jun 23, 2011 3:19 pm
Location: Belgrade Country:Serbia

Re: Kinda disapointed, need to share my views

Postby vox » Mon Jun 17, 2013 5:07 pm

djrikki wrote:The 3D graphics driver and overlay is something all parties involved have been trying their best to inform potential customers all about prior to purchase.

I own the SAM 460 myself and have no problems with overheating.

Simple stuff like including the SDK on the Install CD/Archive and offering the user to Uncheck the box if they don't want it is much better than expecting the user to download it themselves.
I hope when AmigaOS 4.2 is released it is bundled with loads of approved and latest versions of command line programs, third-party libraries and dependancies - especially as once the Netbook is released there is the potential for 100s if not 1000s of new users - first impressions count.

I am quite happy to download a 1GB+ OS Update if it makes life easier and pleasant for everyone.


While OS contribs bundle on DVD is one way of solving things, other one would be suing AmiUpdate during install to get the latest libs needed, or some solution similar to Linux for getting dependencies
------------------------------------------
Future MOS user pon SAM460ex
https://www.facebook.com/rasvoja
https://www.youtube.com/user/rasvoja
http://socdevelopment.wordpress.com/
User avatar
vox
 
Posts: 173
Joined: Thu Jun 23, 2011 3:19 pm
Location: Belgrade Country:Serbia

Previous

Return to Platform: AmigaOne 500 and Sam series

Who is online

Users browsing this forum: No registered users and 3 guests

cron