Page 1 of 1

ppc programs problem with powerpc.library

PostPosted: Fri Feb 15, 2013 5:19 pm
by lozspd4
Hi All
As posted before i have just got a new AmigaOne 500, and am now installing it, i have os4.1 till updates 6 installed then installed some ppc programs like WO2097, Amigawriter ,earth2140,when starting the programs i get a cannot open PowerPC.library v7 press ok and the program doesnt start.

I am using the original PowerPC.library that came with os4.1.

On the other Hand amigawriter ,earth2140 in 68mk work, even Nightlong Freespace Napalm works. I have installed a RADEON HD5450 Gfx Card which i dont think is the Problem.

If anyone else has experienced this and can shed some light maybe im doing something wrong on the Installation.

Many Thanks in Advance
Laurence

Re: ppc programs problem with powerpc.library

PostPosted: Sat Feb 16, 2013 12:09 am
by Petrol
There is no WarpOS emulation for Sam460 in the powerpc.library. Only classics, Aone SE/XE, pegasos and Sam440 are supported.

Regards,
Petrol

Re: ppc programs problem with powerpc.library

PostPosted: Sun Feb 17, 2013 12:58 am
by lozspd4
Hi Petrol
Thanks for the reply saved me a lot of time trying to figure it out comming from a os4.1 classic system. i wasn,t aware of that. One learns something new every day.:))

Regards
Laurence

Re: ppc programs problem with powerpc.library

PostPosted: Sun Feb 17, 2013 10:52 am
by thomasrapp
Why does WarpOS emulation need hardware dependency? Isn't it possible to make a generic library which just wraps WarpOS functions to OS4 functions?

Re: ppc programs problem with powerpc.library

PostPosted: Sun Feb 17, 2013 11:37 am
by kas1e
@thomasrapp
Problem is that powerpc.library is no more in develop as i see, and seems author never will worry about it anymore. So if someone new (by someone i mean ThomasRapp:) ) will write such a new library from scratch and make it opensource, then there is some chances to have better warpos support in end.