SAM440ep flex 667 CORE 1920x1080 black screen issue

This forum is for all AmigaOne 500, Sam440 and Sam460 specific issues.

SAM440ep flex 667 CORE 1920x1080 black screen issue

Postby toolkitman » Thu Jan 24, 2013 10:33 pm

HI All,
i'm new to the forum and to AMIGA OS 4.1, i have bought right now a new SAM 440ep flex 667 CORE complete sistem, i'm having an issue with the ati radeon 9250 128MB PCI 128bit connected to my philips 244E with DVI to DVI cable, i get a black screen when moving OWB window, the resolution is set to 1920x1080 60hz, i'm having trouble only in this resolution. I have used a DVI TO HDMI cable and at 1920x1080 60 hz the owb window moving doesent make a black screen, but the game Chromium BSU give me some black screen during game paly and loading. With VGA everithing works but the quility is worst. I hade black screen also with an efika and mos 3.1 with this monitor and cable and an amiga 1200 with indivision aga mk ii. So i dont know if it's a proble of screen or cable or a problem of wrong configuration or i dont know!!!
Please Help
toolkitman
 
Posts: 32
Joined: Thu Jan 24, 2013 5:17 pm

Re: SAM440ep flex 667 CORE 1920x1080 black screen issue

Postby Spectre660 » Thu Jan 24, 2013 10:54 pm

You can try to add "+RB" or "-RB" at the end of your resolutions (in the monitor tooltypes).
Example: MODE=1920x1080@60+RB
Spectre660
 
Posts: 1489
Joined: Sat Jun 18, 2011 3:16 pm
Location: Montserrat

Re: SAM440ep flex 667 CORE 1920x1080 black screen issue

Postby toolkitman » Thu Jan 24, 2013 10:56 pm

I have tried it doesnt works. Can be i set it in the wrong way?
toolkitman
 
Posts: 32
Joined: Thu Jan 24, 2013 5:17 pm

Re: SAM440ep flex 667 CORE 1920x1080 black screen issue

Postby Spectre660 » Thu Jan 24, 2013 11:04 pm

I think that I gave you the old way to do this.

Try the new way below
Have a look at Screenmode preferences in Prefs.
Click on the Monitor Tab.
Make sure that Detect settings automatically is unticked .
You can then select the mode that you want to adjust then select edit.
Select Type of Reduced Blanking. Either +RB or -RB.Click Confirm Changes.
Then Save Monitor. Reboot and see if it makes a difference.




toolkitman wrote:I have tried it doesnt works. Can be i set it in the wrong way?
Spectre660
 
Posts: 1489
Joined: Sat Jun 18, 2011 3:16 pm
Location: Montserrat

Re: SAM440ep flex 667 CORE 1920x1080 black screen issue

Postby ssolie » Thu Jan 24, 2013 11:41 pm

If multiple systems are having trouble with the same monitor I would suspect the monitor first.

Try Googling the make/model of your monitor and see if others are having trouble with it as well.
ExecSG Team Lead
User avatar
ssolie
Beta Tester
Beta Tester
 
Posts: 1010
Joined: Mon Dec 20, 2010 9:51 pm
Location: Canada

Re: SAM440ep flex 667 CORE 1920x1080 black screen issue

Postby mr2 » Fri Jan 25, 2013 2:13 am

Hello :D

How long does it stay black? I have similar problem with my SAM Flex since the begenning. Sometimes the whole image disappear for a while (half second, sometimes one or two). I've heard some graphic cards have such problem. A man with Peg2 and MOS had simillar black screens and solved it with a new graphic card. It was long, long time ago. I can't find it.... I gave up but remember that only resolutions like ....x1200 (1600x1200, 1920x1200) cause the problem with my configuration. I tried the lower resolutions (1600x1080, 1920x1080) and everything was fine (DVI). There is no problem with VGA output. Its like power dropout....
I even know how easily bring it on....if enybody is interested?

PS. My monitor is 1920x1200....and tried all the tricks with +RB/-RB
SAM440 Flex 800MHz 1GB R9250 SBLive! OS4.1 Update 6
mr2
 
Posts: 5
Joined: Sun Jan 13, 2013 10:40 pm

Re: SAM440ep flex 667 CORE 1920x1080 black screen issue

Postby toolkitman » Fri Jan 25, 2013 9:09 am

The screen disappear for half a second, please let me know mr2 thank you.
toolkitman
 
Posts: 32
Joined: Thu Jan 24, 2013 5:17 pm

Re: SAM440ep flex 667 CORE 1920x1080 black screen issue

Postby nbache » Sat Jan 26, 2013 12:39 am

mr2 wrote:How long does it stay black? I have similar problem with my SAM Flex since the begenning. Sometimes the whole image disappear for a while (half second, sometimes one or two).

[...]

PS. My monitor is 1920x1200....and tried all the tricks with +RB/-RB
Did you also try reducing the screen depth to 16 bit (along with the RB+)?

Best regards,

Niels
User avatar
nbache
Beta Tester
Beta Tester
 
Posts: 1395
Joined: Mon Dec 20, 2010 8:25 pm
Location: Copenhagen, Denmark

Re: SAM440ep flex 667 CORE 1920x1080 black screen issue

Postby toolkitman » Sat Jan 26, 2013 11:40 am

I will try and let you know ; ).
toolkitman
 
Posts: 32
Joined: Thu Jan 24, 2013 5:17 pm

Re: SAM440ep flex 667 CORE 1920x1080 black screen issue

Postby mr2 » Sun Jan 27, 2013 1:52 pm

Ok, tried with 16 bit palette but the screen blinks the same way. It happens few times per hour but when I use Lodepaint and try to draw something it blinks every few seconds. The same with Blender when try to move an object...annoying like hell. I dont remember which but some games causes the same black screen. I found a thread with a MOS guy. He had blinkings with R7000 and R9250 but with R9000 everything was OK. Still it doesn't say if it is SW or HW problem...

PS. I cant reproduce it right now but I remember that moving solid object causes this problem more often than the wireframe one.
SAM440 Flex 800MHz 1GB R9250 SBLive! OS4.1 Update 6
mr2
 
Posts: 5
Joined: Sun Jan 13, 2013 10:40 pm

Next

Return to Platform: AmigaOne 500 and Sam series

Who is online

Users browsing this forum: Google [Bot] and 1 guest