AmigaOS 4.1 Final Edition for classic

A forum for Classic Amiga specific support issues.

Re: AmigaOS 4.1 Final Edition for classic

Postby Amigafan » Sat Dec 13, 2014 8:06 pm

DarrenHD wrote:Ok confirmed. Issue is fixed but it's too late for Final Edition. However, we will likely post a work-around for you on these forums. eg. a new BootFloppy so you can install Ok on your A3000. So check back here soon. Sorry, if I had known about this sooner it would have been fixed sooner. If you reported this earlier and it didn't get back to me I apologize for that.


It must be joke!
I've personally reported this bug in 2012
tonyw and ssolie said that it is fixed and now we have learned that you even don't know about the issue.
I've paid 125 euro for commercial product (AmigaOS4.1) that turned out to be so poor that even can not be installed.
I don't know if this is by incompetence, mess or simply a lack of professionalism but now we have learned that next version, for another 30 euro, is still crap in terms of installing it on A3000 DESPITE that the problem was reported almost three years ago.
This is NOT what we (classic amiga users, especially A3000 users) was expecting.
Amigafan
 
Posts: 21
Joined: Sun Jun 24, 2012 10:58 am
Location: Warsaw, Poland

Re: AmigaOS 4.1 Final Edition for classic

Postby danbeaver » Sun Dec 14, 2014 11:48 pm

Although I remember your prior post, I too was surprised that such a simple issue had reportedly not been fixed; but mistakes do happen, so I hope you will be able to dial down your anger from the "11" setting.
User avatar
danbeaver
 
Posts: 367
Joined: Thu Jan 19, 2012 10:58 pm
Location: On the edge of the Equator in hot & humid Guam

Re: AmigaOS 4.1 Final Edition for classic

Postby ancalimon » Mon Dec 15, 2014 6:05 am

danbeaver wrote:Although I remember your prior post, I too was surprised that such a simple issue had reportedly not been fixed; but mistakes do happen, so I hope you will be able to dial down your anger from the "11" setting.


Maybe some fixed cds can be burned exclusively for A3000 owners?
ancalimon
 
Posts: 27
Joined: Tue Oct 18, 2011 8:31 am

Re: AmigaOS 4.1 Final Edition for classic

Postby DarrenHD » Sat Dec 20, 2014 2:17 am

ancalimon wrote:
danbeaver wrote:Although I remember your prior post, I too was surprised that such a simple issue had reportedly not been fixed; but mistakes do happen, so I hope you will be able to dial down your anger from the "11" setting.


Maybe some fixed cds can be burned exclusively for A3000 owners?


It can be fixed via an updated Boot Floppy, so a new ISO is not required. I will post the info on the fixed boot floppy once I have it, which hopefully will be soon.
AmigaOS 4.x Beta Tester - Classic Amiga enthusiast - http://www.hd-zone.com is my Amiga Blog, check it out!
User avatar
DarrenHD
Beta Tester
Beta Tester
 
Posts: 633
Joined: Mon Dec 20, 2010 4:38 pm
Location: London, Ontario, Canada

Re: AmigaOS 4.1 Final Edition for classic

Postby JurassicC » Mon Dec 22, 2014 8:44 pm

It can be fixed via an updated Boot Floppy, so a new ISO is not required. I will post the info on the fixed boot floppy once I have it, which hopefully will be soon.


Make a backup of your bootfloppy disc then:-

Modify the bootfloppy like this.

Create a new kickstart directory on the Bootfloppy so the disk has Bootfloppy:Kickstart

Copy the A3000 Kicklayout-A3000 file from :System/Kickstart directory on the CD to Bootfloppy:Kickstart/
Copy bootloader from :System/C directory on the CD to Bootfloppy:C/

Edit Bootfloppy:Kickstart/Kicklayout-A3000

Change the line

MODULE Kickstat/JXFileSystem

to

MODULE Kickstart/JXFileSystem

Edit Bootfloppy:s/startup-sequence

replace the line

BootFloppy:c/Execute S:Startup-Sequence

with

C:BootLoader FILENAME Bootfloppy:Kickstart/KickLayout-A3000 COMMANDLINE "AllowBasepageAccess"

Once you have installed OS4.1 using a modified bootfloopy, you will need to boot from Bootfloppy/CD one more time, select the livecd option, edit the installed kicklayout, save reboot and boot from HD
User avatar
JurassicC
Beta Tester
Beta Tester
 
Posts: 454
Joined: Wed Apr 20, 2011 1:21 pm
Location: UK

Re: AmigaOS 4.1 Final Edition for classic

Postby walkero » Thu Dec 25, 2014 5:48 pm

Amigafan wrote:It must be joke!
I've personally reported this bug in 2012
tonyw and ssolie said that it is fixed and now we have learned that you even don't know about the issue.
I've paid 125 euro for commercial product (AmigaOS4.1) that turned out to be so poor that even can not be installed.
I don't know if this is by incompetence, mess or simply a lack of professionalism but now we have learned that next version, for another 30 euro, is still crap in terms of installing it on A3000 DESPITE that the problem was reported almost three years ago.
This is NOT what we (classic amiga users, especially A3000 users) was expecting.


I really don't get the grumble of some people. it is not big deal to find a simple solution and resolve any issue. Mistakes happen. If you consider that even huge companies like Apple and Google release software which surely has major or minor problems. Even the latest iOS 8 or Android 5 had issues. You may not know this and you believe that all the other software houses release bug free code, but in the real world this doesn't happen. So, stop grumble around and try to be more positive than negative.
If you develop or want to develop for AmigaOS 4.x, then join us at OS4Coding.net
User avatar
walkero
Beta Tester
Beta Tester
 
Posts: 56
Joined: Mon Dec 20, 2010 3:05 pm
Location: Athens, Greece

Re: AmigaOS 4.1 Final Edition for classic

Postby danbeaver » Fri Dec 26, 2014 3:11 am

"Can't we all just get along?"
User avatar
danbeaver
 
Posts: 367
Joined: Thu Jan 19, 2012 10:58 pm
Location: On the edge of the Equator in hot & humid Guam

Re: AmigaOS 4.1 Final Edition for classic

Postby Amigafan » Mon Dec 29, 2014 5:37 pm

walkero wrote:I really don't get the grumble of some people. it is not big deal to find a simple solution and resolve any issue. Mistakes happen. If you consider that even huge companies like Apple and Google release software which surely has major or minor problems. Even the latest iOS 8 or Android 5 had issues. You may not know this and you believe that all the other software houses release bug free code, but in the real world this doesn't happen. So, stop grumble around and try to be more positive than negative.


I really don't get lack of professionalism or incompetence that happened here in beta testing.
Two people said it is fixed - tony and sookie - so they lied or you have such a mess there?
This is not small mistake but big problem that prevent installing OS so it shouldn't happen so stop grumble and do better betatesting.
You may not know this but in real world in any company if the bug is reported three years ago in an official forum it is fixed.
Amigafan
 
Posts: 21
Joined: Sun Jun 24, 2012 10:58 am
Location: Warsaw, Poland

Re: AmigaOS 4.1 Final Edition for classic

Postby Amigafan » Mon Dec 29, 2014 5:44 pm

JurassicC wrote:
It can be fixed via an updated Boot Floppy, so a new ISO is not required. I will post the info on the fixed boot floppy once I have it, which hopefully will be soon.

Make a backup of your bootfloppy disc then:-


This is better than nothing but still we can't boot from CD (like A4000 users can) and install OS without using of floppy.
It's nice that you have finally noticed the problem after so many years. I hope that other reported bugs do not wait such a long time for quick quasi-fix.
Amigafan
 
Posts: 21
Joined: Sun Jun 24, 2012 10:58 am
Location: Warsaw, Poland

Re: AmigaOS 4.1 Final Edition for classic

Postby DarrenHD » Tue Dec 30, 2014 6:47 am

Amigafan wrote:
JurassicC wrote:
It can be fixed via an updated Boot Floppy, so a new ISO is not required. I will post the info on the fixed boot floppy once I have it, which hopefully will be soon.

Make a backup of your bootfloppy disc then:-


This is better than nothing but still we can't boot from CD (like A4000 users can) and install OS without using of floppy.
It's nice that you have finally noticed the problem after so many years. I hope that other reported bugs do not wait such a long time for quick quasi-fix.


Hey, I understand the frustration. For whatever reason your bug report never reached the right people and I already apologized for that. That's something we can learn from but it's nothing I can go back and retro-fix. We've provided you a work-around and that's the best we can do. You are free to burn your own new ISO with the typo fixed so you can reinstall from SCSI CDROM.

Darren
AmigaOS 4.x Beta Tester - Classic Amiga enthusiast - http://www.hd-zone.com is my Amiga Blog, check it out!
User avatar
DarrenHD
Beta Tester
Beta Tester
 
Posts: 633
Joined: Mon Dec 20, 2010 4:38 pm
Location: London, Ontario, Canada

PreviousNext

Return to Platform: Classic

Who is online

Users browsing this forum: Majestic-12 [Bot] and 1 guest