Installation instructions for Picasso IV Addons

A forum for Classic Amiga specific support issues.

Installation instructions for Picasso IV Addons

Postby Calgor » Sat Jul 09, 2011 8:27 pm

What are the installation instructions for getting the Paloma, Concierto and Pablo working under OS4.1?

I followed the instructions included in the FAQ for the Paloma, namely modifying the kicklayout file to uncomment the p4specials.library entry and I copied the p4specials.library 68k version from my paloma floppy disk to LIBS: (instructions do not say from where to get this library)

I then manualy installed (without installer as that looked like it may overwrite some newer os4.1 picasso96 libs) the files from the floppy disk by reading the install script.

However the PalomaTV program would not load properly (after clicking on the icon, nothing happened except the mouse pointer disappeared, and nothing on the Picassoiv output).

So what is the proper way to install the programs for these addon hardware to work? I understand they have been tested to be working in the compatibility list.

Among other things the hardware needs:
Paloma: needs libs and PalomaTV to view TV
PabloII: needs special monitor modes specific to it (otherwise will output nothing)
Concierto: needs mixer utility so one can select what input to send to the output
Amiga 4000T: CSPPC 604e@233/060@50 146MB RAM/CVPPC/Mediator/Radeon 256MB/Realtek 8029AS/TerraTec Solo1-N/Picasso IV (Paloma Pablo Concierto)/Deneb/ZorRAM 256MB/Indivision AGA MKII/OS4.xBETA/OS4.1u4/OS3.9BB2
AmigaONE X1000: Nemo 2.1 PA6T-1682M@1.8 2GB RAM/Radeon HD 4770 512MB/Catweasel MK4+/Audigy 2 ZS/Realtek 8139D/OS4.xBETA/OS4.1u5
User avatar
Calgor
Beta Tester
Beta Tester
 
Posts: 319
Joined: Mon Dec 20, 2010 5:42 pm

Re: Installation instructions for Picasso IV Addons

Postby Calgor » Sat Jul 23, 2011 5:56 pm

Who was it from Hyperion/Beta Tester who used these hardware addons so that it is listed on the compatibility page?

Has anyone else successfully installed these drivers and can suggest what I did wrong with at least Paloma?
Amiga 4000T: CSPPC 604e@233/060@50 146MB RAM/CVPPC/Mediator/Radeon 256MB/Realtek 8029AS/TerraTec Solo1-N/Picasso IV (Paloma Pablo Concierto)/Deneb/ZorRAM 256MB/Indivision AGA MKII/OS4.xBETA/OS4.1u4/OS3.9BB2
AmigaONE X1000: Nemo 2.1 PA6T-1682M@1.8 2GB RAM/Radeon HD 4770 512MB/Catweasel MK4+/Audigy 2 ZS/Realtek 8139D/OS4.xBETA/OS4.1u5
User avatar
Calgor
Beta Tester
Beta Tester
 
Posts: 319
Joined: Mon Dec 20, 2010 5:42 pm

Re: Installation instructions for Picasso IV Addons

Postby tonyw » Sun Jul 24, 2011 6:21 am

Back in the old days when OS4 was still available to betatesters in 68K mode (before it became PPC only), I had it running on my A4000 with Picasso IV, Concierto and Paloma.

I was never able to get the add-on drivers to run under OS4, although they ran fine under OS3.9. I don't remember why, and I didn't have time to spend on it, but I'm sure it was because the drivers used some trickery that doesn't work under OS4.
cheers
tony
User avatar
tonyw
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 1361
Joined: Wed Mar 09, 2011 2:36 pm
Location: Sydney, Australia

Re: Installation instructions for Picasso IV Addons

Postby Calgor » Sun Jul 24, 2011 9:04 am

Thanks Tonyw. So it sounds like it may not just simply be a straightforward install.

I also put all newly installed Paloma files into the Petunia exception list but that did not help.

Looks like I will have to try and debug it myself if I want to get it to work (assuming that it will eventually work as it is on the compatibilty list).
All these addons are working on the same computer under OS3.9 so I know it's not a hardware problem.
Amiga 4000T: CSPPC 604e@233/060@50 146MB RAM/CVPPC/Mediator/Radeon 256MB/Realtek 8029AS/TerraTec Solo1-N/Picasso IV (Paloma Pablo Concierto)/Deneb/ZorRAM 256MB/Indivision AGA MKII/OS4.xBETA/OS4.1u4/OS3.9BB2
AmigaONE X1000: Nemo 2.1 PA6T-1682M@1.8 2GB RAM/Radeon HD 4770 512MB/Catweasel MK4+/Audigy 2 ZS/Realtek 8139D/OS4.xBETA/OS4.1u5
User avatar
Calgor
Beta Tester
Beta Tester
 
Posts: 319
Joined: Mon Dec 20, 2010 5:42 pm

Re: Installation instructions for Picasso IV Addons

Postby l3rd » Wed Aug 03, 2011 2:00 pm

I have tested the ad-don modules on the PicassoIV, which one is not working with you?
I believe that your P4 has the latest FW..
Amiga 4000: CSPPC 604e@180/060@50 / 146MB RAM / Mediator PCI 4000D
    Zorro: Picasso IV (Concierto/Paloma/Pablo) / Ariadne II / VLab Motion
    PCI: 3dfx VooDoo5 5500 64MB / Realtek 8029 / Terratec ESS Solo-1
User avatar
l3rd
Beta Tester
Beta Tester
 
Posts: 4
Joined: Sat Jun 18, 2011 9:22 am

Re: Installation instructions for Picasso IV Addons

Postby Calgor » Wed Aug 03, 2011 5:09 pm

Paloma is the main one not working that I have tried. I have not tried to install extra drivers for the other 2 yet. I need special monitor files or screenmodes for the Pablo which I do not know how I should install in OS4 (or in OS3.x for that matter unless I use the Pablo install disk).

Do you have instructions on what you did to get them to work?
Amiga 4000T: CSPPC 604e@233/060@50 146MB RAM/CVPPC/Mediator/Radeon 256MB/Realtek 8029AS/TerraTec Solo1-N/Picasso IV (Paloma Pablo Concierto)/Deneb/ZorRAM 256MB/Indivision AGA MKII/OS4.xBETA/OS4.1u4/OS3.9BB2
AmigaONE X1000: Nemo 2.1 PA6T-1682M@1.8 2GB RAM/Radeon HD 4770 512MB/Catweasel MK4+/Audigy 2 ZS/Realtek 8139D/OS4.xBETA/OS4.1u5
User avatar
Calgor
Beta Tester
Beta Tester
 
Posts: 319
Joined: Mon Dec 20, 2010 5:42 pm

Re: Installation instructions for Picasso IV Addons

Postby l3rd » Sun Aug 07, 2011 4:54 pm

Make sure that your PicassoIV has the latest FW (7.4).
Use the PicassoIV in Zorro3 mode.
You can download the drivers from one of the link listed here :http://www.villagetronic.com/classics/amiga.html

Hereafter you can find a list of file needed to let work each add-on.
--------------------------------------------------------------------------------------------------
PicassoIV:

C:P4info
DEVS\Monitors\PicassoIV (It is created during OS4.1 installation)
DEVS\Monitors\PicassoIV.info (It is created during OS4.1 installation)
Prefs\PicassoModeTNG (optional)
Prefs\PicassoModeTNG.info (optional)
--------------------------------------------------------------------------------------------------
Concierto:

Note: Use the mini-jack connectors on the riser board.

DEVS\AHI\concierto.audio
DEVS\AudioMode\concierto
DEVS\MIDI\Concierto
DEVS\concierto.device
Documentation\Concierto\ConciertoMixer
Documentation\Concierto\ConciertoMixer.doc.info
Documentation\Concierto\ConciertoRecorder
Documentation\Concierto\ConciertoRecorder.doc.info
Libs\camd.library
Libs\concierto.library
Libs\gtlayout.library
Prefs\MidiPorts
Prefs\MidiPorts.info
Utilities\ConciertoMixer
Utilities\ConciertoMixer.info
Utilities\ConciertoRecorder
Utilities\ConciertoRecorder.info
--------------------------------------------------------------------------------------------------
Paloma:

Note: Uncomment the p4specials.library entry in the Kicklayout.

Libs\gtlayout.library
Libs\p4specials.library
Utilities\PalomaTV
Utilities\PalomaTV.info
--------------------------------------------------------------------------------------------------
Pablo:

C\AddPabloModes
Libs\gtlayout.library
Prefs\PabloII
Prefs\PabloII.info
--------------------------------------------------------------------------------------------------

If you still have any problem, please post the results of P4info. :mrgreen:
Amiga 4000: CSPPC 604e@180/060@50 / 146MB RAM / Mediator PCI 4000D
    Zorro: Picasso IV (Concierto/Paloma/Pablo) / Ariadne II / VLab Motion
    PCI: 3dfx VooDoo5 5500 64MB / Realtek 8029 / Terratec ESS Solo-1
User avatar
l3rd
Beta Tester
Beta Tester
 
Posts: 4
Joined: Sat Jun 18, 2011 9:22 am

Re: Installation instructions for Picasso IV Addons

Postby Calgor » Wed Aug 17, 2011 7:28 pm

Thanks l3rd, I will get back to you on this.
Amiga 4000T: CSPPC 604e@233/060@50 146MB RAM/CVPPC/Mediator/Radeon 256MB/Realtek 8029AS/TerraTec Solo1-N/Picasso IV (Paloma Pablo Concierto)/Deneb/ZorRAM 256MB/Indivision AGA MKII/OS4.xBETA/OS4.1u4/OS3.9BB2
AmigaONE X1000: Nemo 2.1 PA6T-1682M@1.8 2GB RAM/Radeon HD 4770 512MB/Catweasel MK4+/Audigy 2 ZS/Realtek 8139D/OS4.xBETA/OS4.1u5
User avatar
Calgor
Beta Tester
Beta Tester
 
Posts: 319
Joined: Mon Dec 20, 2010 5:42 pm

Re: Installation instructions for Picasso IV Addons

Postby Calgor » Thu Mar 29, 2012 3:25 pm

@ l3rd

I know it's been a long time.... I manually installed the drivers from the install scripts found on each disk, skipping each step where there was a newer version of the file already installed in OS4.1. This means that all of the files you have listed above are installed on the system. My PicassoIV has firmware v7.4.

Disks:
Picasso96 v1.40
Paloma v1.3 + p4specials.library v1.8
Concierto v1.9
PabloII v1.2

Results:
Concierto: Successful, but slow in AHI probably due to 68k drivers.

Paloma: PalomaTV detects channels and plays audio of TV but does not show any picture at all either in Full Screen mode or windowed on PicassoIV screenmodes 800x600x16 and 800x600x24 in a window on Workbench (ote that I think it requires 16bit PicassoIV screenmode to work in a workbench window as observed in OS3.9). Note that the display of the system starts behaving weird if changing screenmode while PalomaTV is open - graphics corruption on workbench. Something to do with overlay? It works in OS3.9.

PabloII: As I could not find a way to use AddPabloModes as per the install script for which it updates Picasso96 display mode database to make PicassoIV PabloII compatible screenmodes, it shows nothing using the Prefs/PabloII application on the SVideo output. AddPabloModes is to be run on the DEVS:Picasso96/PicassoIV and DEVS:Picasso96Settings files but these do not exist in OS4.1. An alternative would be to use Picasso96Settings to make new screenmodes yourself. How did you get it to work? It works in OS3.9.

Version of OS is AmigaOS4.1 Update 4.

P4Info output:
Hidden Text - Click to Show :
Opened PicassoIV.resource 7.4 at $3FF91474
p4res_boardcount 1
p4res_PALTiming $3FE6B1E0
p4res_NTSCTiming $3FE6B1F8
p4res_IntServer $3FFF8200
p4res_IntServer->is_Node.ln_Pri = 30
p4res_IntServer->is_Node.ln_Type = 2
p4res_IntServer->is_Node.ln_Name = "PicassoIV.resource"
p4res_IntServer->is_Data = $3FF91474
p4res_IntServer->is_Code = $3FE6D01C

Board # 1
p4bi_Flags $80000800
ZorroII Mode
Board contains CL-GD5446 Rev.A
connected to Color Monitor
Used by Gfx-System
p4bi_MemoryBase1 $200000
p4bi_MemoryBase2 $400000
p4bi_GPPortBase $EC0000
p4bi_RegisterBase $ED0000
p4bi_ConfigBase $EC0000
p4bi_MMIOBase $EC8000
p4bi_Modules $5F
is connected to Video-Slot (FlickerFixer active)
is connected to AA-Video-Slot (24 bit capable)
PabloII (Video-Out) is installed
Paloma (Video-In) is installed
PAL TV-Tuner is installed
Concierto (Audio) is installed
p4bi_BridgeRevision $4
p4bi_FlickerFixerRevision $7
p4bi_BankingSetting $7
p4bi_AudioSettings $1
p4bi_IntStatus $01
interrupt $3FFB7144
interrupt->is_Node.ln_Pri 100
interrupt->is_Node.ln_Type 2
interrupt->is_Node.ln_Name "VBInt PicassoIV.card (2)"
interrupt->is_Data $3FFB7100
interrupt->is_Code $0927DE30
interrupt $3FE56494
interrupt->is_Node.ln_Pri 0
interrupt->is_Node.ln_Type 2
interrupt->is_Node.ln_Name "p4specials.library"
interrupt->is_Data $3FE56494
interrupt->is_Code $09286484
interrupt $3DCBE004
interrupt->is_Node.ln_Pri 0
interrupt->is_Node.ln_Type 2
interrupt->is_Node.ln_Name "« Concierto I/O »"
interrupt->is_Data $3DCBE004
interrupt->is_Code $3FEBCA12
p4bi_PabloConfig $3FF8D4E0
pabloconfig->p4pc_Initialized 1
pabloconfig->p4pc_Enabled 0
pabloconfig->p4pc_VideoSignal 0
pabloconfig->p4pc_VideoMode 0
pabloconfig->p4pc_VideoStandard 3
pabloconfig->p4pc_OffsetX 0
pabloconfig->p4pc_OffsetY 0
pabloconfig->p4pc_FilterLines 0
pabloconfig->p4pc_DirectionX 1
pabloconfig->p4pc_DirectionY 1
pabloconfig->p4pc_RGBLoads 0


EDIT: The only thing I copied from the Picasso96 disk was the AudioSelect program and its docs.
Amiga 4000T: CSPPC 604e@233/060@50 146MB RAM/CVPPC/Mediator/Radeon 256MB/Realtek 8029AS/TerraTec Solo1-N/Picasso IV (Paloma Pablo Concierto)/Deneb/ZorRAM 256MB/Indivision AGA MKII/OS4.xBETA/OS4.1u4/OS3.9BB2
AmigaONE X1000: Nemo 2.1 PA6T-1682M@1.8 2GB RAM/Radeon HD 4770 512MB/Catweasel MK4+/Audigy 2 ZS/Realtek 8139D/OS4.xBETA/OS4.1u5
User avatar
Calgor
Beta Tester
Beta Tester
 
Posts: 319
Joined: Mon Dec 20, 2010 5:42 pm


Return to Platform: Classic

Who is online

Users browsing this forum: No registered users and 4 guests

cron