Why does AOS 4 go from unstable to stable?

A forum for general AmigaOS 4.x support questions that are not platform-specific

Why does AOS 4 go from unstable to stable?

Postby hotrod » Sat Oct 08, 2011 12:43 pm

Being a long time AOS 4.x user I've always wondered why AOS 4 are a bit unstable when you've done a fresh install but overtime it becomes stable as a rock?

I assume that adding libraries, mcc classes and so on will make a difference but it doesn't explain it all. Sure, some programs works with when you got the correct libraries installed, nothing strange about that but why does the whole system become more stable?

Also, recently scrolling in applications are suddenly faster! This wasn't true with any of the previous updates and not with update 3 either untill I turned it on yesterday. I turned it off for a while and turned it on again and scrolling is fast! It works great in DOpus 4, in MUI apps and so on, something that I've been complaining about and I have no idea why, not a clue.

Does AOS 4 have some self-repair system or are updates being sent out secretly? I just don't get it, I've never seen this behaviour in any other OS and it's the same thing every time an update of AOS 4 are released, people complain about bugs but suddenly some of them just wents away.

Any reasons for this? It is nice because I find myself always going from unhappy to happy but I don't know why? :-)
hotrod
 
Posts: 53
Joined: Tue Jun 21, 2011 11:17 pm

Re: Why does AOS 4 go from unstable to stable?

Postby tonyw » Mon Oct 10, 2011 12:40 am

We flatly deny that we are secretly issuing updates while you aren't watching.

There, that should start a good conspiracy thread...
cheers
tony
User avatar
tonyw
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 1385
Joined: Wed Mar 09, 2011 2:36 pm
Location: Sydney, Australia

Re: Why does AOS 4 go from unstable to stable?

Postby hotrod » Mon Oct 10, 2011 5:20 am

tonyw wrote:We flatly deny that we are secretly issuing updates while you aren't watching.

There, that should start a good conspiracy thread...


Haha, the question is weird I agree but I've always wondered why AOS 4.x for unknown reasons becomes more stable over time. It is usually the other way around if you look at other operating systems and the most clean install should also be the most stable?

I guess that there are no easy answer to this. The weirdest thing is that scrolling works in programs like DOpus 4, YAM, AmIRC, WookieChat whan it has been slow with update 1, 2 and also 3 untill recently. It is the same hardware and all I've done is change themes a couple of times and now I run the default theme again. The settings regarding compositing and VRAM usage has always been the same (performance) and I've done these exact things earlier. Only thing that is new is that I found the mui.key file and added it to the system. It's just weird.

Anyway, a faster and more stable OS is always good, just wondered if there where some kind of thoughts or opinions as to why this happens. If someone got a theory or knows I'll take that answer and if not I'm equally happy.
hotrod
 
Posts: 53
Joined: Tue Jun 21, 2011 11:17 pm

Re: Why does AOS 4 go from unstable to stable?

Postby kas1e » Mon Oct 10, 2011 8:15 am

@Hotrod
Should to say that i notice the same :) But i know the roots: When you install something fresh, you always need all those hard-reboots, you have some wrong apps on background, you have some old prefs of some old prefs which was updates and not works with old formats and so on and so on. So, for the first times when you install it you have some kind of mess, then, step by step you manage everything to works as it should, and then, you have stable stuff.

Its just can look like it "automatically" start to be better, but in real you just do all those hard-reboots, all the prefs overwrites as they need it, and non-necessary libs are removed or added after a while (and you just not count everything of course, just have feel that something wrong, but then start to be not).

And of course placebo too :)
kas1e
Beta Tester
Beta Tester
 
Posts: 481
Joined: Sat Jun 18, 2011 8:56 am

Re: Why does AOS 4 go from unstable to stable?

Postby Deniil » Mon Oct 10, 2011 2:08 pm

I have noticed the same thing.
Pretty much always after an update or install it crashes and freezes randomly a couple of times for some days, then it becomes stable. It's wierd.
Deniil
 
Posts: 108
Joined: Mon Jul 11, 2011 7:59 pm

Re: Why does AOS 4 go from unstable to stable?

Postby Spectre660 » Mon Oct 10, 2011 4:59 pm

I had this also with update 3.
4 Days of fiddling with different hard drive then blaming my graphics card,which is working perfectly now.
could it be that some prefs files could have been slightly mangled ?
not sure as I got things working with a damaged video card (fuzzy display but no crashes) but the new one would still not work until about a week later by which time I had reconnecting my rear case fan.
Also for the SAM models there is a new Uboot variable for activating the extra USB 1.1 header so thing like that could cause problems until the correct setting was done.


Deniil wrote:I have noticed the same thing.
Pretty much always after an update or install it crashes and freezes randomly a couple of times for some days, then it becomes stable. It's wierd.
Spectre660
 
Posts: 1489
Joined: Sat Jun 18, 2011 3:16 pm
Location: Montserrat

Re: Why does AOS 4 go from unstable to stable?

Postby hotrod » Mon Oct 10, 2011 6:57 pm

kas1e wrote:@Hotrod
Should to say that i notice the same :) But i know the roots: When you install something fresh, you always need all those hard-reboots, you have some wrong apps on background, you have some old prefs of some old prefs which was updates and not works with old formats and so on and so on. So, for the first times when you install it you have some kind of mess, then, step by step you manage everything to works as it should, and then, you have stable stuff.

Its just can look like it "automatically" start to be better, but in real you just do all those hard-reboots, all the prefs overwrites as they need it, and non-necessary libs are removed or added after a while (and you just not count everything of course, just have feel that something wrong, but then start to be not).

And of course placebo too :)


It is NOT placebo :-P . Regarding reboots, I turn my computer off for like a day and then turn it on. If I for example run MUI software that got all the MCC classes installed and I know what software I run and what files are required there is no reason for them to be unstable and then suddenly stable. I always use the same programs, like YAM for e-mail, SabreMSN, WookieChat or now AmIRC. AmigaAMP3 for music most of the times, DOPus 4 or Filer (or workbench, or shell) and for browsers, these days it's either MUIOWB or NetSurf.

With exception for AmIRC and MUIOWB I've been using the same programs for a long time, some differences ever since AOS 4 since several of them wasn't available. The same thing happens though, unstable for some weeks and suddenly no crashes or a lot less crashes.

And the weirdest thing that there are no explanation for what so ever is the scrolling. I don't know how big a change the "performance" option does in sys:prefs/gui but I've never noticed any difference. Sometimes when the option was new I forgot to switch it to performance but when I discovered it and change the setting everything felt the same. That is the only setting that I can think of that could make a difference but should it suddenly work now when it hasn't for years? Doesn't make any sense or my graphicscard are broken/weird and suddenly just works which doesn't make much sense either.

When I say scrolling I'm talking about text only in DOpus 4, WookieChat, YAM, AmIRC. I thought that it was a MUI issue first since scrolling was fine in any ReAction based application but then it was slower in DOpus 4 too. Now it is suddenly fast in those applications as well. It's like switching themes has suddenly activated some hidden feature... no I really don't know what's going on but it's nice to know that runing 1920x1080 @ 32-bit isn't that bad on the old machine after all :)
hotrod
 
Posts: 53
Joined: Tue Jun 21, 2011 11:17 pm

Re: Why does AOS 4 go from unstable to stable?

Postby hotrod » Mon Oct 10, 2011 7:11 pm

haha I've found the reason for the slow scrolling.... it was the mouse! OMG... I temporarily changed it I but didn't think about it. Who would've thought that it could make a difference? Well not me, not regarding that. Nice, a logical explanation to one of the issues that I've been having. With update 2 I didn't use that very mouse but graphics was slower overall.

I should stop using the peezee and use my A1 more to notice things like this. Never buy a cheap mouse I guess.
hotrod
 
Posts: 53
Joined: Tue Jun 21, 2011 11:17 pm

Re: Why does AOS 4 go from unstable to stable?

Postby hotrod » Tue Oct 11, 2011 9:28 pm

I'd like to add that scrolling was bad with update 2 even with the mouse that suddenly works. I bought a new mouse that I like a lot and there wasn't any difference between the two with update 2. Now however the older mouse works perfectly :) . Both are cheapish mice at the pricerange of 30 euro. I've used Logitech mice earlier and they have worked withouth any issues.

I hope that mouse support can be improved. I wonder why scrolling get slow, it isn't using any CPU time and moving windows around for example is fast and also scrolling in programs like Filer. It wasn't very obvious at all that the mouse was the issue.

This is a separate part from the original thread though but thought that it could maybe be helpfull information to someone unless it's been covered already.
hotrod
 
Posts: 53
Joined: Tue Jun 21, 2011 11:17 pm


Return to General AmigaOS

Who is online

Users browsing this forum: No registered users and 4 guests

cron