Updates do not work properly

A forum for general AmigaOS 4.x support questions that are not platform-specific

Re: Updates do not work properly

Postby Amiguy » Fri Jul 26, 2019 8:51 pm

Thank you very much Petrol and nbache for your help. After an amazing puzzle to return to normal operation, I can conclude the following facts.

According to the log file, I was able to connect to amiupdate.net at least once without problems with version 2.39 of 24/09/2015, which was never possible with version 2.45 of 20/05 / 2018. In addition, version 2.45 of the French catalog, from os4depot, is not valid.

No longer having the 2.41 file that Petrol is talking about, I'm happy with the English version, which works well. Nevertheless, I wonder what can explain that a change of version causes a connection error on amiupdate.net. Would it be a DNS problem? The IP of the site would have changed and an update would not have been made somewhere? Again, I'm happy for the moment of the connection with amiupdate.codebench.co.uk

In my opinion, there are certainly points of fragility to dig ...
Amiga Forever 7 Plus Edition which emulates AmigaOS4.1 FE Classic
AmigaOne X5000 2 GHz / 8 GB Ram - Radeon HD 7700 - AmigaOS4.1 FE
User avatar
Amiguy
 
Posts: 17
Joined: Mon May 15, 2017 9:01 pm

Re: Updates do not work properly

Postby Petrol » Fri Jul 26, 2019 9:47 pm

@Amiguy,

I can ensure you that the french catalog from Os4depot.net still works with AmiUpdate 2.45. I tested it again.
Be sure to copy the french catalogs on a fresh boot before launching AmiUpdate.

Image

Regards,
Petrol
User avatar
Petrol
Beta Tester
Beta Tester
 
Posts: 164
Joined: Mon Dec 20, 2010 7:19 pm
Location: France

Re: Updates do not work properly

Postby nbache » Fri Jul 26, 2019 10:06 pm

Amiguy wrote:Nevertheless, I wonder what can explain that a change of version causes a connection error on amiupdate.net.
It doesn't have anything to do with the client version change, it's just something that started to happen around the same time.

Would it be a DNS problem?
Yes. Just use the server amiupdate.codebench.co.uk, the other one was/is redirected (when that worked) to the same actual server.

Best regards,

Niels
User avatar
nbache
Beta Tester
Beta Tester
 
Posts: 1387
Joined: Mon Dec 20, 2010 8:25 pm
Location: Copenhagen, Denmark

Re: Updates do not work properly

Postby Rigo » Sat Jul 27, 2019 12:56 am

@minuous

Well, I don't know who you approached to have your apps removed, but I've heard nothing.

The administrative email addresses for AmiUpdate are well publised, so you have no problem contacting someone that can help you.

If you have a problem, then feel free to email me here.

AmiUpdate is off-topic here, but I will be happy to show you the door if you really want to de-camp.

Simon
User avatar
Rigo
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 339
Joined: Mon Jan 17, 2011 10:42 pm

Re: Updates do not work properly

Postby Amiguy » Sat Jul 27, 2019 8:49 am

@Petrol
You are right Petrol. Version 2.41 of the french catalog on os4depot (and not 2.45, as I indicated by mistake) works correctly. I went directly from version 2.39 to version 2.45 and probably did not have version 2.41 initially. There must have been confusion between catalogs at some point. Excuse me.

@nbache
I see in the log of version 2.39, that we check the versions of all resources from the sites that host it. Is this operation still in progress?
Amiga Forever 7 Plus Edition which emulates AmigaOS4.1 FE Classic
AmigaOne X5000 2 GHz / 8 GB Ram - Radeon HD 7700 - AmigaOS4.1 FE
User avatar
Amiguy
 
Posts: 17
Joined: Mon May 15, 2017 9:01 pm

Re: Updates do not work properly

Postby Minuous » Sat Jul 27, 2019 9:39 am

@Rigo:

Odd you didn't see it, I sent this email to the official mailing list at amiupdate@freelists.org last month:

Hello

Could you remove my apps from AmiUpdate please, they would be Africa,
AmiArcadia, CodeWar, Handy, MCE, Koules, Report+, Saga and Worm Wars. None of
them have supported AmiUpdate for years, they have their own updating
system. I don't (and can't) update their entries on the site anymore
in any case. No point listing obsolete versions of software.

Thanks

James Jacobs
Amigan Software
Minuous
 
Posts: 7
Joined: Mon Dec 21, 2015 11:36 am

Re: Updates do not work properly

Postby Raziel » Sat Jul 27, 2019 9:49 am

Minuous wrote:I don't (and can't) update their entries on the site anymore in any case.

Not that i want to be a pain, but why can't you update the entries anymore?
Maybe there's a bug on the site which will make it difficult for other users to update their entries in future too?
That would be nice to have fixed then...
If slaughterhouses had glass walls, everyone would be a vegetarian. ~ Sir Paul McCartney
-
Did everything just taste purple for a second? ~ Philip J. Fry
-
Ain't got no cash, ain't got no style, ladies vomit when I smile. ~ Dr. John Zoidberg
User avatar
Raziel
 
Posts: 924
Joined: Sat Jun 18, 2011 5:00 pm
Location: a story that hasn't been written yet

Re: Updates do not work properly

Postby Minuous » Sat Jul 27, 2019 10:10 am

@Raziel:

IIRC there used to be an "Edit" button which later disappeared. I reported the issue years ago, it was never investigated or fixed as apparently it is still OK for some users.

I just tried logging in and that didn't work either, maybe my account has already been removed. Although the apps are still listed.
Minuous
 
Posts: 7
Joined: Mon Dec 21, 2015 11:36 am

Re: Updates do not work properly

Postby nbache » Sat Jul 27, 2019 12:37 pm

Minuous wrote:@Raziel:

IIRC there used to be an "Edit" button which later disappeared.
Editing is done by displaying the entry, then typing your corrections into the relevant fields, and finally hitting Save.

Best regards,

Niels
User avatar
nbache
Beta Tester
Beta Tester
 
Posts: 1387
Joined: Mon Dec 20, 2010 8:25 pm
Location: Copenhagen, Denmark

Re: Updates do not work properly

Postby nbache » Sat Jul 27, 2019 12:47 pm

Amiguy wrote:@nbache
I see in the log of version 2.39, that we check the versions of all resources from the sites that host it. Is this operation still in progress?
Version 2.39 of what? AmiUpdate? Or the French catalogs? The releasenotes of AmiUpdate 2.39 say:

AmiUpdate 2.39 (24.9.2015)

- Fixed support for X5020 and X5040.
- Added support for upcoming platform(s).

I'm not sure exactly what you are asking, but perhaps Rigo (author of AmiUpdate) can answer your question.

I'm just a user and Danish translator.

Best regards,

Niels
User avatar
nbache
Beta Tester
Beta Tester
 
Posts: 1387
Joined: Mon Dec 20, 2010 8:25 pm
Location: Copenhagen, Denmark

PreviousNext

Return to General AmigaOS

Who is online

Users browsing this forum: No registered users and 4 guests

cron