CD/DVD icon bug (icon still present in WB)

A forum for general AmigaOS 4.x support questions that are not platform-specific

CD/DVD icon bug (icon still present in WB)

Postby samo79 » Sun Sep 06, 2015 11:24 pm

I wonder why sometimes the icon of an automounted CD/DVD still remained in Workbench even if you have already expelled it ...
I was searching for a file in a couple of DVD i have, so first i put a disk, then i remove it and i inserted another disk ... as a result both DVD remained visible ! ..

See grab: http://s10.postimg.org/tuxif9ecp/cd_tray_bug.jpg

I had a similar problem with AmigaOS 4.1 Update 4 (if i remember correctly) and at the time i reported it, then apparently it seems fixed ... now i have the same problem again ...
User avatar
samo79
 
Posts: 519
Joined: Sat Jun 18, 2011 12:13 am
Location: Italy

Re: CD/DVD icon bug (icon still present in WB)

Postby broadblues » Mon Sep 07, 2015 12:04 am

Usually it's because something has a lock on a file or directory on the CD, so that it can't be unmounted, it is not a bug.
User avatar
broadblues
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 538
Joined: Sat Jun 18, 2011 3:40 am
Location: Portsmouth, UK

Re: CD/DVD icon bug (icon still present in WB)

Postby samo79 » Mon Sep 07, 2015 7:58 am

Yep, probably the reason is about somethings locked in background, however technically speaking this is a bug for sure ... if something "bad" happen when you dismount a device the system should "forced" its closure automatically by removing its icon from the desktop .. at least this is the normal behaviour of any other operating system, so i don't know why AmigaOS should manage this differently ...
User avatar
samo79
 
Posts: 519
Joined: Sat Jun 18, 2011 12:13 am
Location: Italy

Re: CD/DVD icon bug (icon still present in WB)

Postby broadblues » Mon Sep 07, 2015 12:14 pm

Broken behaviour of other operating systems does not an AmigaOS bug make.

If something has a lock on the disk or a file / directory on it then unmounting it will not bode well for that app. This is exactly the same behaviout as you used to get to with floppies. It's certainly not a bug with the OS but may be caused by a bug in some other program not unlocking a file on exit.
User avatar
broadblues
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 538
Joined: Sat Jun 18, 2011 3:40 am
Location: Portsmouth, UK

Re: CD/DVD icon bug (icon still present in WB)

Postby chris » Mon Sep 07, 2015 1:37 pm

broadblues wrote:Broken behaviour of other operating systems does not an AmigaOS bug make.

If something has a lock on the disk or a file / directory on it then unmounting it will not bode well for that app. This is exactly the same behaviout as you used to get to with floppies.


IIRC if you try to eject a disk with an active lock on it, the OS throws up a big scary warning "You MUST replace volume XXXX in device DF0" (or maybe that's open files, rather than locks).

It's certainly not a bug with the OS but may be caused by a bug in some other program not unlocking a file on exit.


In particular, bitmap.image seems to keep locks on files. I think it's related to the internal caching, but I don't think it should be keeping a lock?
chris
 
Posts: 551
Joined: Sat Jun 18, 2011 12:05 pm


Return to General AmigaOS

Who is online

Users browsing this forum: No registered users and 2 guests