USB Stack Issue still unsolved...

A forum for general AmigaOS 4.x support questions that are not platform-specific

Re: USB Stack Issue still unsolved...

Postby xenic » Sun Jan 20, 2019 5:52 pm

broadblues wrote:This is not specific to the X5000. Try attaching a LED mouse (ie one with visible light not an infra red laser mouse). Then do a USBCtrl RESTART you will see the LED cycle on and off as it reset the USB busses.

Are you sure it's not the mouse circuitry turning the LED on/off for a reset? When I boot my X1000, the network adapter power light comes on and stays on untill I turn the computer off. The adapter also has an LED indicating when the adapter is connected to my router. The adapter connects to the router shortly after the system is turned on (connection LED comes on) and stays connected even during reboots.

When I boot my X5000, the adapter power light comes on but cycles through several on/off states until the system is completely booted. The adapter power light also goes off and back on during a warm (AmigaOS) reboot.

I also have a USB powered cellphone charging stand that has a power LED. When I tested both of my NG Amigas by connecting the charging stand to a USB port, the results were the same as with the network adapter: With the X1000 the USB power comes on and stays on when the computer is turned on and with the X5000 the USB power cycles on/off until the system is completely booted.
AmigaOne X1000 with 2GB memory - OS4.1 FE
xenic
 
Posts: 1160
Joined: Sun Jun 19, 2011 1:06 am

Re: USB Stack Issue still unsolved...

Postby Roland » Sun Jan 20, 2019 10:36 pm

USB is also in my X5000 the most common source of problems...

1)
I have a HDMI-->VGA adapter (Deltaco), which needs USB power to work. When I turn on my machine with the USB power cable connected to any of X5000's USB ports, the adapter gives signal to the diplay only after booting has reached the OS4.1 Prerelease screen. Thus, I cannot reach the U-boot menus to switch e.g. to Linux.

If I then soft reboot or a reset the X5000 the adapter works immediately, and I can reach U-boot, too. But if I use some external USB power source for the adapter (e.g. the USB port of an old portable), the adapter works always immediately.

2)
When I turn on my X5000, all the USB drives (sticks) connected are (usually) all mounted. When I then do a soft reboot, they have all dissappeared (not visible for WB or AmigaDos). Unplugging and replugging them do not make then appear, they stay unmounted. But when I soft reboot again, they reappear... And so on. Very annoying :-/.
- Roland -
Roland
 
Posts: 299
Joined: Tue May 02, 2017 8:23 am

Re: USB Stack Issue still unsolved...

Postby broadblues » Mon Jan 21, 2019 1:37 am

@Roland

If a USB stick does not mount when inserted bring up the massstorage GUI and see if it is listed. Then you can mount it from there.

No idea why themount status might toggle between soft reboots though.

@Xenic

Yes I suppose it is possible that it's internal circuitry in the mouse triggering the LED on and off.

If you do a USBCtrl RESTART do you see the power on and off on the X5000 that you describe?
User avatar
broadblues
AmigaOS Core Developer
AmigaOS Core Developer
 
Posts: 590
Joined: Sat Jun 18, 2011 3:40 am
Location: Portsmouth, UK

Re: USB Stack Issue still unsolved...

Postby xenic » Mon Jan 21, 2019 3:33 am

broadblues wrote:Yes I suppose it is possible that it's internal circuitry in the mouse triggering the LED on and off.

If you do a USBCtrl RESTART do you see the power on and off on the X5000 that you describe?

I got my X5000 out of the closet and connected it temporarily. When I execute "USBCtrl Reset" the power goes off and back on much quicker than it does during an initial boot, reset or warm reboot. However, my network adapter loses it's connection to the router just like it does during boot or reboot. I normally avoid the network adapter problem by connecting the network adapter power to a an external USB port adapter that is connected directly to the 5V supply from the X5000 power supply. I hope that's all the testing I need to do because the X5000 is back in the closet awaiting a long overdue system software update.
AmigaOne X1000 with 2GB memory - OS4.1 FE
xenic
 
Posts: 1160
Joined: Sun Jun 19, 2011 1:06 am

Re: USB Stack Issue still unsolved...

Postby Roland » Mon Jan 21, 2019 10:43 am

broadblues wrote: If a USB stick does not mount when inserted bring up the massstorage GUI and see if it is listed. Then you can mount it from there.


You mean 'Mounter'...? Yes, it was able to see the stick and I was able mount the missing partition(s). Thanks!

No idea why themount status might toggle between soft reboots though.


And it indeed seems to be only soft reboot, as after 'resets' all the partitions are usually visible.

BTW, while playing with the Mounter, I also got a Grim Reaper from my keyboard. This happens every now and then but very irregularly...
I have not been able to relate it directly to any other activity, but it seems to appear more often now when I use the HDMI-VGA adapter.
- Roland -
Roland
 
Posts: 299
Joined: Tue May 02, 2017 8:23 am

Re: USB Stack Issue still unsolved...

Postby nbache » Mon Jan 21, 2019 11:33 am

Roland wrote:
broadblues wrote: If a USB stick does not mount when inserted bring up the massstorage GUI and see if it is listed. Then you can mount it from there.


You mean 'Mounter'...?
No, the massstorage GUI is a commodity (I think) created on the fly by the massstorage USB software. You bring it up by pressing Ctrl Alt M.

Best regards,

Niels
User avatar
nbache
Beta Tester
Beta Tester
 
Posts: 1382
Joined: Mon Dec 20, 2010 8:25 pm
Location: Copenhagen, Denmark

Re: USB Stack Issue still unsolved...

Postby Roland » Mon Jan 21, 2019 12:28 pm

nbache wrote:No, the massstorage GUI is a commodity (I think) created on the fly by the massstorage USB software. You bring it up by pressing Ctrl Alt M.

Never heard before...! But no wonder: it does not have an icon in the 'Commodities' drawer, and there is no info about it in 'Documentation/Commodities'. A hidden feature of OS 4.1...
- Roland -
Roland
 
Posts: 299
Joined: Tue May 02, 2017 8:23 am

Re: USB Stack Issue still unsolved...

Postby xenic » Mon Jan 21, 2019 4:29 pm

Roland wrote:Never heard before...! But no wonder: it does not have an icon in the 'Commodities' drawer, and there is no info about it in 'Documentation/Commodities'. A hidden feature of OS 4.1...

There is limited info about massstorage in 'Documentation/usb/usb_massstorage_readme'. If you have problems remembering all the system keyboard shortcuts like me, you can also open the MassStorage window by opening the Exchange commodity window, selecting MassStorage in the left lister and pressing the 'Show interface' button on the right.
AmigaOne X1000 with 2GB memory - OS4.1 FE
xenic
 
Posts: 1160
Joined: Sun Jun 19, 2011 1:06 am

Re: USB Stack Issue still unsolved...

Postby nbache » Tue Jan 22, 2019 12:25 am

The reason there is no icon for it is that there is no separate diskbased module for it. Its code is part of the massstorage usb driver, and it is started automatically by that driver.

And yes, like with so many other things, more info can be found in the Documentation drawer.

But I agree, it is a bit "hidden" to the average user, something which might be nice to change. Maybe it could be possible to have a script or something to open it, which could be callable from e.g. the Tools menu or from AmiDock (or any other dock)?

Best regards,

Niels
User avatar
nbache
Beta Tester
Beta Tester
 
Posts: 1382
Joined: Mon Dec 20, 2010 8:25 pm
Location: Copenhagen, Denmark

Re: USB Stack Issue still unsolved...

Postby samo79 » Sat Jan 26, 2019 12:24 am

At boot I often have problem using all 4 USB ports in my Sam440 ... no problem having plugged mouse and keyboard in rear ports, and also no problem if i plug an USB pen stick in the first front port .... howewer as soon as i plug my fourth device (a Samsung Android device) i got serious problem at boot ...
The system boot normally, but as soon as it finished to load the mouse pointer still in busy state, the Workbench's wallpaper will not be loaded aswell as the Workbench icon ... to unlock these i need to manually remove atleast one of the front device

I checked with LogViewer (and the USB log) and i can see that errors:

Code: Select all
I: [23:11:15]                      USB stack |                                | ==========
I: [23:11:15]                      USB stack |                                | USB System Software Task started
I: [23:11:15]                      USB stack |                                | Starting HCDs...
I: [23:11:15]                      USB stack |                        New Fkt | Fkt 0x5FF9ED20 at level -1
I: [23:11:15]                      USB stack |                        New Fkt | Fkt 0x5FF9EDC0 at level 0
I: [23:11:16]                      USB stack |                        New Fkt | Fkt 0x5FF9EE60 at level -1
I: [23:11:16]                      USB stack |                        New Fkt | Fkt 0x5FF9EF00 at level 0
I: [23:11:16]                      USB stack |                        New Fkt | Fkt 0x5FD93010 at level -1
I: [23:11:16]                      USB stack |                        New Fkt | Fkt 0x5FD930B0 at level 0
I: [23:11:16]                      USB stack |                                | ...HCDs started.
I: [23:11:16]                   USB Fkt Init |                       Init Fkt | Fkt 0x5FF9EDC0 is {Vendor: 0x0000, Product: 0x0000, Class: 09.00}
I: [23:11:16]                   USB Fkt Init |                       Init Fkt | Fkt 0x5FF9EF00 is {Vendor: 0x0000, Product: 0x0000, Class: 09.00}
I: [23:11:16]                   USB Fkt Init |                       Init Fkt | Fkt 0x5FD930B0 is {Vendor: 0x0000, Product: 0x0000, Class: 09.00}
I: [23:11:16]                   USB Fkt Init |                       Init Fkt | Fkt 0x5FF9EDC0 initialized
I: [23:11:16]                   USB Fkt Init |                       Init Fkt | Fkt 0x5FF9EF00 initialized
I: [23:11:16]                   USB Fkt Init |                       Init Fkt | Fkt 0x5FD930B0 initialized
I: [23:11:16]                      hub.usbfd |                            HUB | Hub "Rear Roothub (ohci.usbhcd/0)" has TT thinktime of 8 full speed bittimes and protocol 0
I: [23:11:16]                      hub.usbfd |                            HUB | Hub "Front Roothub (ohci.usbhcd/1)" has TT thinktime of 8 full speed bittimes and protocol 0
I: [23:11:16]                      hub.usbfd |                            HUB | Hub "Rear Roothub (ehci.usbhcd/0)" has TT thinktime of 8 full speed bittimes and protocol 0
I: [23:11:16]                      hub.usbfd |                            HUB | All ports are empty
I: [23:11:16]                      hub.usbfd |                            HUB | All ports are empty
I: [23:11:16]    EHCI Controller Task Unit 0 |                           EHCI | Device at port 0 is a lowspeed device. Giving up ownership.
I: [23:11:16]    EHCI Controller Task Unit 0 |                           EHCI | Device at port 1 is a lowspeed device. Giving up ownership.
I: [23:11:16]                      hub.usbfd |                            HUB | Device found on port 1 of hub "Rear Roothub (ohci.usbhcd/0)".
I: [23:11:16]                      hub.usbfd |                       Hub port | Device at port 1 of hub "Rear Roothub (ohci.usbhcd/0)" is low-speed.
I: [23:11:16]                      USB stack |                        New Fkt | Fkt 0x5FD93330 at level 1
I: [23:11:16]                      hub.usbfd |                            HUB | Device on hub port 1 successfully added.
I: [23:11:16]                   USB Fkt Init |                       Init Fkt | Fkt 0x5FD93330 is {Vendor: 0x046D, Product: 0xC018, Class: 00.00}
I: [23:11:16]                   USB Fkt Init |                       Init Fkt | Fkt 0x5FD93330 initialized
I: [23:11:16]                      hub.usbfd |                            HUB | Device found on port 1 of hub "Front Roothub (ohci.usbhcd/1)".
I: [23:11:16]                      hub.usbfd |                            HUB | Device found on port 4 of hub "Rear Roothub (ehci.usbhcd/0)".
I: [23:11:16]                      hub.usbfd |                       Hub port | Device at port 1 of hub "Front Roothub (ohci.usbhcd/1)" is low-speed.
I: [23:11:16]                      USB stack |                        New Fkt | Fkt 0x5FD933D0 at level 1
I: [23:11:16]                      hub.usbfd |                            HUB | Device on hub port 1 successfully added.
I: [23:11:16]                   USB Fkt Init |                       Init Fkt | Fkt 0x5FD933D0 is {Vendor: 0x046D, Product: 0xC312, Class: 00.00}
I: [23:11:16]                   USB Fkt Init |                       Init Fkt | Fkt 0x5FD933D0 initialized
W: [23:11:16]               USB FD fkt start |            BindInterfaceDriver | No interface driver of fkt 0x5FD933D0/ifc 0x5FF1FE10 {Class 03.00} has been found
I: [23:11:16]                      hub.usbfd |                       Hub port | Device at port 4 of hub "Rear Roothub (ehci.usbhcd/0)" is high-speed.
I: [23:11:16]                      USB stack |                        New Fkt | Fkt 0x5FD93470 at level 1
I: [23:11:16]                      hub.usbfd |                            HUB | Device on hub port 4 successfully added.
I: [23:11:16]    EHCI Controller Task Unit 0 |                           EHCI | Port 3 is not in reset state.
I: [23:11:16]                      hub.usbfd |                            HUB | Driver Running
I: [23:11:16]                   USB Fkt Init |                       Init Fkt | Fkt 0x5FD93470 is {Vendor: 0x058F, Product: 0x6387, Class: 00.00}
I: [23:11:16]                   USB Fkt Init |                       Init Fkt | Fkt 0x5FD93470 initialized
W: [23:11:17]        MassStorage Device Task |               Massstorage Init | Switched to 64 sector mode
I: [23:11:17]        MassStorage Device Task |                    Massstorage | Lun 0 has device type 0x00 (Direct access) and is removable
W: [23:11:17]        MassStorage Device Task |                    Massstorage | Created usbdisk.device/0
I: [23:11:18]                   Mounter Task |  Sys_EndInitialAttachmentPhase | Initial USB Attachment Phase terminated
I: [23:11:22]                      hub.usbfd |                            HUB | Device found on port 3 of hub "Rear Roothub (ehci.usbhcd/0)".
I: [23:11:23]                      hub.usbfd |                       Hub port | Device at port 3 of hub "Rear Roothub (ehci.usbhcd/0)" is high-speed.
I: [23:11:23]                      USB stack |                        New Fkt | Fkt 0x58a840d0 at level 1
I: [23:11:23]                      hub.usbfd |                            HUB | Device on hub port 3 successfully added.
I: [23:11:23]    EHCI Controller Task Unit 0 |                           EHCI | Port 2 is not in reset state.
I: [23:11:23]                   USB Fkt Init |                       Init Fkt | Fkt 0x58a840d0 is {Vendor: 0x04E8, Product: 0x6860, Class: 00.00}
I: [23:11:23]                   USB Fkt Init |                       Init Fkt | Fkt 0x58a840d0 initialized
W: [23:11:23]               USB FD fkt start |            BindInterfaceDriver | No interface driver of fkt 0x58a840d0/ifc 0x589ca040 {Class 10.00} has been found
W: [23:11:23]               USB FD ifc start |            BindInterfaceDriver | No interface driver of fkt 0x58a840d0/ifc 0x5896bed0 {Class 06.01} has been found
W: [23:11:23]               USB FD ifc start |            BindInterfaceDriver | No interface driver of fkt 0x58a840d0/ifc 0x58cf7810 {Class 02.02} has been found
I: [23:11:23]              USB stack Process |                                | USB System Software Process started.
I: [23:11:23]              USB stack Process |                                | Reading FD descriptors...
I: [23:11:23]              USB stack Process |                                | ...FD infos read
I: [23:11:23]              USB stack Process |                      Rebind FD | Weak FD "bootkeyboard.usbfd" for Ifc 0x5FF1FD90 is being preempted.
W: [23:11:23]               USB FD fkt start |            BindInterfaceDriver | No interface driver of fkt 0x58a840d0/ifc 0x589ca040 {Class 10.00} has been found
W: [23:11:23]               USB FD ifc start |            BindInterfaceDriver | No interface driver of fkt 0x58a840d0/ifc 0x58cf7810 {Class 02.02} has been found
I: [23:11:23]              USB stack Process |                      Rebind FD | Weak FD "bootmouse.usbfd" for Ifc 0x5FF1FA90 is being preempted.
I: [23:11:23]              USB stack Process |                                | Starting HCDs...
I: [23:11:23]              USB stack Process |                                | ...HCDs started.
I: [23:11:23]              USB stack Process |                                | USB stack fullbooted
I: [23:11:24]                      hid.usbfd |                     HID driver | USB Interface bound
I: [23:11:24]                      hid.usbfd |                     HID driver | USB Interface bound
I: [23:11:24]                      hid.usbfd |                     HID driver | USB Interface bound
E: [23:11:24]                   HID Keyboard |                   HID Keyboard | Undefined raw key: usage=0x00070000
E: [23:11:24]                   HID Keyboard |                   HID Keyboard | Undefined raw key: usage=0x00070000
E: [23:11:24]                   HID Keyboard |                   HID Keyboard | Undefined raw key: usage=0x00070000
E: [23:11:24]                   HID Keyboard |                   HID Keyboard | Undefined raw key: usage=0x00070000
E: [23:11:24]                   HID Keyboard |                   HID Keyboard | Undefined raw key: usage=0x00070000
E: [23:11:24]                   HID Keyboard |                   HID Keyboard | Undefined raw key: usage=0x00070000
I: [23:11:24]               USB FD ifc start |  Sys_EndInitialAttachmentPhase | Initial USB Attachment Phase terminated
E: [23:11:31]        MassStorage Device Task |                    Massstorage | Reading 64 blocks starting from block 262416 failed with USB error -33 and sense key NO SENSE (0)
E: [23:11:31]        MassStorage Device Task |                    Massstorage | Reading 64 blocks starting from block 262416 failed with USB error -33 and sense key NO SENSE (0)
E: [23:11:31]        MassStorage Device Task |                    Massstorage | Reading 64 blocks starting from block 262416 failed with USB error -33 and sense key NO SENSE (0)
E: [23:11:31]        MassStorage Device Task |                    Massstorage | Reading 64 blocks starting from block 262416 failed with USB error -33 and sense key NO SENSE (0)
E: [23:11:31]        MassStorage Device Task |                    Massstorage | Reading 64 blocks starting from block 262416 failed with USB error -33 and sense key NO SENSE (0)
E: [23:11:31]        MassStorage Device Task |                    Massstorage | Reading 64 blocks starting from block 262416 failed with USB error -33 and sense key NO SENSE (0)
E: [23:11:31]        MassStorage Device Task |                    Massstorage | Reading 64 blocks starting from block 262416 failed with USB error -33 and sense key NO SENSE (0)
E: [23:11:31]        MassStorage Device Task |                    Massstorage | Reading 64 blocks starting from block 262416 failed with USB error -33 and sense key NO SENSE (0)
E: [23:11:31]        MassStorage Device Task |                    Massstorage | Reading 64 blocks starting from block 262416 failed with USB error -33 and sense key NO SENSE (0)
E: [23:11:31]        MassStorage Device Task |                    Massstorage | Reading 64 blocks starting from block 262416 failed with USB error -33 and sense key NO SENSE (0)
E: [23:11:31]        MassStorage Device Task |                    Massstorage | Reading 64 blocks starting from block 262416 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:31]        MassStorage Device Task |                    Massstorage | Reading 64 blocks starting from block 262416 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:31]        MassStorage Device Task |                    Massstorage | Reading 64 blocks starting from block 262416 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:31]        MassStorage Device Task |                    Massstorage | Reading 64 blocks starting from block 262416 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:31]        MassStorage Device Task |                    Massstorage | Reading 64 blocks starting from block 262416 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:31]        MassStorage Device Task |                    Massstorage | Reading 64 blocks starting from block 262416 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:31]        MassStorage Device Task |                    Massstorage | Reading 64 blocks starting from block 262416 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:31]        MassStorage Device Task |                    Massstorage | Reading 64 blocks starting from block 262416 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:31]        MassStorage Device Task |                    Massstorage | Reading 64 blocks starting from block 262416 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:31]        MassStorage Device Task |                    Massstorage | Reading 64 blocks starting from block 262416 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:31]        MassStorage Device Task |                    Massstorage | Reading 64 blocks starting from block 262416 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:31]        MassStorage Device Task |                    Massstorage | Reading 64 blocks starting from block 262416 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:31]        MassStorage Device Task |                    Massstorage | Reading 64 blocks starting from block 262416 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:31]        MassStorage Device Task |                    Massstorage | Reading 64 blocks starting from block 262416 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:31]        MassStorage Device Task |                    Massstorage | Reading 64 blocks starting from block 262416 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:31]        MassStorage Device Task |                    Massstorage | Reading 64 blocks starting from block 262416 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:31]        MassStorage Device Task |                    Massstorage | Reading 64 blocks starting from block 262416 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:31]        MassStorage Device Task |                    Massstorage | Reading 64 blocks starting from block 262416 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:31]        MassStorage Device Task |                    Massstorage | Reading 64 blocks starting from block 262416 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:31]        MassStorage Device Task |                    Massstorage | Reading 64 blocks starting from block 262416 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:31]        MassStorage Device Task |                    Massstorage | Reading 64 blocks starting from block 262416 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:31]        MassStorage Device Task |                    Massstorage | Reading 64 blocks starting from block 262416 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:31]        MassStorage Device Task |                    Massstorage | Reading 64 blocks starting from block 262416 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:31]        MassStorage Device Task |                    Massstorage | Reading 64 blocks starting from block 262416 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:31]        MassStorage Device Task |                    Massstorage | Reading 64 blocks starting from block 262416 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:31]        MassStorage Device Task |                    Massstorage | Reading 64 blocks starting from block 262416 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:31]        MassStorage Device Task |                    Massstorage | Reading 64 blocks starting from block 262416 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:31]        MassStorage Device Task |                    Massstorage | Reading 64 blocks starting from block 262416 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:31]        MassStorage Device Task |                    Massstorage | Reading 64 blocks starting from block 262416 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:31]        MassStorage Device Task |                    Massstorage | Reading 64 blocks starting from block 262416 failed with USB error -33 and sense key MISCOMPARE (14)
I: [23:11:31]                      hub.usbfd |                            HUB | Detaching Function removed from hub port 4
I: [23:11:34]                      hub.usbfd |                            HUB | Device found on port 4 of hub "Rear Roothub (ehci.usbhcd/0)".
I: [23:11:34]                      hub.usbfd |                       Hub port | Device at port 4 of hub "Rear Roothub (ehci.usbhcd/0)" is high-speed.
I: [23:11:34]                      USB stack |                        New Fkt | Fkt 0x57f7d640 at level 1
I: [23:11:34]                      hub.usbfd |                            HUB | Device on hub port 4 successfully added.
I: [23:11:34]    EHCI Controller Task Unit 0 |                           EHCI | Port 3 is not in reset state.
I: [23:11:35]                   USB Fkt Init |                       Init Fkt | Fkt 0x57f7d640 is {Vendor: 0x058F, Product: 0x6387, Class: 00.00}
I: [23:11:35]                   USB Fkt Init |                       Init Fkt | Fkt 0x57f7d640 initialized
W: [23:11:35]        MassStorage Device Task |               Massstorage Init | Switched to 64 sector mode
I: [23:11:35]        MassStorage Device Task |                    Massstorage | Lun 0 has device type 0x00 (Direct access) and is removable
W: [23:11:35]        MassStorage Device Task |                    Massstorage | Created usbdisk.device/1
E: [23:11:45]        MassStorage Device Task |                    Massstorage | Reading 48 blocks starting from block 15904 failed with USB error -33 and sense key NO SENSE (0)
E: [23:11:45]        MassStorage Device Task |                    Massstorage | Reading 48 blocks starting from block 15904 failed with USB error -33 and sense key NO SENSE (0)
E: [23:11:45]        MassStorage Device Task |                    Massstorage | Reading 48 blocks starting from block 15904 failed with USB error -33 and sense key NO SENSE (0)
E: [23:11:45]        MassStorage Device Task |                    Massstorage | Reading 48 blocks starting from block 15904 failed with USB error -33 and sense key NO SENSE (0)
E: [23:11:45]        MassStorage Device Task |                    Massstorage | Reading 48 blocks starting from block 15904 failed with USB error -33 and sense key NO SENSE (0)
E: [23:11:45]        MassStorage Device Task |                    Massstorage | Reading 48 blocks starting from block 15904 failed with USB error -33 and sense key NO SENSE (0)
E: [23:11:45]        MassStorage Device Task |                    Massstorage | Reading 48 blocks starting from block 15904 failed with USB error -33 and sense key NO SENSE (0)
E: [23:11:45]        MassStorage Device Task |                    Massstorage | Reading 48 blocks starting from block 15904 failed with USB error -33 and sense key NO SENSE (0)
E: [23:11:45]        MassStorage Device Task |                    Massstorage | Reading 48 blocks starting from block 15904 failed with USB error -33 and sense key NO SENSE (0)
E: [23:11:45]        MassStorage Device Task |                    Massstorage | Reading 48 blocks starting from block 15904 failed with USB error -33 and sense key NO SENSE (0)
E: [23:11:46]        MassStorage Device Task |                    Massstorage | Reading 48 blocks starting from block 15904 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:46]        MassStorage Device Task |                    Massstorage | Reading 48 blocks starting from block 15904 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:46]        MassStorage Device Task |                    Massstorage | Reading 48 blocks starting from block 15904 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:46]        MassStorage Device Task |                    Massstorage | Reading 48 blocks starting from block 15904 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:46]        MassStorage Device Task |                    Massstorage | Reading 48 blocks starting from block 15904 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:46]        MassStorage Device Task |                    Massstorage | Reading 48 blocks starting from block 15904 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:46]        MassStorage Device Task |                    Massstorage | Reading 48 blocks starting from block 15904 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:46]        MassStorage Device Task |                    Massstorage | Reading 48 blocks starting from block 15904 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:46]        MassStorage Device Task |                    Massstorage | Reading 48 blocks starting from block 15904 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:46]        MassStorage Device Task |                    Massstorage | Reading 48 blocks starting from block 15904 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:46]        MassStorage Device Task |                    Massstorage | Reading 48 blocks starting from block 15904 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:46]        MassStorage Device Task |                    Massstorage | Reading 48 blocks starting from block 15904 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:46]        MassStorage Device Task |                    Massstorage | Reading 48 blocks starting from block 15904 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:46]        MassStorage Device Task |                    Massstorage | Reading 48 blocks starting from block 15904 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:46]        MassStorage Device Task |                    Massstorage | Reading 48 blocks starting from block 15904 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:46]        MassStorage Device Task |                    Massstorage | Reading 48 blocks starting from block 15904 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:46]        MassStorage Device Task |                    Massstorage | Reading 48 blocks starting from block 15904 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:46]        MassStorage Device Task |                    Massstorage | Reading 48 blocks starting from block 15904 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:46]        MassStorage Device Task |                    Massstorage | Reading 48 blocks starting from block 15904 failed with USB error -33 and sense key MISCOMPARE (14)
E: [23:11:46]        MassStorage Device Task |                    Massstorage | Reading 48 blocks starting from block 15904 failed with USB error -33 and sense key MISCOMPARE (14)
I: [23:11:46]                      hub.usbfd |                            HUB | Detaching Function removed from hub port 4
I: [23:11:47]                      hub.usbfd |                            HUB | Device found on port 4 of hub "Rear Roothub (ehci.usbhcd/0)".
I: [23:11:47]                      hub.usbfd |                       Hub port | Device at port 4 of hub "Rear Roothub (ehci.usbhcd/0)" is high-speed.
I: [23:11:47]                      USB stack |                        New Fkt | Fkt 0x57f7d780 at level 1
I: [23:11:47]                      hub.usbfd |                            HUB | Device on hub port 4 successfully added.
I: [23:11:47]    EHCI Controller Task Unit 0 |                           EHCI | Port 3 is not in reset state.
I: [23:11:47]                   USB Fkt Init |                       Init Fkt | Fkt 0x57f7d780 is {Vendor: 0x058F, Product: 0x6387, Class: 00.00}
I: [23:11:47]                   USB Fkt Init |                       Init Fkt | Fkt 0x57f7d780 initialized
W: [23:11:48]        MassStorage Device Task |               Massstorage Init | Switched to 64 sector mode
I: [23:11:48]        MassStorage Device Task |                    Massstorage | Lun 0 has device type 0x00 (Direct access) and is removable
W: [23:11:48]        MassStorage Device Task |                    Massstorage | Created usbdisk.device/2
E: [23:11:54]                      ptp.usbfd |                     DevAbortIO | Bad EndPoint ptr in IO req (0x00000000)
E: [23:12:07]        MassStorage Device Task |                    Massstorage | Reading 48 blocks starting from block 15904 failed with USB error -33 and sense key NO SENSE (0)
E: [23:12:07]        MassStorage Device Task |                    Massstorage | Reading 48 blocks starting from block 15904 failed with USB error -33 and sense key NO SENSE (0)
E: [23:12:07]        MassStorage Device Task |                    Massstorage | Reading 48 blocks starting from block 15904 failed with USB error -33 and sense key NO SENSE (0)
E: [23:12:07]        MassStorage Device Task |                    Massstorage | Reading 48 blocks starting from block 15904 failed with USB error -33 and sense key NO SENSE (0)
E: [23:12:07]        MassStorage Device Task |                    Massstorage | Reading 48 blocks starting from block 15904 failed with USB error -33 and sense key NO SENSE (0)
E: [23:12:07]        MassStorage Device Task |                    Massstorage | Reading 48 blocks starting from block 15904 failed with USB error -33 and sense key NO SENSE (0)
E: [23:12:07]        MassStorage Device Task |                    Massstorage | Reading 48 blocks starting from block 15904 failed with USB error -33 and sense key NO SENSE (0)
E: [23:12:07]        MassStorage Device Task |                    Massstorage | Reading 48 blocks starting from block 15904 failed with USB error -33 and sense key NO SENSE (0)
E: [23:12:07]        MassStorage Device Task |                    Massstorage | Reading 48 blocks starting from block 15904 failed with USB error -33 and sense key NO SENSE (0)
E: [23:12:07]        MassStorage Device Task |                    Massstorage | Reading 48 blocks starting from block 15904 failed with USB error -33 and sense key NO SENSE (0)
I: [23:12:07]                      hub.usbfd |                            HUB | Detaching Function removed from hub port 4
I: [23:12:17]                      hub.usbfd |                            HUB | Device found on port 4 of hub "Rear Roothub (ehci.usbhcd/0)".
I: [23:12:17]                      hub.usbfd |                       Hub port | Device at port 4 of hub "Rear Roothub (ehci.usbhcd/0)" is high-speed.
I: [23:12:17]                      USB stack |                        New Fkt | Fkt 0x57f7d780 at level 1
I: [23:12:17]                      hub.usbfd |                            HUB | Device on hub port 4 successfully added.
I: [23:12:17]    EHCI Controller Task Unit 0 |                           EHCI | Port 3 is not in reset state.
I: [23:12:17]                   USB Fkt Init |                       Init Fkt | Fkt 0x57f7d780 is {Vendor: 0x058F, Product: 0x6387, Class: 00.00}
I: [23:12:17]                   USB Fkt Init |                       Init Fkt | Fkt 0x57f7d780 initialized
User avatar
samo79
 
Posts: 540
Joined: Sat Jun 18, 2011 12:13 am
Location: Italy

PreviousNext

Return to General AmigaOS

Who is online

Users browsing this forum: No registered users and 3 guests

cron