BUG: notepad's non-working "save" after few redo/undo.

A forum for general AmigaOS 4.x support questions that are not platform-specific

BUG: notepad's non-working "save" after few redo/undo.

Postby kas1e » Wed Dec 05, 2018 9:49 pm

Just to start with, i do test with latest beta of notepad 53.17 , but want to bring that report there , so users with latest public version of notepad can confirm if there is such behaviour or not.

So, steps to reproduce:

1). reboot
2). run shell, go to RAM: , type "notepad aa.txt"
3). write there "123456789" , save, exit
4). run notepad aa.txt
5). select by mouse that "123456789" line, and press "backspace" , so line will be deleted.

6). now , press "undo", then press "save".
7). now, press "redo", then press "save".

Repeat 6,7 step 2,3,4 up 10 times.

Some time "save" will be ghosted after 3 repeats, sometime after more of them. Probably related to the "pause" between pressing. And when save will be ghoste, not more redos, not more undos, will not make it be working again. Even if you will type anything , save will be not working. And not only button, but also entry in RMB menu for "save" will be ghosted too. "Save As" will works through.

Is it the same on latest public version, and is it reproducable for everyone ?
kas1e
Beta Tester
Beta Tester
 
Posts: 469
Joined: Sat Jun 18, 2011 8:56 am

Re: BUG: notepad's non-working "save" after few redo/undo.

Postby Raziel » Wed Dec 05, 2018 10:22 pm

NotePad 53.16 (19.05.2016)

I cannot confirm this.

Works as expected.
"Save" is available when the data has changed, and ghosted when everything is at par after the load state.
If slaughterhouses had glass walls, everyone would be a vegetarian. ~ Sir Paul McCartney
-
Did everything just taste purple for a second? ~ Philip J. Fry
-
Ain't got no cash, ain't got no style, ladies vomit when I smile. ~ Dr. John Zoidberg
User avatar
Raziel
 
Posts: 864
Joined: Sat Jun 18, 2011 5:00 pm
Location: A haunted Castle somewhere in the Bavarian Mountains

Re: BUG: notepad's non-working "save" after few redo/undo.

Postby kas1e » Wed Dec 05, 2018 10:25 pm

@Raziel
Try to repeat steps 6 and 7 in a loop for 10, 20 , 30 times. With different pause between pressing. Sometime its enough 2-3 repeat, sometime it can works for 20, and only then.
kas1e
Beta Tester
Beta Tester
 
Posts: 469
Joined: Sat Jun 18, 2011 8:56 am

Re: BUG: notepad's non-working "save" after few redo/undo.

Postby Raziel » Thu Dec 06, 2018 1:28 am

Now i got it, you have to be persistent with 6 and 7.

Undo, save, redo, save etc.
It normally takes 20 to 30 retries here until the save button gets greyed out, but it did show up after five and eight tries as well
No crash, nothing on serial and nothing on snoopy either.
If slaughterhouses had glass walls, everyone would be a vegetarian. ~ Sir Paul McCartney
-
Did everything just taste purple for a second? ~ Philip J. Fry
-
Ain't got no cash, ain't got no style, ladies vomit when I smile. ~ Dr. John Zoidberg
User avatar
Raziel
 
Posts: 864
Joined: Sat Jun 18, 2011 5:00 pm
Location: A haunted Castle somewhere in the Bavarian Mountains

Re: BUG: notepad's non-working "save" after few redo/undo.

Postby kas1e » Thu Dec 06, 2018 7:57 am

Yes, exactly. So its the same for 53.16 and 53.17.. And as it happens sometime after few repeats, but sometime after 20-30, it mean it can be about timing (like pause between pressing on buttons).
kas1e
Beta Tester
Beta Tester
 
Posts: 469
Joined: Sat Jun 18, 2011 8:56 am

Re: BUG: notepad's non-working "save" after few redo/undo.

Postby Amigo1 » Thu Dec 06, 2018 8:53 am

@kas1e

I can confirm that too. I run the test 8 times 4 of them slightly changing the procedure, instead of deleting the whole line, I just "undid" and "redid" the last typed
character.
What's odd, on my XE the behavior displayed after 43 cycles, on the X1000 after 34 and that 6 times in a row. But the "undo" and "redo" button where not ghosted, only the "Save" button.

And the same happens if you start the experiment the same way replace 6) and 7) with just 6a)"Undo/Redo" for about 80 times, 7)press "Save" then 8)"Undo/Redo" 5-10 times and 9)Save again.
User avatar
Amigo1
 
Posts: 182
Joined: Sun Jan 01, 2012 4:32 pm

Re: BUG: notepad's non-working "save" after few redo/undo.

Postby kas1e » Thu Dec 06, 2018 3:29 pm

@Amigo1
Will be interesting to test with different pause between pressing on buttons, like trying to wait for some time between, or doing all very fast instead: to see, if there is pattern.. At least that onlythe thing about which i can think as it semy random, and never crashes/freezes.
kas1e
Beta Tester
Beta Tester
 
Posts: 469
Joined: Sat Jun 18, 2011 8:56 am

Re: BUG: notepad's non-working "save" after few redo/undo.

Postby Raziel » Thu Dec 06, 2018 3:45 pm

kas1e wrote:@Amigo1
Will be interesting to test with different pause between pressing on buttons, like trying to wait for some time between, or doing all very fast instead: to see, if there is pattern.. At least that onlythe thing about which i can think as it semy random, and never crashes/freezes.

Probably a race condition in the gui elements
If slaughterhouses had glass walls, everyone would be a vegetarian. ~ Sir Paul McCartney
-
Did everything just taste purple for a second? ~ Philip J. Fry
-
Ain't got no cash, ain't got no style, ladies vomit when I smile. ~ Dr. John Zoidberg
User avatar
Raziel
 
Posts: 864
Joined: Sat Jun 18, 2011 5:00 pm
Location: A haunted Castle somewhere in the Bavarian Mountains


Return to General AmigaOS

Who is online

Users browsing this forum: No registered users and 6 guests