Is there a way to exit the User-Startup script?

A forum for general AmigaOS 4.x support questions that are not platform-specific

Is there a way to exit the User-Startup script?

Postby Hypex » Fri Jul 13, 2018 9:49 am

I'm slowly transferring all my applications to another system. And in the process filtering out those I need and what assigns are needed in User-Startup. I thought I would break it and continue work later.

The Quit command is used for that. However, I found that although it broke the script, it also broke the Startup-Sequence. Leaving me with a CLI window that wouldn't close and no Workbench.

I tried passing a RC of 5 with Quit but there was no difference. Is there a way to break or exit from a User-Startup script and continue the boot process? :?
User avatar
Hypex
Beta Tester
Beta Tester
 
Posts: 384
Joined: Mon Dec 20, 2010 3:23 pm
Location: Vic. Australia.

Re: Is there a way to exit the User-Startup script?

Postby nbache » Fri Jul 13, 2018 10:53 am

Hypex wrote:Is there a way to break or exit from a User-Startup script and continue the boot process? :?
One way that comes to my mind would be to create a label with Lab at the end of User-Startup and then Skip to it.

Best regards,

Niels
User avatar
nbache
Beta Tester
Beta Tester
 
Posts: 1298
Joined: Mon Dec 20, 2010 8:25 pm
Location: Copenhagen, Denmark

Re: Is there a way to exit the User-Startup script?

Postby thomasrapp » Fri Jul 13, 2018 4:27 pm

I'd also suggest the Lab / Skip solution for exiting a script.

However, for a migration job like yours I would keep the old script with another name and copy/paste only those sections which shall be executed into the real user-startup file.
User avatar
thomasrapp
 
Posts: 264
Joined: Sun Jun 19, 2011 12:22 am

Re: Is there a way to exit the User-Startup script?

Postby Amigo1 » Fri Jul 13, 2018 10:03 pm

Hypex wrote:I'm slowly transferring all my applications to another system. And in the process filtering out those I need and what assigns are needed in User-Startup. I thought I would break it and continue work later.

The Quit command is used for that. However, I found that although it broke the script, it also broke the Startup-Sequence. Leaving me with a CLI window that wouldn't close and no Workbench.

I tried passing a RC of 5 with Quit but there was no difference. Is there a way to break or exit from a User-Startup script and continue the boot process? :?


What about commenting out (with a column ";" ) the passages you do not want/need?
User avatar
Amigo1
 
Posts: 182
Joined: Sun Jan 01, 2012 4:32 pm

Re: Is there a way to exit the User-Startup script?

Postby Hypex » Sat Jul 14, 2018 5:23 am

I also could do it with a Lab and Skip, yes, but I was wondering if there was a way to do it without a work around. In all the years I've used AmigaOS I don't ever recall coming across this problem. So just thought I'd ask. :)
User avatar
Hypex
Beta Tester
Beta Tester
 
Posts: 384
Joined: Mon Dec 20, 2010 3:23 pm
Location: Vic. Australia.

Re: Is there a way to exit the User-Startup script?

Postby Hypex » Sat Jul 14, 2018 5:25 am

Amigo1 wrote:What about commenting out (with a column ";" ) the passages you do not want/need?


That's exactly how I started doing it. But when you have a hundred lines to go through, it's gets a but tedious doing semi-colon, down, left, ... ;)
User avatar
Hypex
Beta Tester
Beta Tester
 
Posts: 384
Joined: Mon Dec 20, 2010 3:23 pm
Location: Vic. Australia.


Return to General AmigaOS

Who is online

Users browsing this forum: Google [Bot] and 6 guests